Reply
Occasional Advisor
Posts: 6
0

SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hi

we are using  SFB cloud PBX.  when  the users try to sign in using  the Web sign-in feature the phone througing and error " Failed to get pair code"

 

can you please help

 

attached  the error screenshot

 

we are using the latest version 

 

UC Software Version 5.5.1.15937 Updater Version 5.7.1.17460

Polycom Employee & Community Manager
Posts: 13,737
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hello Ali,

welcome to the Polycom Community.

The community's Skype for Business FAQ contains this post here:

 

 Jan 17, 2017 Question:How can I troubleshoot simple Skype for Busines, LYNC or Office365 issues?

Resolution: Have a look => here <=

 

Most likely a firewall issue

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Occasional Advisor
Posts: 6
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

[ Edited ]

I did check the firewall and all traffic from the phones is allowed and when i monitor the traffic i could not not find any denied requests. i traced the logs from the phone as below

 

0403095048|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182d548 activeMenu 4182d548
0403095048|curl |3|00|timeout on name lookup is not supported
0403095048|app1 |1|00|AppHybridC::processEventFromUi, pAppUi->m_nBlockUICounter=0, pAppUi->pAppUi->m_bBlockUserActions=1 UI is blocked
0403095048|app1 |2|00|AppC::keyCbFunc: appKeyFunc = 65, scanCode = 62, hwId = 30.
0403095048|app1 |1|00|AppC::sendKeyToFd: qtkey=be.
0403095048|curl |3|00|About to connect() to bootstrap.pinauth.services.skypeforbusiness.com port 443 (#0)
0403095048|curl |3|00| Trying 13.92.80.132...
0403095048|curl |3|00|the local port callback returned 0
0403095048|curl |3|00|Local port: 24055
0403095048|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182d548 activeMenu 4182d548
0403095048|curl |3|00|Connected to bootstrap.pinauth.services.skypeforbusiness.com (13.92.80.132) port 443 (#0)
0403095049|curl |3|00|successfully set certificate verify locations:
0403095049|curl |3|00| CAfile: /ffs0/ca3.crt
CApath: none
0403095049|curl |3|00|SSLv3, TLS handshake, Client hello (1):
0403095049|curl |0|00|SSL DATA_OUT: Data of len 124 not displayed
0403095049|curl |3|00|SSLv3, TLS handshake, Server hello (2):
0403095049|curl |0|00|SSL DATA_IN: Data of len 81 not displayed
0403095049|curl |3|00|SSLv3, TLS handshake, CERT (11):
0403095049|curl |0|00|SSL DATA_IN: Data of len 3062 not displayed
0403095049|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182d548 activeMenu 4182d548
0403095049|curl |3|00|SSLv3, TLS handshake, Server finished (14):
0403095049|curl |0|00|SSL DATA_IN: Data of len 4 not displayed
0403095049|curl |3|00|SSLv3, TLS handshake, Client key exchange (16):
0403095049|curl |0|00|SSL DATA_OUT: Data of len 262 not displayed
0403095049|curl |3|00|SSLv3, TLS change cipher, Client hello (1):
0403095049|curl |0|00|SSL DATA_OUT: Data of len 1 not displayed
0403095049|curl |3|00|SSLv3, TLS handshake, Finished (20):
0403095049|curl |0|00|SSL DATA_OUT: Data of len 16 not displayed
0403095049|curl |3|00|SSLv3, TLS change cipher, Client hello (1):
0403095049|curl |0|00|SSL DATA_IN: Data of len 1 not displayed
0403095049|curl |3|00|SSLv3, TLS handshake, Finished (20):
0403095049|curl |0|00|SSL DATA_IN: Data of len 16 not displayed
0403095049|curl |3|00|SSL connection using AES256-SHA
0403095049|curl |3|00|Server certificate:
0403095049|curl |3|00| subject: CN=*.pinauth.services.skypeforbusiness.com
0403095049|curl |3|00| start date: 2016-05-31 20:16:53 GMT
0403095049|curl |3|00| expire date: 2018-02-28 20:16:53 GMT
0403095049|curl |3|00| issuer: C=US, ST=Washington, L=Redmond, O=Microsoft Corporation, OU=Microsoft IT, CN=Microsoft IT SSL SHA2
0403095049|curl |3|00| SSL certificate verify ok.
0403095049|curl |1|00|HEADER_OUT: GET /api/DeviceConfig/Polycom/Default?api-version=1.0 HTTP/1.1
...
0403095049|curl |1|00|HEADER_IN : HTTP/1.1 200 OK
0403095049|curl |1|00|HEADER_IN : Cache-Control: no-cache
0403095049|curl |1|00|HEADER_IN : Pragma: no-cache
0403095049|curl |1|00|HEADER_IN : Content-Type: text/xml; charset=utf-8
0403095049|curl |1|00|HEADER_IN : Expires: -1
0403095049|curl |1|00|HEADER_IN : Server: Microsoft-IIS/8.5
0403095049|curl |1|00|HEADER_IN : X-Content-Type-Options: nosniff
0403095049|curl |1|00|HEADER_IN : Strict-Transport-Security: max-age=31536000; includeSubDomains
0403095049|curl |1|00|HEADER_IN : Date: Mon, 03 Apr 2017 05:50:22 GMT
0403095049|curl |1|00|HEADER_IN : Content-Length: 610
0403095049|curl |1|00|HEADER_IN :
0403095049|curl |0|00|DATA_IN : Data of len 610 not displayed
0403095049|curl |3|00|Connection #0 to host bootstrap.pinauth.services.skypeforbusiness.com left intact
0403095049|curl |3|00|Closing connection #0
0403095049|curl |3|00|SSLv3, TLS alert, Client hello (1):
0403095049|curl |0|00|SSL DATA_OUT: Data of len 2 not displayed
0403095049|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182d548 activeMenu 4182d548
0403095049|curl |3|00|timeout on name lookup is not supported
0403095049|curl |3|00|getaddrinfo(3) failed for common:80
0403095049|curl |3|00|Couldn't resolve host 'common'
0403095049|curl |3|00|Closing connection #0
0403095049|Devic|4|00|parseAndSaveRequiredInfo: Failed to get Response for req(2)
0403095049|Devic|4|00|Response received:
0403095049|Devic|4|00|HttpRespCode [480], CurlRespCode [6]
0403095049|app1 |2|00|[CSeGetDevicePairingServiceRsp::execute] URL= , Paircode=
0403095049|app1 |3|00|[CSeGetDevicePairingServiceRsp::execute] Service is ended
0403095050|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182e798 activeMenu 4182e798
0403095050|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182e798 activeMenu 4182e798
0403095051|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182e798 activeMenu 4182e798
0403095051|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182e798 activeMenu 4182e798

 

Polycom Employee & Community Manager
Posts: 13,737
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hello Ali,

0403095049|curl |3|00|getaddrinfo(3) failed for common:80
0403095049|curl |3|00|Couldn't resolve host 'common'
0403095049|curl |3|00|Closing connection #0
0403095049|Devic|4|00|parseAndSaveRequiredInfo: Failed to get Response for req(2)
0403095049|Devic|4|00|Response received:
0403095049|Devic|4|00|HttpRespCode [480], CurlRespCode [6]

 

From the log you shared it cannot resolve an address.


Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Occasional Advisor
Posts: 6
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

if you look up the address already resolved

 

403095048|app1 |0|00| CContentInfo:: m_nTimeOut 0 ,this 4182d548 activeMenu 4182d548
0403095048|curl |3|00|Connected to bootstrap.pinauth.services.skypeforbusiness.com (13.92.80.132) port 443 (#0)
0403095049|curl |3|00|successfully set certificate verify locations:
0403095049|curl |3|00| CAfile: /ffs0/ca3.crt

 

Polycom Employee & Community Manager
Posts: 13,737
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hello Ali,

I stated it could not resolve an address but I did not state it could not resolve any address.

 

From the log snippet you posted this seems to be an firewall / routing issue.

 

The next step would be opening a ticket with support.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Polycom Employee & Community Manager
Posts: 13,737
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hello Ali,

I can replicate this in my lab.

 

Please get this escalated to we have a customer case logged against this.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Occasional Advisor
Posts: 6
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Hi

this is a MAC address  for one of the phones we have 

 

64:16:7F:A1:79:62

 

we did  open ticket with FVC but still no reply after 24 hours 

 

thanks

 

Occasional Visitor
Posts: 3
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

Yes, please update if you find any resolution, I am having the same issue, started yesterday.  Phone restarted automatically and now I cannot connect to Skype for Business, web sign in gives the same error.  I'm guessing this will be affecting a number of people today.

Occasional Advisor
Posts: 6
0

Re: SFB Cloud / VVX / Web sign-in "Failed to get pair code"

the same behavior happened with us, regarding the auto restart the cause was the update pushed from polycom and at the same time you have provisioning server with old version. the result  is upgrade/ downgrade cycle. the only work around we found is to put the latest firmware on the provisioning server.

 

for the web sign-in still i am waiting for someone from polycom to provide a solution.

 

 

regards