cancel
Showing results for 
Search instead for 
Did you mean: 

VVX310 vulnerability

Occasional Contributor

VVX310 vulnerability

Our VVX310's are running Dropbear Vulnerabilities is there a way to disable SSH in our provisioning server? We are on firmware 5.5.1.11526

 

 

Scan Information

Start time:

Thu Mar 23 10:16:53 2017

End time:

Thu Mar 23 10:17:24 2017

Host Information

IP:

  Results Summary

Critical

High

Medium

Low

Info

Total

1

0

0

0

3

4

Results Details 22/tcp  

93650 - Dropbear SSH Server < 2016.72 Multiple Vulnerabilities

[-/+]

Synopsis

The SSH service running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version in its banner, Dropbear SSH running on the remote host is prior to 2016.74. It is, therefore, affected by the following vulnerabilities :

- A format string flaw exists due to improper handling of string format specifiers (e.g., %s and %x) in usernames and host arguments. An unauthenticated, remote attacker can exploit this to execute arbitrary code with root privileges. (CVE-2016-7406)

- A flaw exists in dropbearconvert due to improper handling of specially crafted OpenSSH key files. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2016-7407)

- A flaw exists in dbclient when handling the -m or -c arguments in scripts. An unauthenticated, remote attacker can exploit this, via a specially crafted script, to execute arbitrary code. (CVE-2016-7408)

- A flaw exists in dbclient or dropbear server if they are compiled with the DEBUG_TRACE option and then run using the -v switch. A local attacker can exploit this to disclose process memory. (CVE-2016-7409)

See Also

https://matt.ucc.asn.au/dropbear/CHANGES

Solution

Upgrade to Dropbear SSH version 2016.74 or later.

Risk Factor

Critical

CVSS v3.0 Base Score

10.0 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H)

CVSS v3.0 Temporal Score

8.7 (CVSS:3.0/E:U/RL:O/RC:C)

CVSS Base Score

10.0 (CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Temporal Score

7.4 (CVSS2#E:U/RL:OF/RC:C)

References

BID

92970

BID

92972

BID

92973

BID

92974

CVE

CVE-2016-7406

CVE

CVE-2016-7407

CVE

CVE-2016-7408

CVE

CVE-2016-7409

XREF

OSVDB:142291

XREF

OSVDB:142292

XREF

OSVDB:142293

XREF

OSVDB:142294

Plugin Information:

Publication date: 2016/09/22, Modification date: 2016/12/06

Ports tcp/22


Version source : SSH-2.0-dropbear_0.51
Installed version : 0.51
Fixed version : 2016.74

Message 1 of 4
3 REPLIES
Highlighted
Polycom Employee & Community Manager

Re: VVX310 vulnerability

Hello technicholas,

welcome back to the Polycom Community.

I believe we are already looking into this and will correct this in a future version.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 2 of 4
Occasional Visitor

Re: VVX310 vulnerability

Anyone know the latest version suportted on VVX-300s without the vunerability? 

Message 3 of 4
Polycom Employee & Community Manager

Re: VVX310 vulnerability

Hello ,

welcome to the Polycom Community.

UC Software 5.4.6 is later than 5.5.1 but I assume only later releases will have this fix. I suggest to check the release notes.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 4 of 4