Reply
Occasional Contributor
Posts: 6
0

IP650 not honoring daylight saving?

[ Edited ]

I have a set of IP650 here  (running 4.0.11.0583) , and daylight saving time arrived and it didn't switch this year (even though I've not had a problem in previous years). Any ideas as to why it didn't/won't switch (even a reboot won't show the right time)?

 

Relevant phone.cfg:

	<DEVICE_SETTINGS
		device.sntp.serverName="pool.ntp.org"
		device.sntp.gmtOffset="-28800"
		device.auth.localAdminPassword.set="1"
		device.auth.localAdminPassword=""
	/>
	<SNTP
		tcpIpApp.sntp.resyncPeriod="86400"
		tcpIpApp.sntp.address="198.202.199.1"
		tcpIpApp.sntp.gmtOffset.overrideDHCP="0"
		tcpIpApp.sntp.gmtOffset="-28800"
		tcpIpApp.sntp.daylightSavings.enable="1"
		tcpIpApp.sntp.daylightSavings.fixedDayEnable="0"
		tcpIpApp.sntp.daylightSavings.start.month="3"
		tcpIpApp.sntp.daylightSavings.start.date="13"
		tcpIpApp.sntp.daylightSavings.start.time="2"
		tcpIpApp.sntp.daylightSavings.start.dayOfWeek="1"
		tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth="0"
		tcpIpApp.sntp.daylightSavings.stop.month="11"
		tcpIpApp.sntp.daylightSavings.stop.date="6"
		tcpIpApp.sntp.daylightSavings.stop.time="2"
		tcpIpApp.sntp.daylightSavings.stop.dayOfWeek="0"
		tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth="0"
	/>

 

Polycom Employee & Community Manager
Posts: 12,491
0

Re: IP650 not honoring daylight saving?

Hello matthewk4,

welcome back to the Polycom Community.

Your Device section is missing a device.set="1" or the parameters are simply ignored. In addition we need to see a backup of your config and not what you assume it is loading.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Occasional Contributor
Posts: 6
0

Re: IP650 not honoring daylight saving?

Updated to add device.set="1" like so:

	<DEVICE_SETTINGS
		device.set="1"
		device.sntp.serverName="pool.ntp.org"
		device.sntp.gmtOffset="-28800"
		device.auth.localAdminPassword.set="1"
		device.auth.localAdminPassword=""
	/>
	<SNTP
		tcpIpApp.sntp.resyncPeriod="86400"
		tcpIpApp.sntp.address="198.202.199.1"
		tcpIpApp.sntp.gmtOffset.overrideDHCP="0"
		tcpIpApp.sntp.gmtOffset="-28800"
		tcpIpApp.sntp.daylightSavings.enable="1"
		tcpIpApp.sntp.daylightSavings.fixedDayEnable="0"
		tcpIpApp.sntp.daylightSavings.start.month="3"
		tcpIpApp.sntp.daylightSavings.start.date="13"
		tcpIpApp.sntp.daylightSavings.start.time="2"
		tcpIpApp.sntp.daylightSavings.start.dayOfWeek="1"
		tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth="0"
		tcpIpApp.sntp.daylightSavings.stop.month="11"
		tcpIpApp.sntp.daylightSavings.stop.date="6"
		tcpIpApp.sntp.daylightSavings.stop.time="2"
		tcpIpApp.sntp.daylightSavings.stop.dayOfWeek="0"
		tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth="0"
	/>

The exported config from the phone is:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Mink 4.0.11.0583 21-Jun-16 16:56 -->
<!-- Created 14-03-2017 08:45 -->
<PHONE_CONFIG>
	<!-- Note: The following parameters have been excluded from the export:
		reg.1.auth.password=""
		reg.2.auth.password=""
		reg.3.auth.password=""
	-->
	<ALL
		attendant.behaviors.display.spontaneousCallAppearances.automata="1"
		attendant.behaviors.display.spontaneousCallAppearances.normal="0"
		device.auth.localAdminPassword.set="1"
		device.set="1"
		device.sntp.gmtOffset="-28800"
		device.sntp.serverName="pool.ntp.org"
		dialplan.digitmap="[2-9]11|0x.T|1[0-1]x|1[2-9]xxxxxxxxx|[2-9]xxxxxx"
		feature.enhancedFeatureKeys.enabled="1"
		ptt.pageMode.displayName="Matthew Office"
		ptt.pageMode.enable="1"
		softkey.feature.forward="0"
		softkey.feature.newcall="0"
		tcpIpApp.sntp.address="198.202.199.1"
		tcpIpApp.sntp.daylightSavings.start.date="13"
		tcpIpApp.sntp.daylightSavings.stop.date="6"
		tcpIpApp.sntp.gmtOffset="-28800"
		voice.volume.persist.handset="1"
		voIpProt.SIP.specialEvent.checkSync.alwaysReboot="1"
		reg.1.address="96771"
		reg.2.address="93435"
		reg.3.address="100"
		reg.1.auth.userId="96771"
		reg.2.auth.userId="93435"
		reg.3.auth.userId="100"
		reg.1.displayName="6771-Matthew Office"
		reg.2.displayName="3435-Matthew Office"
		reg.3.displayName="100-Matthew Office"
		reg.1.label="426-6771"
		reg.2.label="469-3435"
		reg.3.label="100"
		reg.1.lineKeys="2"
		reg.2.lineKeys="2"
		reg.3.lineKeys="2"
		reg.1.outboundProxy.port="5060"
		reg.2.outboundProxy.port="5060"
		reg.3.outboundProxy.port="5060"
		reg.1.outboundProxy.transport="TCPOnly"
		reg.2.outboundProxy.transport="TCPOnly"
		reg.3.outboundProxy.transport="TCPOnly"
		reg.1.ringType="2"
		reg.2.ringType="4"
		reg.3.ringType="7"
		reg.1.type="shared"
		reg.2.type="shared"
		softkey.1.action="$FPage$$FPage$"
		softkey.2.action="$FPage$$FPage$"
		softkey.1.enable="1"
		softkey.2.enable="1"
		softkey.1.insert="2"
		softkey.1.label="Page"
		softkey.2.label="Page"
		softkey.1.use.dialtone="1"
		softkey.2.use.hold="1"
		reg.1.server.1.address="10.10.155.8"
		reg.2.server.1.address="10.10.155.8"
		reg.3.server.1.address="10.10.155.8"
		reg.1.server.1.expires="80"
		reg.2.server.1.expires="80"
		reg.3.server.1.expires="80"
		reg.1.server.1.transport="TCPOnly"
		reg.2.server.1.transport="TCPOnly"
		reg.3.server.1.transport="TCPOnly"
	/>
</PHONE_CONFIG>

Still showing standard time.

 

Highlighted
Occasional Contributor
Posts: 6
0

Re: IP650 not honoring daylight saving?

It appears that removing these two:

		tcpIpApp.sntp.daylightSavings.start.date="13"
		tcpIpApp.sntp.daylightSavings.stop.date="6"

fixes the problem... somehow having both a start day of week and a specific date is causing neither to have effect?