Plantronics + Polycom. Now together as Poly Logo

How to use XML API of RMX Manager

Occasional Contributor

How to use XML API of RMX Manager

Hi all,

I intend to use XML API to communicate with MCU.

I use Postman to send request

The LOGIN action seem works well, but other commands always return "User not found" with id 65561

So, did I miss anything?

Or what is solution for this

Thank you

Message 1 of 4
3 REPLIES 3
Highlighted
Occasional Contributor

Re: How to use XML API of RMX Manager

This is my full response I got

<RESPONSE_GENERAL>
<RETURN_STATUS>
<ID>65561</ID>
<DESCRIPTION>User not found</DESCRIPTION>
<YOUR_TOKEN1>-1</YOUR_TOKEN1>
<YOUR_TOKEN2>-1</YOUR_TOKEN2>
<MESSAGE_ID>-1</MESSAGE_ID>
</RETURN_STATUS>
<ACTION_TYPE>set_request</ACTION_TYPE>
</RESPONSE_GENERAL>
Message 2 of 4
Visitor

Re: How to use XML API of RMX Manager

Hello

I ha ve the same problem . The login request return XML string with MCU_TOKEN and MCU_USER_TOKEN . And when i wan to use it for next request ( for example a <GET_STATE/> to get a keealive ) , the MCU return :

 

["ID"]=> string(5) "65561"

["DESCRIPTION"]=> string(14) "User not found"

["YOUR_TOKEN1"]=> string(1) "2"

["YOUR_TOKEN2"]=> string(1) "2"

["MESSAGE_ID"]=> string(2) "-1" 

["ACTION_TYPE"]=> string(11) "get_request" 

 

I see in release note for 8.4.2.

"BRIDGE16350
General Rest API: Failed to get Time from MCU due to (65611) Internal
communication error / (-1) Empty Response Arrived / (65561) User not
found.
V8.4.2

"

by i am in version 8.8.1.2157

 

have you a idea for resolve this problem ?

( User account define in MCU , Coding or Param for Protocol XML , etc ... )

 

Thks.

Message 3 of 4
Visitor

Re: How to use XML API of RMX Manager

when i add in the header  ( "Connection: Keep-Alive\r\n" ) , i see now my session with my account in the Manager.

But the next "Post" end in timeout.

 

thks.

Message 4 of 4