Plantronics + Polycom. Now together as Poly Logo

Is Remote-Party-ID supported on KWS6000 with 4020 and 5020 handsets

Highlighted
Occasional Advisor

Is Remote-Party-ID supported on KWS6000 with 4020 and 5020 handsets

Is Remote-Party-ID supported on KWS600 with 4020 and 5020 handsets. I am using Asterisk 1.8. Remote-Party-ID is working on my IP650 and IP550s but not on the 4020 and 5020 handsets.

 

EDIT BY MOD: Change to the correct KWS Model

Message 1 of 4
3 REPLIES 3
Highlighted
Polycom Employee & Community Manager

Re: Is Remote-Party-ID supportd on KWS600 with 4020 and 5020 handsets

Hello Alan,

 

welcome to the Polycom Community.

 

  • Is this a KWs600v3 or a KWS6000?
  • What Software Version are these Units on?

The KWS6000 had the following added/changed in PCS08:

 

Handset display handling during SIP calls has been improved with respect to displaying other party username and display name.
P-Asserted-Identity or Remote-Party-ID, INVITE and INVITE responses are used to update the handset display with other party username and display name. Specifically, this makes the handset update the display correctly during call transfer and call forwarding on several SIP servers including Cisco Unified Call Manager. Furthermore, this makes the display name of the other party update correctly in connection with group call pickup on a 3CX PBX.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 4
Highlighted
Occasional Advisor

Re: Is Remote-Party-ID supportd on KWS600 with 4020 and 5020 handsets

Steffen It is a KWS6000. It is a new install, about 1 month old but I do not recall the firmware version. I will be on site today and will check. I think it is PCS08, but I am not positive. I can upgrade to PCS09 today if needed.
Message 3 of 4
Highlighted
Polycom Employee & Community Manager

Re: Is Remote-Party-ID supported on KWS6000 with 4020 and 5020 handsets

Hello Alan,

 

PCS10 is the latest release to my Knowledge and I do not think it depends on the Software Version of the Handset's.

 

Please work with Polycom Support if you run into any issues and take a trace via the KWS6000 to capture the issue and provide Support with the reproduction Steps.

 

Best regards

 

Steffen Baier

 

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 4