Plantronics + Polycom. Now together as Poly Logo

Problems with DECT handset update

Valued Contributor

Problems with DECT handset update


I have a system here with a KWS300 and three 5040 handsets.  Two of them are brand new, with firmware 13Aa, and the third is older with firmware 13Va.  I'd like to update the older unit.  I have downloaded the "Simple Loader 50xx" and it connects to my USB charger station just fine.  When I try to update, the instructionsa are to to turn off the unit first, click OK and then turn on the unit while holding down the "on" button.  The unit will turn on just fine if it is not cradled in the charger, but will not turn on at all if cradled.  I had this problem before but I cannot remember what I did to get around it.  Trying to turn on the unit (and holding down the on button) while out of the charger and then placing it in the charger (still with the button depressed) does not work.  As long as the unit is cradled it refuses to come on.

I've tried the web Handset Updater but there is some problem with that as well; I just get a blank grey area on the screen where the instructions normall are and no response at all even after waiting.

Any suggestions?



Message 1 of 7
Valued Contributor

Re: Problems with DECT handset update

Followup to above:  I forgot to write that with the KIRK Handset Software Updater, I get the error message:

"Cannot find cached resource for URL:"

Message 2 of 7
Polycom Employee & Community Manager

Re: Problems with DECT handset update

Hello Richs,
Please be aware of the recent change outlined => here <=


SpectraLink KIRK is no longer a part of the Polycom brand.


You should contact SpectraLink KIRK directly.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 3 of 7
Frequent Advisor

Re: Problems with DECT handset update

HI Richs


When you use the Simple loader when it tells you to switch off the handset - do this out of the charger


Then place it back in the charger - click ok


Then when it says "press and hold the ON key" do so with it in the charger - it will not turn on keep holding


Click ok to the message and it should load the fw - keep holding till it ends


Its a kind of vulcan firmware death grip!



ICON - UK SpectraLink Wireless Distributor
Message 4 of 7
Valued Contributor

Re: Problems with DECT handset update

Thanks, David.  I tried this also but the load returns the message "Download Failed!  Exception" with no further explanation.

Message 5 of 7
Frequent Advisor

Re: Problems with DECT handset update

Something odd is happening with this process.


I suggest you raise this with your reseller who should be able to help you with this directly.


If they can't help contact spectralink support or local distributor. 




ICON - UK SpectraLink Wireless Distributor
Message 6 of 7
Valued Contributor

Re: Problems with DECT handset update

Hello all,

For some reason the problem resolved itself when I rebooted my computer a second time, and I was able to use both the online updater and the simple loader without difficulties.  I have no explanation for this.  I ran into a separate problem but I'll raise that in a different thread.

Thanks for all your help


Message 7 of 7