Plantronics + Polycom. Now together as Poly Logo

CMA DNS SRV Record

SOLVED
Advisor

CMA DNS SRV Record

I'm trying to get auto discovery working for CMA, but I'm getting stuck in a "Unable to connect to the provisioning server" message. I run Wireshark and see the request from my computer to the DNS asking "Standard query SRV _cmaconfig._tcp", but the DNS responds with "no such name".

 

Attached is a screen cap of how my DNS admin configured the service. The text in the admin guide says I should have something like this: "__cmaconfig._tcp.wvus.org 86400 IN SRV 0 0 443 vtc.wvus.org". 

 

Any hints where i messed up? 

Message 1 of 7
1 ACCEPTED SOLUTION

Accepted Solutions
Polycom Employee & Community Manager

Re: CMA DNS SRV Record

Hello NoSatrun,

 

welcome to the Polycom community.

 

It looks like you are using two __ lines rather than just one _

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 7
6 REPLIES 6
Polycom Employee & Community Manager

Re: CMA DNS SRV Record

Hello NoSatrun,

 

welcome to the Polycom community.

 

It looks like you are using two __ lines rather than just one _

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 7
Advisor

Re: CMA DNS SRV Record

Thanks Steffen. I followed the CMA doc with a copy and paste :)

 

 

I removed the extra "_" but find the same thing. Attached is the wireshark of the two marked frames. It is starting to look to me like the DNS is checking an external name server for this. 

 

Am I right? if so, what do I tell my DNS admin? If not, ?

Message 3 of 7
Polycom Employee

Re: CMA DNS SRV Record

You are right, the dns lookup is going to the root DNS servers:

 

_cmaconfig._tcp..!............@.a.root-servers.net..nstld.verisign-grs.com

 

Your domain name is missing from the service lookups. I would check to see if the PC is part of a domain or not. You can also look the TCP/IP properties of the network connection you are using. There is a DNS tab which has some options about adding a suffix (aka you domain name). I would try this first and repeat your tests.

 

S.

Message 4 of 7
Advisor

Re: CMA DNS SRV Record

gaaaaaaaaa

 

yeah, my test bot was not on the domain. tried it from my box and it works. 

 

Thanks!

Message 5 of 7

Re: CMA DNS SRV Record

Hi Steffen,

 

I am having this same issue. I have deployed two CMA4000 servers, and the CMA desktop clients cannot Auto Register with any of the CMA Servers. This is after creating a DNS Service Entry for them. The string we used is this:

 

__cmaconfig._tcp.nlng.net 86400 IN SRV 0 0 443 NLNGVCCMA001.nlng.net

 

where NLNGVCCMA001 is the server's DNS name.

 

Is there any issue with the string?

 

Kindly assist.

 

Best Regards

Ismail

 

 

Message 6 of 7
Polycom Employee & Community Manager

Re: CMA DNS SRV Record

Hello Ismail,

See my original reply to the topic starter.

Two __ underscore instead of _ one.

Best regards

Steffen Baier
----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 7