Plantronics + Polycom. Now together as Poly Logo

CCX400/500 Teams Device Lock

SOLVED
KyleAtSchool
Occasional Visitor

CCX400/500 Teams Device Lock

We just bought a handful of CCX 400 and CCX 500 phones to test. We have them in Teams base profile, running software version 10.0.02535.

 

I created a configuration profile in the Teams Admin Center that changes the admin password and also enables Device Lock, with a 30-second timeout. I deployed the config to the phone, and confirmed that it received the new config by testing the new admin password. However, the phone never locks. 

I downloaded the device logs from the Teams Admin Center and found the following lines that looks relevant:

0211133558|apps |5|00|cfgParamAndroidSetPartnerConfig: Unknown parameter "Settings.System.SCREEN_OFF_TIMEOUT" val "900000"
...
...
0211133820|apps |5|00|cfgParamAndroidCommTask: Unknown parameter "Settings.System.SCREEN_OFF_TIMEOUT" val "30000"

 

I know that the Teams app on the phone is provided/supported by Microsoft so I'll open a ticket with them too, just thought I'd ask here if anyone else is using the device lock feature successfully?

 

I can post the full log if required, I just wasn't sure if I need to remove any identifiable information from it.

Message 1 of 11
1 ACCEPTED SOLUTION

Accepted Solutions
jschertz
Polycom Employee

Re: CCX400/500 Teams Device Lock

Device Lock is not currently supported on the Teams IP Phones and has been disabled in recent builds.  Some additional fixes are required in the Android client before this feature can be supported.

-----------
Jeff Schertz - Principal Microsoft Solutions Architect [Blog]

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.

View solution in original post

Message 2 of 11
10 REPLIES 10
jschertz
Polycom Employee

Re: CCX400/500 Teams Device Lock

Device Lock is not currently supported on the Teams IP Phones and has been disabled in recent builds.  Some additional fixes are required in the Android client before this feature can be supported.

-----------
Jeff Schertz - Principal Microsoft Solutions Architect [Blog]

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.

View solution in original post

Message 2 of 11
KyleAtSchool
Occasional Visitor

Re: CCX400/500 Teams Device Lock

Thanks Jeff, not what I was hoping but kind of expected.

 

By the way, I love your blog! We've been very slowly rolling out S4B and now Teams over the last year, and just about every time we've had a problem I've ended up finding the solution there.

Message 3 of 11
jjvitales
Occasional Visitor

Re: CCX400/500 Teams Device Lock

Is there a timeline on when this feature will be supported on the CCX 400/500 Teams profile?

Message 4 of 11
PASSR
Advisor

Re: CCX400/500 Teams Device Lock

We've also purchased a few 400/500/600s to test for a gradual replacement of our fleet of VVX 411s.  I also tried using the lock code in Teams Admin config with the same result.  Bear with me here...   Our setup: We're using Teams, users are all Teams only with O365.  We're just beginning to work with Intune and I noticed during initial boot that these phones prompted to install a secure certificate for the company portal but there's no obvious prompt to tap like "install" on the screen.  The prompt stays on the screen for maybe 3 seconds before disappearing.  If I do nothing the phones show up as Android Devices in MS Endpoint Manager and under Device Configuration show error for Android Device Certificate.  

On the next boot I found that if I tap the certificate message, it takes me to an accept and install prompt and requires that I create a 4-digit PIN or 6-digit lock code.  Once I do this, the phone shows Succeeded in MS EM.

So very long story but if you have Intune (MEM or whatever MS is calling it this week), you can manage the lock code from there.  In my testing, it works as designed.  Now if I can just figure out if/how to turn it off in MEM...

Message 5 of 11
MacEdwards
Occasional Visitor

Re: CCX400/500 Teams Device Lock

We also need an update on this.  RPRM loses a lot of its values if we can't use it to push required configurations. 

Message 6 of 11
SteffenBaierUK
Polycom Employee & Community Manager

Re: CCX400/500 Teams Device Lock

Helo @MacEdwards 

 

ensure to use:

<web prov.startupCheck.enabled="1"/>

to be added to the configuration from 1st boot-up or the device never looks for a provisioning server when in Teams mode.

 

Best regards

 

Steffen Baier 

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 11
sl12
Occasional Visitor

Re: CCX400/500 Teams Device Lock

Hi,

We are currently testing different Teams handsets for a roll out to our staff. We can't get device lock (via configuration profile) to work on the CCX400 and CCX500. We also cannot get the CCX500 to lock/unlock via Better Together with a Win10 device.

 

We are also testing some AudioCodes phones and I can confirm that the device lock and Better Together functionality both work as expected on an AudioCodes C470HD running the same version of the Teams Admin Agent (1.0.0.202103160138), the Company Portal App (5.0.5088.0) and the Teams App (1449/1.0.94.2021052803). As such it would seem that the issue is not related to Microsoft but related to the Polycom software of the phone.

 

Would someone from Polycom be able to provide an update as to when the device lock and better together functionality is expected to work on CCX phones?
Thanks,
Sander

Message 8 of 11
SteffenBaierUK
Polycom Employee & Community Manager

Re: CCX400/500 Teams Device Lock

Hello @sl12 ,

 

Welcome to the Poly Community. Your post ended up in the spam filter and had to be moved to the right section.

 

Whilst it is good info what the different Microsoft Applications are running on the phone the most important is the Poly UC Software.

 

Better together is working as far as I am aware as long as:

 

  • Enable Bluetooth in the device settings.

  • Enable phone lock in the device

 

If you still have an issue please work with our support team ensuring you use the current latest certified software UC Software 7.0.3 Rev C and ensure the latest TAC update is applied.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 11
sl12
Occasional Visitor

Re: CCX400/500 Teams Device Lock

Hi Steffen,

The phone is running UCS 7.0.3.0515 and no further updates are available from the TAC (screenshot attached). Note that Bluetooth is enabled and the phone is connected to the laptop using the connect to device feature (screenshot attached). The phone is also set up to auto lock with a 6 digit pin. It won't lock at all.

 

When I lock my Win10 laptop typically nothing happens to the phone. Very rarely the phone screen goes black when I lock my Win10 laptop. When I touch the screen of the phone it's clear that it's not locked.

 

How do I contact your pre-sales support team? Can you share their contact details?

Thanks,
Sander