Plantronics + Polycom. Now together as Poly Logo

CCX500 DHCP issue

Highlighted
Occasional Visitor

CCX500 DHCP issue

Hello, We are starting to deploy Poly CCX500 and CCX600 phones, however when they are connected to our work network they are unable to to connect to teams or the company portal, unless we manually configure the IP addressing info. Having done some digging in the logs it appears that they are not correctly interpreting the Subnet mask they receive from our DHCP server. LLDP is disabled as it is used for our legacy phone infrastructure.

 

Below is some snippets of the log file where the device

-CUT-

000019.450|cfg |*|00|RT| Phone IP address is 10.111.101.26.
000019.450|cfg |*|00|RT| Subnet mask is 49.65.80.67.
000019.450|cfg |*|00|RT| Gateway address is 10.111.100.1.
-CUT-
000047.419|cfg |*|00|RT| DNS server is 10.100.144.25.
000047.419|cfg |*|00|RT| DNS alternate server is 10.100.144.26.
000047.419|cfg |*|00|RT| DNS domain is -CUT-.
000047.423|cfg |*|00|RT| Time server is time.windows.com.
000047.434|dns |*|00|DNS resolver servers are '10.100.144.25' '10.100.144.26'
000047.434|dns |*|00|DNS resolver search domain is '-CUT-'
000047.442|cfg |4|00|RT|cfgOsUpdateDns: fails to write to /etc/resolv.conf
000047.457|cfg |*|00|RT|Primary IP: 10.111.101.26 subnet mask 255.0.0.0
000047.457|so |*|00|soNetworkStateSend: primaryNetworkIPChanged:1, primaryNetworkUp:1
000047.458|so |*|00|soNetworkStateSend: primaryNetworkIPChanged:0, primaryNetworkUp:1
000047.474|so |*|00|Network initialisation is complete, continue with network tasks.

-CUT-

 

From what i understand of this log, the phone recieves a valid IP address from the server, a Valid gateway, valid DNS servers, and a valid domain name. However initially it displays a subnet mask of '49.65.80.67', then further down it states that the subnet mask is '255.0.0.0', the actual subnet mask for this subnet is '255.255.254.0'. This issue persists regardless of if we are using the latest firmware published to the teams admin center, or the latest firmware we can update to from the web interface within the device, and is displayed across every CCX500 we have attempted to deploy so far (5). Any assistance with this would be appreciated. No other devices connected to this subnet have ever displayed this issue. I've also included a screenshot of our DHCP server info and configured options.

 

 

4 REPLIES 4
Highlighted
Frequent Advisor

Re: CCX500 DHCP issue

Hi

 

It seems like a thing definitely worth opening a service request at Poly.

BTW. Shouldn't there be option 1 for subnet mask? Or you just didn't show it on screenshot? 255.0.0.0 is default mask for private IP subnet class A.

 

Cheers

Message 2 of 5
Highlighted
Polycom Employee & Community Manager

Re: CCX500 DHCP issue

Hello @MRTVSD ,

 

Welcome to the Poly Community.

I do agree with @LKVer as it seems we interpret potentially your Option 43 falsely as the Subnet.

 

Poly phones have the most versatile network abilities so we can interpret any received DHCP options to gather for example a Subnet.

 

I recommend the below FAQ post to understand this as a DHCP Vendor option should not be a global value and should rather be for a specific device(s):

 

Aug 24, 2015 Question:What basic network data is sent and received by a Poly phone?

Resolution: Please check this post => here <=

 

The section "Additional DHCP Option 43 Configuration Options" is what I suggest to look at.

 

The next step would be opening a ticket.


In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 5
Highlighted
Occasional Visitor

Re: CCX500 DHCP issue

Option 1 is configured when you create the scope on windows DHCP and is not listed as a individual option.

 

The option 43 info we have applied is allowing APC upses we have deployed throughout the building to receive DHCP addresses. Since the units are deployed throughout the building across many subnets, we have the scope option applied globally.

 

We contacted our vendor and they are working on opening a case with support.

Highlighted
Polycom Employee & Community Manager

Re: CCX500 DHCP issue

Hello @MRTVSD 

 

please share the Poly ticket reference once you receive this via your reseller.

 

I suggest you use a separate Vendor Option as described below:

 

Sep 13, 2016 Question: Do Poly Phones support the DHCP Option 60 Vendor Data Format?

Resolution: Please check => here <=

 

If this fails or anything else the reseller needs to provide Logs >here< and a Wireshark from a spanned/mirrored port.

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Tags (1)
Message 5 of 5