Plantronics + Polycom. Now together as Poly Logo

Devices Showing Offline In Teams Admin Center

CBTECH
Occasional Advisor

Devices Showing Offline In Teams Admin Center

So, nothing has changed on our side and we've started seeing about half of our devices showing 'Offline' in the teams admin center.  

 

Our devices are either on 7.0.2 or 7.0.3B, both are having the same issue and a couple more devices show offline each day.

 

The devices work just fine they just show as offline in the admin center which of course would make it harder to do a firmware update if needed.

 

Microsoft support has of course been useless, they have us factory reset the the devices and login again, but we've had the devices go offline again after that.

 

Any ideas anyone?

Message 1 of 7
6 REPLIES 6
leomezza
Polycom Employee

Re: Devices Showing Offline In Teams Admin Center

Please reach out to Microsoft support again and ask them to review case 27008398, there is a known Microsoft issue in the Admin Agent component running in the phone causing this issue.

Regards,
Leonardo Mezzanotti
Message 2 of 7
CBTECH
Occasional Advisor

Re: Devices Showing Offline In Teams Admin Center

Thank You!!  This is very helpful.

Message 3 of 7
steeps
Advisor

Re: Devices Showing Offline In Teams Admin Center

I'm having the same issue. 

 

Deskphones aren't working and are showing as Offline in admin centre.

 

I spoke with Microsoft support who said it was a phone issue and to update firmware... hard to do when phones can't connect!  I referred them to this thread and the case number you mentioned -- the agent told me they couldn't access the case as it's not associated with me and my account.

 

Is there any more information you can give on the specific issue so that we can guide support agents in the right direction?

 

(EDIT: I was using a device without the web server enabled... ignore the next paragraph, that I'm leaving for posterity's sake!)  I've also tried connecting directly to the web interface using the phone's IP address, but am getting an error that the site "refused to connect."  I can ping the device's IP, so it is connected to the network.  I'm not sure where that issue is rooted!

Message 4 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices Showing Offline In Teams Admin Center

Hello @steeps ,

 

Welcome back to the Poly Community.


The ticket reference share by my colleague should enable the Microsoft agent to access the other case and see that the issue described could be the same and therefore start working on the case.

 

Please do not let our Partner Microsoft tell you otherwise and they should look into this.

 

In regards to the Web Interface please see this from our FAQ:

 

Apr 1, 2020 Question: How can I enable the Web Interface on a Poly phone running in Teams mode?

Resolution: Please check >here<

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 7
steeps
Advisor

Re: Devices Showing Offline In Teams Admin Center

"should" is a key word!

 

The support representative had to escalate to a team technical lead to view the ticket.  And wait for that lead to view and pass the summary to the support representative, rather than granting that representative access.


I was told it doesn't apply as the ticket is for a different model number Poly device...

 

While I'm still without understanding from Microsoft as to how this issue could spontaneously affect all our devices and cripple our phone system, I am able to manually fix it one device at a time:

 

  1. Enable web server and log into device directly
  2. Upgrade to latest firmware from Poly server (which is higher version number than that available through Teams Admin centre)
  3. On the deskphone, log out of whatever user profile is logged in and log back in with a DIFFERENT user profile
  4. Teams Admin centre now sees the device but notifies it has the wrong Teams App and firmware versions installed.  Push the "update" (aka: downgrade) from Admin centre to the device
  5. When device finally updates and restarts, log back in as the actual user for the device

 

It's obviously untenable to manually run that process for every single device, especially if this problem reoccurs.  I will tell the support representative at Microsoft, again, that they need to review the referenced ticket!

Message 6 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Devices Showing Offline In Teams Admin Center

Hello @steeps ,

 

I would suggest you ensure you install an FTP or at least HTTP server in your network and set up both DHCP option 161 and option 160 or just option 66.

 

Then follow this:

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

and check this:

 

Aug 27, 2021 Question: Why do I not see the different Base Profile modes offered when factory resetting /OOB / Out Of Box wizard a Poly device?

Resolution: Please check => here <=

 

This should enable you to factory reset the devices during booting up:

 

Oct 10, 2011 Question: How can I reset / Factory default my Phones configuration?

Resolution: Please check => here <=

 

They would then pick up the DHCP Options and apply the configuration and have the Web Interface enabled, EULA accepted, Time Server and the language set and also have the screen capture enabled.

 

This way you could even remotely (within the time period allowed) get the sign-in code and sign the phone in remotely

 

Oct 17, 2011 Question: How can I create a Screen Capture of the phone GUI?

Resolution: Please check => here <=

 

Meanwhile our Partner Microsoft can most certainly look at the logs that they can get of the TAC to the point when the phone is no longer online.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 7