Plantronics + Polycom. Now together as Poly Logo

Microsoft Teams Device Sign-in Method (Code) Not Working

Satori
Occasional Advisor

Microsoft Teams Device Sign-in Method (Code) Not Working

Hello,

 

In a recent firmware update we noticed that there is a new default sign in method on the Poly CCX600 phones in which utilizes device login in which you can use a sign utilizing code on your computer to authenticate enroll the phone into Microsoft Teams by going to microsoft.com/devicelogin.

 

We have attempted to use this feature on several phones and accounts all of which have been unsuccessful in signing into Microsoft Teams.  Once you enter the code in on your computer the phone begins to enroll into Company Portal, followed by it displaying a banner saying Active Directory, and then immediately comes back to the sign in page again, prompting for a new code. Signing in again with the code, repeats the cycle.

 

I also noticed that if you click on the Teams button (on the side of the phone) it appears that phone signed in as your phone number appears in the upper right corner, however your picture, calendar, voicemail, etc. are all missing and dialing is not functional.  You are also not able to sign out of the phone either, even when you click sign out.  The phone indicates that it signed out, but clicking the Teams button again brings you back to your phone number. Rebooting the phone and clicking the Teams button (bypassing the sign in code page) takes you back as if you are signed in already.  Only a factory reset clears this behavior.

 

I don't see any Interrupted or Failed sign ins in Azure AD, in-fact it all looks successful.  Is anyone else having this issue or thoughts on how to diagnose it?  Below are the software builds on the phone.

 

Teams Admin Agent

1.0.0.202101280722.product
 
Firmware
7.0.3.0228
 
Company Portal App
5.0.5045.0
 
OEM Agent App
1.0.21
 
Teams App
1449/1.0.94.2021033002
 
Jason B.
Message 1 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Hello @Satori ,

 

Welcome back to the Poly Community.


Just as a reminder, the Microsoft Teams Application is provided by our Partner Microsoft so the easiest and best way to get support is to work with our Partner Microsoft.

 

There are several applications working together when signing into Microsoft Teams so they control the troubleshooting side of this.

 

You can ask members of the Poly community for their experience with this but the support should come from Microsoft.

 

Please remember to update the post here once you get a reply or a solution.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
rgsteele
Valued Contributor

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Hi Satori,

 

There was an authentication bug in the version of the Teams app that is installed with the 7.0.3.0228 firmware (1449/1.0.94.2021022403). I see from the version info you posted that the update resolving this issue (1449/1.0.94.2021033002) is installed, but have you ensured this is the case for all your phones, particularly the ones affected by the issue?

 

Another thing to check: if you have Conditional Access policies enabled in your Azure AD tenant that apply to Teams, the phones need to be enrolled with Intune and compliant with your policies. See this article for more info on that: Deploy Teams phones and Teams displays using Intune - Microsoft Teams | Microsoft Docs

Message 3 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Hello @rgsteele  and @Satori 

 

our partner Microsoft delivered to us for the 7.0.2 UC software release the 1449/1.0.94.2021022403 Microsoft Teams App APK.

 

Via the Microsoft TAC 1449/1.0.94.2021022403 can be upgraded to 1449/1.0.94.2021033002.

 

The UC Software 7.0.3 still includes 1449/1.0.94.2021022403.

 

There seem to be other people having the same issue as reported >here<

 

Best Regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Hello @rgsteele  and @Satori 

 

It seems Microsoft has fixed this from reports that I have heard in the latest 7.0.3 released today >here<


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 7
Rial_Coleman_DC_Water
Occasional Visitor

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Do the phones still need to register with Intune once the new version is installed?  

Message 6 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Microsoft Teams Device Sign-in Method (Code) Not Working

Hello @Rial_Coleman_DC_Water ,

 

Welcome to the Poly Community.


I am unaware of any changes to the sign-in method and would suggest you ask this question within a Microsoft community.


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 7