Plantronics + Polycom. Now together as Poly Logo

Trio 8800 Stuck on Black screen after factory Reset

Rolof van den Hof
Occasional Visitor

Trio 8800 Stuck on Black screen after factory Reset

Hi,

 

I've got a Polycom Trio 8800 that has a black screen with only the 'home' and 'back' button available at the bottom of the screen. 

After a couple of minutes (about 5 minutes) the phone also reboots on it's own.

 

I am able to restore the factory defaults, but upgrading a firmware version via USB does not succeed. 

In fact, there doesn't seem to be any power on the USB device.

 

Is there a way to restore the firmware or get the phone back to life again?

The phone doesn't seem to be fully dead (yet)  

 

Best regards,

Rolof van den Hof

 

7 REPLIES 7
Long Hoang
Advisor

Re: Trio 8800 Stuck on Black screen after factory Reset

Hi,

How did you "Factory Reset"?

You can get some method to "Factory Reset" here:

https://knowledgebase-iframe.polycom.com/kb/viewContent.do;jsessionid=A88CD6317AB72269A3FAF80002D5AC...

Message 2 of 8
Rolof van den Hof
Occasional Visitor

Re: Trio 8800 Stuck on Black screen after factory Reset

Hi, 

 

There's (as far as I know) only one method. 

I performed the factory reset method you've mentioned in link. (touching the four corners of the screen after the Poly logo on boot) 

 

 

 

Message 3 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Trio 8800 Stuck on Black screen after factory Reset

Hello @Rolof van den Hof ,

 

Welcome to the Poly Community.

It would be of interest how the Trio got into this state? How is it powered? PoE or a PoE Injector? Have you tried to reset but not have an IP connection on it aka so any potential setting on a provisioning server could cause this? Are you sure the reset locally works aka are the led's toggling through different colors on the Mute LED's?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 8
Rolof van den Hof
Occasional Visitor

Re: Trio 8800 Stuck on Black screen after factory Reset

Hi,

 

The device is powered by PoE.

Like the title of this topic said; it started after a factory reset. The Teams account coulnd't sign in and I was stuck there so I decided to factory Reset (with mode flashing Mute buttons) 

 

There is no way a provisioning server has caused this state of the device.

 

Is there any way how I can Reprogram the device to make it start working again?

 

Best regards,

Rolof van den Hof

 

 

 

 

Message 5 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Trio 8800 Stuck on Black screen after factory Reset

Hello @Rolof van den Hof ,

 

I have never seen it in this state and only an RMA can fix this device.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 8
Rolof van den Hof
Occasional Visitor

Re: Trio 8800 Stuck on Black screen after factory Reset

The problem is that this device is out of warranty and an RMA is not being accepted I'm afraid... 

We bought this via local reseller that will not provide support on it.

 

 

 

 

Message 7 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Trio 8800 Stuck on Black screen after factory Reset

Hello @Rolof van den Hof ,

 

What is the device serial aka the MAC


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 8