Plantronics + Polycom. Now together as Poly Logo

Trio 8800 screen issue

Nazzal
Frequent Visitor

Trio 8800 screen issue

Hi,

Have the Trio 8800 with the screen issue like attached. too many dots with inaccurate touch. tried to upgrade to latest version with same issue.

3 REPLIES 3
SteffenBaierUK
Polycom Employee & Community Manager

Re: Trio 8800 screen issue

Hello @Nazzal 

 

it would really help all of us volunteers to explaining how the Trio got into this state. If this is a day 1 issue please simply select an RMA

 

replied via a mobile device 

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 4
Nazzal
Frequent Visitor

Re: Trio 8800 screen issue

thank you Steffen. just came and found it into this state. tried to change the poe switch with another one; even i connected it directly to poe injector. same issue.

Message 3 of 4
rgsteele
Valued Contributor

Re: Trio 8800 screen issue

Sure looks like a hardware problem to me.

Message 4 of 4