Plantronics + Polycom. Now together as Poly Logo

Trio C60 Teams 5.9.5.2831 update does not work - workaround

Highlighted
Occasional Contributor

Trio C60 Teams 5.9.5.2831 update does not work - workaround

As reported in my other thread Firmware updates for Poly phones were made available in Teams Administration Center.  CCX 400 update does not work at all i.e. it wont even install.  Trio update to 5.9.5.2831 appears to install, but then it would not login user nor can contact intune to finish setting up.  It just had a message on the top left saying No Internet.  But it in fact  was connected and I could login via web browser and also run ping tests.  I tried factor reset as well. Since it no longer is connected to Teams Admin, I wasn't even sure how to downgrade.  In poking around the web interface, I found an update option that checks Poly servers and it found 5.9.5.2686.  But it wouldn't update.  I had to switch from Teams profile to Generic profile and then it updated to 2686.  This version appears to work as it is supposed to and I can make calls.

We are just starting to deploy Teams Phone System with Poly phones. If this is how Poly and Microsoft pushes out firmware updates, we are in for a rough ride!

Message 1 of 6
5 REPLIES 5
Highlighted
Polycom Employee & Community Manager

Re: Trio C60 Teams 5.9.5.2831 update does not work - workaround

Hello @Sarat ,

 

Welcome back to the Poly Community.


These scenarios have been thoroughly tested both by Poly and our Partner Microsoft but some corner conditions could affect what you are seeing.

 

I believe if you try to upgrade via the TAC our own built-in software upgrade server most likely gets overruled and therefore what fails.

 

Switching to openSIP will disconnect the device from TAC and most likely this is why it succeeds. In order to verify this, we would need you to open a support ticket.


In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
Highlighted
Polycom Employee

Re: Trio C60 Teams 5.9.5.2831 update does not work - workaround

There is a problem with the CCX400 version that Microsoft posted to the Teams update service causing upgrades to fail.  That version will be removed and a newer, fixed version will replace it later this month.  So the CCX400 needs to stay on the last 1.x firmware for the time being.  (The CCX 500/600 are unaffected and should be upgrading to 6.2.21 without issues.)

 

The released Trio build may exhibit the 'No Internet Access' message even when it's successfully signed in to Teams. This bug will be fixed in a newer Trio firmware also coming out this month.

-----------
Jeff Schertz - Principal Microsoft Solutions Architect [Blog]

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Message 3 of 6
Highlighted
Occasional Contributor

Re: Trio C60 Teams 5.9.5.2831 update does not work - workaround

Thanks for the update. Just to clarify, on Trio upgrade, the "no internet" message is present and the phone can not login to Teams.  It says can't connect to Company Portal (I guess Intune).  So, it is not that it is logged in and it's just a message, rather it is unable to login.

Message 4 of 6
Highlighted
Polycom Employee & Community Manager

Re: Trio C60 Teams 5.9.5.2831 update does not work - workaround

Hello @Sarat ,

 

Welcome back to the Poly Community.
We may need to refer this to Microsoft but to start this off please work with your reseller so this could come into our support organization.

 

In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 6
Highlighted
Frequent Visitor

Re: Trio C60 Teams 5.9.5.2831 update does not work - workaround

We're experiencing the same issue, but found a different workaround.  Updated a Trio C60 (MS Teams base profile) with 5.9.5.2686, and received the 'no ethernet' message, yet device pulled an IP and we could login to the web interface.  Unfortunately, we could not login to Teams, and we do not use Intune with these, either.  I found that changing the Web Proxy mode to 'Auto' resolved the issue, although the Admin guide states that web proxy authentication is not supported for MS Teams, and expectedly, WPAD status failed.  We don't want these hitting out proxy either...  

 

We have over 120 C60s running 5.9.3.823 now, and they're great - no worries about proxies, etc.  I see that there should be a fix coming soon, but I thought I'd add our experience here as well, in case others are seeing the same thing.    

Message 6 of 6