Plantronics + Polycom. Now together as Poly Logo

VVX 310/410 - SfB Web Sign In "Failed to get pair code"

SOLVED
dave6466
Occasional Advisor

VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Hello,

 

I have several VVX phones which have been factory reset and updated to the highest supported FW.

 

I am attempting to provision them using web sign-in, leaving the user field empty.  When I do so, I get an error message on the phone's screen that says "failed to get pair code."

 

Below are log entries from the moments after I pressed "sign in." Can anyone tell me what we have going wrong here?  If it's something obvious, apologies; I've genuinely done tons of research and experimentation and posting here is my last resort.

 

Dave6466

0212103113|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Enter

0212103113|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Default

0212103113|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Exit

0212103114|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Enter

0212103114|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Default

0212103114|brow |4|00|CWebLayoutMgr::handleProxyConfiguration Exit

0212103114|ec |4|00|configureEws empty email id
0212103114|ec |4|00|configureEws empty email id
0212103112|dasvc|2|00|Request(-1)dasvc,(2)ServiceDebugMsgKey,(-1),(-1),(Expiry,TransactionId,Time,Type):(-1,-1,1613143872,0)IndicationLevel:(200)
0212103112|log |*|00|changed log level of 1152 to 4
0212103112|log |*|00|changed log level of 1182 to 2
0212103112|nisvc|2|00|Request(-1)nisvc,(2)ServiceDebugMsgKey,(-1),(-1),(Expiry,TransactionId,Time,Type):(-1,-1,1613143872,0)IndicationLevel:(200)
0212103112|log |*|00|changed log level of 1200 to 2
0212103112|proxy|2|00|Request(-1)proxy,(2)ServiceDebugMsgKey,(-1),(-1),(Expiry,TransactionId,Time,Type):(-1,-1,1613143872,0)IndicationLevel:(200)
0212103112|log |*|00|changed log level of 1210 to 2
0212103112|log |*|00|changed log level of 1235 to 2
Message 1 of 9
1 ACCEPTED SOLUTION

Accepted Solutions
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Firewall issue!  Traffic was getting blocked.  Thank you again S, keep up the great work.

 

View solution in original post

Message 9 of 9
8 REPLIES 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Hello @dave6466 ,

 

Welcome to the Poly community.


Stating the latest software does not help others when finding this post in days, weeks, months or years to come as they do not know what software mentioned was current at the time of writing.

Please therefore always post the exact complete build id.

Therefore the Poly VoIP FAQ contains this post here:

Question: How can I find out my SIP or UC Software Version of my Phone?
Resolution: Please check here

 

I am not sure I fully understand the statement about the username being empty.

 

Are you using the Web interface to do what?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 9
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Current software version :
5.9.6.2327

 

Thanks!  I'm a big fan of your support articles, Steffen.

 

Message 3 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Hello @dave6466 

 

best to add a screenshot or similar a description of what you are trying to do.

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 9
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Sure.  In the VVX 310 and 410, I'm going to Settings / Skype for Business Sign In, and selecting Web Sign In from the drop down, and then pressing sign in.  The phone displays a message that says "Failed to get pair code."  Posting screenshots of both.  Please let me know if any part of this isn't clear.  Thanks so much again.

 

dave6466_0-1613149599454.png

dave6466_1-1613149626714.png

 

 

Message 5 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Hello @dave6466 ,

 

I just had a quick play with a VVX 600 running 5.9.6 and I assume this could be a firewall issue.

 

Lowering the logging as follows:

 

Settings > Logging > Global Settings > Global Log Level Limit > Log File Size (Kbytes) > Trio 8300 & VVX after 5.5.0 = 1000

Settings > Logging > Module Log Level Limits > CURL > Event 3

 

shows:

0212175157|curl |3|00|About to connect() to bootstrap.pinauth.services.skypeforbusiness.com port 443 (#0)
0212175157|curl |3|00|  Trying 52.114.74.20... 
0212175157|curl |3|00|the local port callback returned 0
0212175157|curl |3|00|Local port: 38917
0212175157|curl |3|00|Connected to bootstrap.pinauth.services.skypeforbusiness.com (52.114.74.20) port 443 (#0)

 

If you cannot see this or similar I would assume something in your network is blocking the traffic. Other community members are more than welcome to comment but if this all fails and you need support please see the below.

 

In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 9
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Thanks Steffen!

 

Here are the logs from my attempt:

 

0212143659|log |*|00|changed log level of 1142 to 3
0212143708|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1168673776)
0212143708|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1168673776)
0212143708|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1168673776)
0212143709|curl |3|00|timeout on name lookup is not supported
0212143709|curl |3|00|About to connect() to 140.242.64.35 port 21 (#0)
0212143709|curl |3|00| Trying 140.242.64.35...
0212143709|curl |3|00|the local port callback returned 0
0212143709|curl |3|00|Local port: 46503
0212143709|curl |3|00|Connected to 140.242.64.35 (140.242.64.35) port 21 (#0)
0212143710|curl |3|00|Send failure: Broken pipe
0212143710|curl |3|00|Closing connection #0
0212143710|curl |3|00|timeout on name lookup is not supported
0212143710|curl |3|00|About to connect() to 140.242.64.35 port 21 (#0)
0212143710|curl |3|00| Trying 140.242.64.35...
0212143710|curl |3|00|the local port callback returned 0
0212143710|curl |3|00|Local port: 50004
0212143710|curl |3|00|Connected to 140.242.64.35 (140.242.64.35) port 21 (#0)
0212143711|curl |3|00|Send failure: Broken pipe
0212143711|curl |3|00|Closing connection #0
0212143711|curl |3|00|timeout on name lookup is not supported
0212143711|curl |3|00|About to connect() to 140.242.64.35 port 21 (#0)
0212143711|curl |3|00| Trying 140.242.64.35...
0212143711|curl |3|00|the local port callback returned 0
0212143711|curl |3|00|Local port: 48858
0212143711|curl |3|00|Connected to 140.242.64.35 (140.242.64.35) port 21 (#0)
0212143712|curl |3|00|Send failure: Broken pipe
0212143712|curl |3|00|Closing connection #0
0212143712|nisvc|2|00|Request(-1)nisvc,(701)NIServiceHttpReqMsgKey,(-1)dpair,(702)NIServiceHttpResMsgKey,(Expiry,TransactionId,Time,Type):(-1,1613158632,1613158632,0)IndicationLevel:(200)
0212143712|curl |3|00|timeout on name lookup is not supported
0212143712|curl |3|00|About to connect() to bootstrap.pinauth.services.skypeforbusiness.com port 443 (#0)
0212143712|curl |3|00| Trying 52.114.132.2...
0212143712|curl |3|00|the local port callback returned 0
0212143712|curl |3|00|Local port: 31892
0212143712|curl |3|00|Connected to bootstrap.pinauth.services.skypeforbusiness.com (52.114.132.2) port 443 (#0)
0212143713|curl |3|00|successfully set certificate verify locations:
0212143713|curl |3|00| CAfile: /ffs0/ca4.crt
CApath: none
0212143713|curl |3|00|SSLv3, TLS Unknown, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Client hello (1):
0212143713|cfg |4|00|Prov|Could not download file 0004f27ec9fc-web.cfg
0212143713|cfg |4|00|Prov|Uploading phoneWeb.cfg failed
0212143713|cfg |4|00|Prov|Update configuration failed
0212143713|curl |3|00|SSLv2, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Server hello (2):
0212143713|curl |3|00|SSLv3, TLS handshake, CERT (11):
0212143713|curl |3|00|SSLv3, TLS handshake, Server key exchange (12):
0212143713|curl |3|00|SSLv3, TLS handshake, Server finished (14):
0212143713|curl |3|00|SSLv2, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Client key exchange (16):
0212143713|curl |3|00|SSLv2, Unknown (20):
0212143713|curl |3|00|SSLv3, TLS change cipher, Client hello (1):
0212143713|curl |3|00|SSLv2, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Finished (20):
0212143713|curl |3|00|SSLv2, Unknown (20):
0212143713|curl |3|00|SSLv3, TLS change cipher, Client hello (1):
0212143713|curl |3|00|SSLv2, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Finished (20):
0212143713|curl |3|00|SSL connection using ECDHE-RSA-AES256-GCM-SHA384
0212143713|curl |3|00|Server certificate:
0212143713|curl |3|00| subject: CN=*.pinauth.services.skypeforbusiness.com
0212143713|curl |3|00| start date: 2020-11-19 14:20:40 GMT
0212143713|curl |3|00| expire date: 2021-11-19 14:20:40 GMT
0212143713|curl |3|00| issuer: C=US, O=Microsoft Corporation, CN=Microsoft RSA TLS CA 01
0212143713|curl |3|00| SSL certificate verify ok.
0212143713|curl |3|00|SSLv2, Unknown (23):
0212143713|curl |3|00|SSLv2, Unknown (23):
0212143713|curl |3|00|Connection #0 to host bootstrap.pinauth.services.skypeforbusiness.com left intact
0212143713|nisvc|2|00|

****************************HTTP SEND**************************

0212143713|nisvc|2|00|HTTP SEND:: DestUrl(https://bootstrap.pinauth.services.skypeforbusiness.com:443/api/DeviceConfig/Polycom/Default?api-version=1.0), HttpResCode(200), curlRetCode(0) retVal(0)
0212143713|nisvc|2|00|ErrorBuffer::
0212143713|nisvc|2|00|

****************************HTTP SEND**************************

0212143713|curl |3|00|Closing connection #0
0212143713|curl |3|00|SSLv2, Unknown (21):
0212143713|curl |3|00|SSLv3, TLS alert, Client hello (1):
0212143713|nisvc|2|00|<\ni01:1,time taken(50)>
0212143713|nisvc|2|00|Request(-1)nisvc,(701)NIServiceHttpReqMsgKey,(-1)dpair,(702)NIServiceHttpResMsgKey,(Expiry,TransactionId,Time,Type):(-1,1613158632,1613158633,0)IndicationLevel:(200)
0212143713|curl |3|00|timeout on name lookup is not supported
0212143713|curl |3|00|About to connect() to login.microsoftonline.com port 443 (#0)
0212143713|curl |3|00| Trying 20.190.151.8...
0212143713|curl |3|00|the local port callback returned 0
0212143713|curl |3|00|Local port: 20823
0212143713|curl |3|00|Connected to login.microsoftonline.com (20.190.151.8) port 443 (#0)
0212143713|curl |3|00|successfully set certificate verify locations:
0212143713|curl |3|00| CAfile: /ffs0/ca4.crt
CApath: none
0212143713|curl |3|00|SSLv3, TLS Unknown, Unknown (22):
0212143713|curl |3|00|SSLv3, TLS handshake, Client hello (1):
0212143713|curl |3|00|Unknown SSL protocol error in connection to login.microsoftonline.com:443
0212143713|curl |3|00|Closing connection #0
0212143713|nisvc|2|00|

****************************HTTP SEND**************************

0212143713|nisvc|2|00|HTTP SEND:: DestUrl(https://login.microsoftonline.com/common/oauth2/devicecode?api-version=1.0), HttpResCode(0), curlRetCode(35) retVal(0)
0212143713|nisvc|2|00|ErrorBuffer::Unknown SSL protocol error in connection to login.microsoftonline.com:443
0212143713|nisvc|2|00|

****************************HTTP SEND**************************

0212143713|nisvc|2|00|<\ni02:1,time taken(28)>
0212143713|dpair|4|00|parseAndSaveRequiredInfo: Failed to get Response for req(2)
0212143713|dpair|4|00|Response received:
0212143713|dpair|4|00|HttpRespCode [480], CurlRespCode [35]

0212143910|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1212140528)
0212143910|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1212140528)
0212143911|cfg |5|00|Web||ParamParser|Parameter array dimension is unsupported: ""(1212140528)
Message 7 of 9
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Homing in on this entry:

 

0212143713|curl |3|00|Unknown SSL protocol error in connection to login.microsoftonline.com:443

 

Is this possibly related to SSL decryption bypass not working properly on microsoftonline.com?

 

 

 

Message 8 of 9
dave6466
Occasional Advisor

Re: VVX 310/410 - SfB Web Sign In "Failed to get pair code"

Firewall issue!  Traffic was getting blocked.  Thank you again S, keep up the great work.

 

View solution in original post

Message 9 of 9