Plantronics + Polycom. Now together as Poly Logo

VVX 400 Trying to connect to FE Server instead of Edge Server

SOLVED
guideclothing
Frequent Advisor

VVX 400 Trying to connect to FE Server instead of Edge Server

Hello,

 

i have a VVX400 Serial 00:04:F2:6F:F7:26 - S4b version

Firmware: 5.9.6.2996

 

i have been able to connect out of my office fine, connecting to my edge server but it has suddenly stopped working

 

i have enabled debug logs on CURL, DNS & SIP

 

i have public DNS records for:

sip.guideclothing.co.uk,

sipexternal.guideclothing.co.uk, 

_sip._tls.guideclothing.co.uk, 

_sipfederationtls._tcp.guideclothing.co.uk

 

for some reason the phone is trying to connect to my front end server skypeserver1.guideclothing.co.uk on port 5061 instead of on sip.guideclothing.co.uk on 5061

 

the S4B windows client signs in fine and confirms its connecting to sip.guideclothing.co.uk

 

i just cannot work out what has changed

 

i have attached the logs as a text file

 

thanks

 

jack

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

i have fixed the issue

 

the ExternalSipClientAccessFqdn was incorrect

 

for some reason the VVX looks at this in the lyncdiscover response, it does not use the DNS records to find the edge server IP address

 

 

PS C:\Users\administrator> Get-CsAutodiscoverConfiguration


Identity : Global
WebLinks : {}
ExternalSipClientAccessFqdn : skypeserver1.guideclothing.co.uk
ExternalSipClientAccessPort :
EnableCertificateProvisioningServiceUrl : True
EnableCORS : False


PS C:\Users\administrator> Set-CsAutodiscoverConfiguration -ExternalSipClientAccessFqdn sip.guideclothing.co.uk -ExternalSipClientAccessPort 5061
PS C:\Users\administrator> Get-CsAutodiscoverConfiguration


Identity : Global
WebLinks : {}
ExternalSipClientAccessFqdn : sip.guideclothing.co.uk
ExternalSipClientAccessPort : 5061
EnableCertificateProvisioningServiceUrl : True
EnableCORS : False

View solution in original post

Message 10 of 10
9 REPLIES 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

Hello @guideclothing ,

 

Welcome back to the Poly Community. 


Our Spam Filter has caught this and a volunteer needs to release this. There is no need to raise this as Abuse. Simply wait until this is done.

 

Please remember the community is run by volunteers in their spare time.

 

Checking the MAC provides shows this is not a Skype License enabled phone so please be aware of this and any other phone from the same batch:

 

 Please be aware of the following when utilizing UCS 4.1.0 or later:

The use of Polycom UC Software versions 4.1.X (“Software”) requires the purchase of a separate Software license for every device that will use the Software in a LYNC / Skype for Business environment. You may not install, access, or use the Software in a LYNC / Skype for Business environment on more devices than are listed on your license until additional licenses have been purchased and authorized by Polycom. These licenses should be purchased from the same company from which you purchased the devices. You may operate devices against a LYNC / Skype for Business server for trial purposes for up to 30 days without purchasing a license. Use of the Software is subject to the terms and conditions of the End User License Agreement.

Polycom reserves the right to audit your deployment to verify that you have sufficient licenses to match the number of devices being used.

Information in regards of License Part Numbers can be found here

 

Can you provide proof of this license before we look into this or ensure you purchase the relevant amount of these for your installation?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

i have checked my records and i can see i bought licences separately for some of my phones

Message 3 of 10
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

Hello @guideclothing ,

that is great news but all your phones need to be licensed not just a few. Similar to a partner like Microsoft which I would assume would not be too happy if you use their Software without the proper licenses in place.

In addition, your old post  => here <= is still open/pending as you have not marked these as "Accept as a solution" or at least provide some form of feedback or answer.

If they are in this state nobody finding them via a community search will know if an answer or advice provided was useful and has maybe helped you.

Could you therefore kindly go over them and mark or answer as appropriate?

If they are marked as "Accept as a solution" other users can find these easier and it helps them to utilize the community more efficiently.

 

Please do not simply mark them without any type of feedback.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

Steffen,

 

i meant that some of the phones i bought did not have Lync licences. for those ones i purchased lync licences. most of my phones do have licences. if you want serial numbers please send me a private message.

 

the issue you mentioned is still outstanding. I have not found a solution but due to covid and people not working in the office i have not had to fix it

 

i would appreciate help with this issue. do you want me to private message you the details of the licence i bought?

 

jack

 

Message 5 of 10
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

Hello @guideclothing ,

 

Our Support Team has been working throughout the pandemic but I give you the benefit of the doubt in regards to the outlined licenses.

 

In my role as a volunteer, there is only so much I can provide within the community before it gets into support territory.

 

From the logs, it looks like your internal auto-discover fails. As we do not know how this started or what was changed it is hard to tell.

0526102705|nisvc|2|00|HTTP SEND:: DestUrl(http://lyncdiscoverinternal.guideclothing.co.uk), HttpResCode(0), curlRetCode(6) retVal(0)
0526102705|nisvc|2|00|ErrorBuffer::Couldn't resolve host 'lyncdiscoverinternal.guideclothing.co.uk'

and

0526102705|nisvc|2|00|HTTP SEND:: DestUrl(https://lyncdiscoverinternal.guideclothing.co.uk), HttpResCode(0), curlRetCode(6) retVal(0)
0526102705|nisvc|2|00|ErrorBuffer::Couldn't resolve host 'lyncdiscoverinternal.guideclothing.co.uk'

 

After this, it looks at the external entries.

 

Other volunteers are welcome to comment. After this, it is the below.

 

In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI via Nimans Ltd. as they sold the unit back in 2/26/2016.

 

This is all outlined in detail here

 

The license status will be checked by our team.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

Steffen 

 

i appreciate your help and that you are a volunteer

 

the VXX 400 is connecting from outside the network so lyncdiscoverinternal will not be found.

 

from the public DNS records it should connect to sip.guideclothing.co.uk but it is attempting to connect to skypeserver1.guideclothing.co.uk

 

i cannot work out why

Message 7 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

i can see where in the logs the issue is happening, but i do not understand why it is happening

 

when i connect to jack@guideclothing.co.uk there are the following logs:

CreateFailOverProxyList : Reg to Domain 'guideclothing.co.uk' nPort 0, lkup 6
CreateFailOverProxyList : Domain is in user part
CreateFailOverProxyList : For REGISTER Request nPort 0
CreateFailOverProxyList resetting pps watchdog for 200000mSec in auto discovery
CreateFailOverProxyList WAD: ClientInternal[SkypeServer1.guideclothing.local:5061], ClientExternal[skypeserver1.guideclothing.co.uk:5061]

 

if i try to connect to jack@outlook.co.uk which is a lync enabled domain (but not a real user account) i get the following logs:

CreateFailOverProxyList : Reg to Domain 'outlook.co.uk' nPort 0, lkup 6
CreateFailOverProxyList : Domain is in user part
CreateFailOverProxyList : For REGISTER Request nPort 0
CreateFailOverProxyList resetting pps watchdog for 200000mSec in auto discovery
CreateFailOverProxyList - Could not found servers using WAD
Configuration of URL failed
Prov|Could not download file 0004f26ff726-web.cfg
Prov|Uploading phoneWeb.cfg failed
Prov|Update configuration failed
CreateFailOverProxyList : 'Auto Discovery' 0 DHCP servers received
doDnsLookupForList for record SRV: hostname '_sipinternaltls._tcp.outlook.co.uk' attempting..
Miss in All DNS cache for _sipinternaltls._tcp.outlook.co.uk(SRV)
doDnsLookupForList for record SRV: no match found for '_sipinternaltls._tcp.outlook.co.uk'
Retaining Negative DNS cache for _ntp._udp.time.windows.com(SRV)
Retaining Negative DNS cache for _ntp._udp.time.nist.gov(SRV)
Retaining Negative DNS cache for _sip._udp.guideclothing.co.uk(SRV)
Retaining Negative DNS cache for _sip._udp.outlook.co.uk(SRV)
Added Negative DNS cache entry for _sipinternaltls._tcp.outlook.co.uk(SRV) expires in 3600 seconds
Found DNS cache entry for _sipinternaltls._tcp.outlook.co.uk(SRV)
doDnsSrvLookupForARecordList(tcp): SRV lookup returned nothing
doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'outlook.co.uk' found no records
doDnsLookupForList for record SRV: hostname '_sipinternal._tcp.outlook.co.uk' attempting..
Miss in All DNS cache for _sipinternal._tcp.outlook.co.uk(SRV)
|doDnsLookupForList for record SRV: no match found for '_sipinternal._tcp.outlook.co.uk'
Retaining Negative DNS cache for _ntp._udp.time.windows.com(SRV)
Retaining Negative DNS cache for _ntp._udp.time.nist.gov(SRV)
Retaining Negative DNS cache for _sip._udp.guideclothing.co.uk(SRV)
Retaining Negative DNS cache for _sip._udp.outlook.co.uk(SRV)
Retaining Negative DNS cache for _sipinternaltls._tcp.outlook.co.uk(SRV)
Added Negative DNS cache entry for _sipinternal._tcp.outlook.co.uk(SRV) expires in 3600 seconds
Found DNS cache entry for _sipinternal._tcp.outlook.co.uk(SRV)
doDnsSrvLookupForARecordList(tcp): SRV lookup returned nothing
doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'outlook.co.uk' found no records
0527114600|dns |1|00|doDnsLookupForList for record SRV: hostname '_sip._tls.outlook.co.uk' attempting..

 

I need to understand what this means any where the VVX400 is getting the data from:

CreateFailOverProxyList WAD: ClientInternal[SkypeServer1.guideclothing.local:5061], ClientExternal[skypeserver1.guideclothing.co.uk:5061]

 

thanks

 

jack

 

Message 8 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

this issue stems from here:

 

when connecting to jack@outlook.co.uk

****************************HTTP SEND**************************

HTTP SEND:: DestUrl(https://webdir1e.online.lync.com/Autodiscover/AutodiscoverService.svc/root/user?originalDomain=outlook.co.uk?sipuri=jack@outlook.co.uk), HttpResCode(401), curlRetCode(0) retVal(0)
ErrorBuffer::
****************************HTTP SEND**************************

Closing connection #0
SSLv2, Unknown (21):
SSL DATA_OUT: Data of len 5 not displayed
SSLv3, TLS alert, Client hello (1):
SSL DATA_OUT: Data of len 2 not displayed
<\ni02:1,time taken(62)>
<SM>(-1)(0x48a00948):Ctx((550),(1556)kEWADHandleResponse,Ticks(0))
[SWADFetchUserUrls -> EWADHandleResponse]
Response Code:401

when connecting to jack@guideclothing.co.uk

****************************HTTP SEND**************************

HTTP SEND:: DestUrl(https://skypeserver1.guideclothing.co.uk/Autodiscover/AutodiscoverService.svc/root/user?originalDomain=guideclothing.co.uk?sipuri=jack@guideclothing.co.uk), HttpResCode(200), curlRetCode(0) retVal(0)
ErrorBuffer::


****************************HTTP SEND**************************

Closing connection #0
SSLv2, Unknown (21):
SSL DATA_OUT: Data of len 5 not displayed
SSLv3, TLS alert, Client hello (1):
SSL DATA_OUT: Data of len 2 not displayed
<\ni00:1,time taken(88)>
<SM>(-1)(0x17418b8):Ctx((550),(1556)kEWADHandleResponse,Ticks(0))
[SWADFetchUserUrls -> EWADHandleResponse]
Response Code:200

 

When connecting to jack@outlook.co.uk there is a 401 response - bad respone

when connecting to jack@guideclothing.co.uk there is a 200 response - good response 

 

when i open both URLS in a browser i get a 401 response

 

https://webdir1e.online.lync.com/Autodiscover/AutodiscoverService.svc/root/user?originalDomain=outlo...

 

https://skypeserver1.guideclothing.co.uk/Autodiscover/AutodiscoverService.svc/root/user?originalDoma...

 

i do not now how to troubleshoot from here

 

Message 9 of 10
guideclothing
Frequent Advisor

Re: VVX 400 Trying to connect to FE Server instead of Edge Server

i have fixed the issue

 

the ExternalSipClientAccessFqdn was incorrect

 

for some reason the VVX looks at this in the lyncdiscover response, it does not use the DNS records to find the edge server IP address

 

 

PS C:\Users\administrator> Get-CsAutodiscoverConfiguration


Identity : Global
WebLinks : {}
ExternalSipClientAccessFqdn : skypeserver1.guideclothing.co.uk
ExternalSipClientAccessPort :
EnableCertificateProvisioningServiceUrl : True
EnableCORS : False


PS C:\Users\administrator> Set-CsAutodiscoverConfiguration -ExternalSipClientAccessFqdn sip.guideclothing.co.uk -ExternalSipClientAccessPort 5061
PS C:\Users\administrator> Get-CsAutodiscoverConfiguration


Identity : Global
WebLinks : {}
ExternalSipClientAccessFqdn : sip.guideclothing.co.uk
ExternalSipClientAccessPort : 5061
EnableCertificateProvisioningServiceUrl : True
EnableCORS : False

View solution in original post

Message 10 of 10