Plantronics + Polycom. Now together as Poly Logo

Configure Trio 8800 to use Realconnect for Teams Meetings

SOLVED
Occasional Contributor

Configure Trio 8800 to use Realconnect for Teams Meetings

Hi, I'm trying to configure a Polycom Trio 8800 that is configured for SfB to use RealConnnect for MS Teams interop.
 
Details:-
 
Model - Trio 8800
S/W - 5.8.0.15232
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Banyan 5.8.0.15232 25-Feb-19 10:48 -->
<!-- Created 10-04-2019 14:50 -->
<!-- Base profile Lync -->
<PHONE_CONFIG>
 <!-- Note: The following parameters have been excluded from the export:
  btoe.PairingCode=""
  tcpIpApp.ice.password=""
  tcpIpApp.ice.username=""
 -->
 <ALL
  btoe.pairingMode="Manual"
  dialplan.digitmap.lineSwitching.enable="1"
  exchange.meeting.join.promptWithList="1"
  exchange.meeting.parseAllowedSipUriDomains="test.plcm.vc,t.plcm.vc,plcm.vc"
  exchange.meeting.parseEmailsAsSipUris="1"
  exchange.meeting.parseOption="All"
  exchange.meeting.parseWhen="Always"
  exchange.meeting.realConnectProcessing.teams.enabled="1"
  feature.directory.enabled="1"
  feature.fecc.enabled="0"
  httpd.cfg.enabled="1"
  httpd.enabled="1"
  lcl.datetime.time.24HourClock="1"
  log.level.change.afe="5"
  log.level.change.auth="2"
  log.level.change.nisvc="2"
  log.level.change.proxy="2"
  log.level.change.sip="0"
  log.level.change.sipp="0"
  log.level.change.sipt="0"
  log.level.change.tls="0"
  log.level.change.wad="2"
  lync.qos.dscpVoice="40"
  powerSaving.idleTimeout.offHours="5"
  powerSaving.idleTimeout.officeHours="15"
  reg.limit="3"
  sec.TLS.SIP.strictCertCommonNameValidation="0"
  system.name="Team8800"
  tcpIpApp.ice.turn.server="mediaedgeGB1.online.lync.com"
  tcpIpApp.ice.turn.udpPort="3478"
  tcpIpApp.port.rtp.lync.audioPortRangeEnd="50019"
  tcpIpApp.port.rtp.lync.audioPortRangeStart="50000"
  tcpIpApp.port.rtp.lync.contentPortRangeStart="50040"
  tcpIpApp.port.rtp.lync.videoPortRangeEnd="50039"
  tcpIpApp.port.rtp.lync.videoPortRangeStart="50020"
  dialplan.1.lyncDigitmap.timeOut="5"
  msg.mwi.1.callBack="sip:a@b.com;opaque=app:voicemail"
  msg.mwi.1.callBackMode="contact"
  reg.1.address="a@b.com"
  reg.2.address="a@b.com"
  reg.1.auth.loginCredentialType="usernameAndPassword"
  reg.1.ice.turn.callAdmissionControl.enabled="1"
  reg.2.serverAutoDiscovery="0"
  reg.1.srtp.offer="1"
  reg.2.srtp.offer="1"
  voIpProt.server.1.address="Team8800"
  reg.2.server.1.register="0"
  reg.2.server.1.transport="TLS"
 />
</PHONE_CONFIG>
When the join button is pressed the Trio doesn't use line 2 to join via the Re4al Presence bridge.
If I make a test call to 7357@test.plcm.vc the call fails.
 
Any help would be much appreciated!
 
Regards, Graham
 
 
 
Message 1 of 6
5 REPLIES 5
Occasional Contributor

Re: Configure Trio 8800 to use Realconnect for Teams Meetings

According to the attached release documents in the release V5.7.2AB support was added for RealConnect:-

 

5.7.2AB November 2018 This release includes the following enhancements:

• Microphone Synchronization Between Paired Systems

• Audio from an HDMI Connection

• Click-to-Join Support for Polycom RealConnect Services

 

In the same document it states that by default Teams meetings to use RealConnect

 

setting - RealConnect:exchange.meeting.realConnectProcessing.teams.enabled

Description - 1 (default) – Enable Microsoft Teams meeting on Polycom RealConnect technology.

 

Also, the default line that the Trio will attempt to use is line 2:-

 

Setting - exchange.meeting.realConnectProcessing.outboundRegistration

Description - Choose a line number to use to make Polycom RealConnect calls. 2 (default) 1-34

 

I have factory defaulted a Trio, signed the device into SfB Online and tried to join a Teams meeting but the Trio doesn't connect via RealConnect.

I know that for RC to work the Trio has to be able to make calls to a sip URI (you can test with 7357@test.plcm.vc)

 

@Polycom, Is there a admin guide for a Trio and RealConnect? Something similar to this >>https://support.polycom.com/content/dam/polycom-support/products/strategic-partner-solutions/blue-je... << would be ideal.

 

I can get Cisco and Lifesize units to join without any issues but not the Trio!

Polycom Employee & Community Manager

Re: Configure Trio 8800 to use Realconnect for Teams Meetings

Hello @GrahamW ,

 

I am looking into someone responding to this.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 3 of 6
Polycom Employee

Re: Configure Trio 8800 to use Realconnect for Teams Meetings

Hi Graham,

 

Please do not use same address for different lines as documented here

 

To avoid unexpected phone behavior, do not use the same user name for multiple registrations. Use similar but not identical user names. For example, use: reg.1.address="John.Smith@company.com" and reg.2.address="J.Smith@business.com".

Try something like Trio.Graham for reg.2.address.

 

Add the following parameters:

reg.2.server.1.address="t.plcm.vc"

dialplan.2.applyToDirectoryDial="1"
dialplan.2.digitmap="^.+@t\.plcm\.vc$"
dialplan.2.digitmap.mode="regex"

You may wanna try reg.2.server.1.transport="TCPpreferred"

 

Add call.autoOffHook.2.contact="xxxx@t.plcm.vc" and call.autoOffHook.2.enabled="1" changing xxxx to your RealConnect tenant ID. In this case, when pressing the line 2 icon, the Trio will dial to the entry queue of your RealConnect service where you can dial any existent conference ID.

 

And finally make sure to follow the steps mentioned here if you are using a Room Account for your Trio.

Regards,
Leonardo Mezzanotti
Message 4 of 6
Occasional Contributor

Re: Configure Trio 8800 to use Realconnect for Teams Meetings

Thanks Leonardo, after upgrading to firmware V5.9.0.10869 and applying the suggested settings  I can now connect via RealConnect but there is no video being sent from the Visual+/Trio.

 

I set the video codec priority to be as per this doc (see attached image) but that hasn't made any difference.

 

Any additional help would be much appreciated.

Message 5 of 6
Polycom Employee

Re: Configure Trio 8800 to use Realconnect for Teams Meetings

Please open a new forum thread and share your backup. Additionally, is it only failing with RealConnect? Have you verified your firewall config?

Regards,
Leonardo Mezzanotti
Message 6 of 6