Plantronics + Polycom. Now together as Poly Logo

Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

SOLVED
Highlighted
Occasional Contributor

Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

Trying to set up a Polycom 500 in a native-Skype and Teams/RealConnect scenario, e.g. Mixed Mode per https://blog.schertz.name/2019/10/poly-group-series-with-microsoft-teams/

 

We have the t.plcm.vc info being included on Teams invites, and am able to connect (from the 500 to RealConnect/Teams mtg) when we switch the 500 series calendar to point to otd.plcm.vc - but when we _do_ switch the calendar to OTD, all Skype meetings lose the "Join" option.  We have tried with a separate O365 service acct as well as the room-resource acct.  We have verified that DeleteComments and DeleteSubject are both set to 'false' for the O365 room resource.  

 

Telnetting to the 500 series API returns meetings from 'calendarmeetings list today', but pulling logs from the 500 (post-OTD calendar switch) says for the Skype meetings:

2020-01-31 19:24:47.481 DEBUG CalSvcs: hd[0]: CALENDAR: Found no meeting info in both extended properties and body. Meeting: meeting-name-here
2020-01-31 19:24:48.580 DEBUG CalSvcs: hd[0]: CALENDAR: Found no meeting info in both extended properties and body. Meeting: meeting-name2-here

 

Whereas talking directly to O365 acct/calendar, I instead get this:

2020-01-31 19:17:19.734 DEBUG CalSvcs: hd[0]: CALENDAR: UCMEETINGSETTING Found, value: 525011520
2020-01-31 19:17:19.734 DEBUG CalSvcs: hd[0]: CALENDAR: SIP URI found in attribute. sip:user@domain;gruu;opaque=app:conf:focus:id:09312BFC?conversation-id=9ul33cKyTOA

Any other suggestions I can try or look at?  Possible firmware issue with this release (seems a stretch)? Or reach out to Support directly? 

 

RealPresence Group 500
release - 6.2.1.2-590033

Message 1 of 6
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

This is now working.  I'm not sure what the actual "fix" is, but I changed 3 things.  I'll list them in order of my suspicion in terms of what I think resolved it.

 

- updated 500 series firmware to the 6.2.2.1 (currently the latest release), from the 6.2.1.2 that I was running

- added the "domain" of "OTD" when configuring the 500 series calendar service to use the otd.plc.vc service

- changed the Dialing Rules in otd.plcm.vc to _include_ the Skype server/Skype for Business, which is counter to the guide that I was using ("mixed mode" http://blog.schertz.name/2019/10/poly-group-series-with-microsoft-teams/ )

 

Again, I can't say for certain, but we are currently running in mixed-mode with native-Skype calls and Teams-via-RealConnect and all seems well.  Thank you for your input. 

View solution in original post

Message 6 of 6
5 REPLIES 5
Regular Advisor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

Are you using WFS in authenticated mode or pass through auth mode?

Message 2 of 6
Highlighted
Occasional Contributor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

If I understand your question - WFS = polycom work flow server = we are not using it/don't have it.  Is it required?  I have not encountered it in anything I've read to-date.  

Message 3 of 6
Highlighted
Regular Advisor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

Oh - I was assuming you were also looking for the click to join button what workflow server creates for endpoints registered to it for calendaring. WFS talks to exchange on behalf of the endpoints, parses the metadata of invites and searches for the appropriate dial string and makes a JOIN button on the touch control for the endpoint.

 

However, if you are just having issues getting the calendar to even appear, thats usually a permissions issue on exchange for the account being used for the mailbox.

Message 4 of 6
Highlighted
Regular Advisor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

Have you reviewed this guide?

Highlighted
Occasional Contributor

Re: Polycom 500, O365, RealConnect setup - no Skype calendar info detected in Mixed mode

This is now working.  I'm not sure what the actual "fix" is, but I changed 3 things.  I'll list them in order of my suspicion in terms of what I think resolved it.

 

- updated 500 series firmware to the 6.2.2.1 (currently the latest release), from the 6.2.1.2 that I was running

- added the "domain" of "OTD" when configuring the 500 series calendar service to use the otd.plc.vc service

- changed the Dialing Rules in otd.plcm.vc to _include_ the Skype server/Skype for Business, which is counter to the guide that I was using ("mixed mode" http://blog.schertz.name/2019/10/poly-group-series-with-microsoft-teams/ )

 

Again, I can't say for certain, but we are currently running in mixed-mode with native-Skype calls and Teams-via-RealConnect and all seems well.  Thank you for your input. 

View solution in original post

Message 6 of 6