Plantronics + Polycom. Now together as Poly Logo

BToE 3.4 Silent Install and cert

Highlighted
Occasional Visitor

BToE 3.4 Silent Install and cert

In the bookmarked thread announcing BToE 3.4.1, a certificate is included however I don't see anything in the release notes on how to use this for a silent install.  Are there any instructions how we can do this?  We deploy our software with SCCM.

 

What I've tried

- I installed the software silently without the cert.  This resulted in un-ending requests to reboot.  When you look in device manager, it shows the Polycom BToE Enumerator has an error and that error is that the device driver is signed by an unknown party

- I installed the certificate as a Trusted Publisher on the workstation as I had seen in another thread along the lines of this topic.  Perform the silent install, it removes the cert as a trusted publisher.  Same error as before.  Adding the cert back doesn't change anything.  Reboot combinations don't help either.

 

The only workaround I have found is to install BToE 3.3 then upgrade.  This is really inefficient to manage.

 

Thanks

 

Message 1 of 22
21 REPLIES 21
Highlighted
Polycom Employee & Community Manager

Re: BToE 3.4 Silent Install and cert

Hello JeffL,

welcome to the Polycom Community.

I am unsure why we could not simply discuss this in the old post but here we go.

 

First:

 

  • certutil -addstore -f "TrustedPublisher" Polycom_Inc.cer

The above will install the Certificate

 

Second:

 

  • Use something like SCCM to install BToE


The next would be to open a ticket.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post your phone's MAC address so I can look up who would be able to support you.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 22
Highlighted
Occasional Visitor

Re: BToE 3.4 Silent Install and cert

Thanks, that is exactly what was performed to no available.  Did anybody at Polycom try this on an out of the box Windows 10 1607 machine?  Its very easily reproduceable.

 

As for not using the other ticket, I am mostly interested in Polycom providing some documentation.  If the expectation for versions BToE 3.4 or older is that we have to have certificates pushed out to our workstation, one would think that should be documented somewhere instead of me finding a forum thread where every other response is to open a ticket.

Message 3 of 22
Highlighted
Polycom Employee & Community Manager

Re: BToE 3.4 Silent Install and cert

Hello JeffL,

If you read the original post you can find out that someone at Polycom has tried the 1607 build => here <= and could not reproduce this.

 

You also find that one of the original poster's could not reproduce this on one machine but could on another => here <=

 

So to answer your question you should just be able to install this with no issues at all.

 

As you encounter an issue and we as the manufacturer obviously want to solve this if we can you need to open a Ticket.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post your phone's MAC address so I can look up who would be able to support you.

 

Please be aware that we will check the entitlement of using our phones with LYNC / Skype for Business and will also check if you have the relevant licenses in place if applicable.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 22
Highlighted
Occasional Visitor

Re: BToE 3.4 Silent Install and cert

Hi,

 

The issue only appears with a clean 1607 UEFI install with Secure Boot enabled.  I strongly suspect it is due to the new Microsoft driver signing policy implemented only on clean 1607 installs.  If the Polycom support person in the other thread tested a machine updated to 1607, the issue would not present itself.

 

Here is a link to MSDN indicating the changes in clean 1607 installs:

https://blogs.msdn.microsoft.com/windows_hardware_certification/2016/07/26/driver-signing-changes-in...

 

Cheers,

--

Don

Message 5 of 22
Highlighted
Advisor

Re: BToE 3.4 Silent Install and cert

I am having the same problem with BToE on Windows 10 1607.

 

BToE crashes and then a popup appears stating that the system needs to be restarted to complete the installation. This happens with BToE 3.3.0, 3.4.0 and 3.4.1.

 

Here is the error message on the Polycom BToE Enumerator driver in Device Manager:

 

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

 

 

Highlighted
Polycom Employee & Community Manager

Re: BToE 3.4 Silent Install and cert

Hello all,

Polycom support is aware of this and it only affects new installations of Windows 10 running the 1607 build. We are tracking this under VOIP-123647 and there is no workaround.

 

We will update the community once a fix can be released.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 22
Highlighted
Occasional Visitor

Re: BToE 3.4 Silent Install and cert

It is not a windows 10 only problem! We use Windows 7 on 1400 clients and on exactly 0 we can install the driver via sccm (tested with btoe 3.4.0 and btoe 3.4.1).

 

the command "certutil -f -addstore...." does indeed import the certificate, the same command btw. gets executed in the msi. still, the setup asks if you want to trust the publisher. in silent mode there is nobody to answer, so the drivers wont get installed at all.

 

Phones: Polycom VVX 411

UC: 5.5.1

BTOE: 3.4.0 / 3.4.1

 

Expected behavior: import polycom_inc.cer into the trusted publisher certstore, install the software silently and the drivers gets installed because they are trusted

 

Experienced behavior: import the polycom_inc.cer into trusted publisher certstore. install btoe silently. no driver gets installed. if we run the setup with an admin user afterwards, windows prompts the user about not signed drivers and asks if you want to trust the publisher "polycom...". if you choose "always trust software from that publisher" you can then install the software silently and the driver gets also installed. still, there is no certificate for polycom in the certstore. even more funny. if you importat the useless certificate into the trusted publisher before running the setup, after installing the software and driver manually, the imported certificate is no longer there.

Message 8 of 22
Highlighted
Polycom Employee & Community Manager

Re: BToE 3.4 Silent Install and cert

Hello schuert,

welcome to the Polycom Community.

This post and discussion is about Windows 10.

 

If you have an issue with Windows 7 I can only ask you to open a service ticket via your Polycom reseller.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post your phone's MAC address so I can look up who would be able to support you.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 22
Highlighted
Occasional Visitor

Re: BToE 3.4 Silent Install and cert

this discussion is about silent installation of btoe 3.4.0 and problems with certs, as the title says:

http://community.polycom.com/t5/Skype-for-Business/BToE-3-4-Silent-Install-and-cert/m-p/87536#M2489

 

you are the one saying its windows 10 only, which it is not, since we have exactly the same problems with all our windows 7 clients.

 

since after btoe version 3.3.0 the certificate got updated and verious people have problems installing the drivers via the btoe setup silently, i highly recommend that someone from polycom looks into it, instead of refering everyone to your ticket system. this is no customer problem but a problem in your software.

 

btw. if you can't reproduce the problem, try to use a pc that has not all your internal polycom certs imported already.

Message 10 of 22