Plantronics + Polycom. Now together as Poly Logo

|[CAuthServiceEwsAutoDiscRsp::execute] Failed to get oAuth token with (400,Failed to Get UT)

Occasional Visitor

|[CAuthServiceEwsAutoDiscRsp::execute] Failed to get oAuth token with (400,Failed to Get UT)

Logged in to a polycom trio 8800 in SfbO but unable to sync exchange online calendar. After pulling logs I see the following error. Polycom Trio has already been updated to latest firmware (5.7.2.3206). Only other forum posts I could find on this was for MFA being enabled. Checked user accounts in O365 tenant and it is currently disabled. At this point I'm at a loss for what else to look for. Logs below, any help would be greatly appreciated!

 

Error: |[CAuthServiceEwsAutoDiscRsp::execute] Failed to get oAuth token with (400,Failed to Get UT)

 

1 REPLY 1
Polycom Employee & Community Manager

Re: |[CAuthServiceEwsAutoDiscRsp::execute] Failed to get oAuth token with (400,Failed to Get UT)

Hello @brsieff,

 

welcome to the Polycom Community.

Both the community's Must Read First and the community's FAQ reference the basic minimum information a new or follow up post should contain.

This ensures the questions having to be asked are limited and any new or follow up post contains the right amount of details to ensure any voluntary participant within the community does not spend additional time chasing basic information.

As a reminder the basic information asked for:

 

  • Provide the exact Software Version of your Phone
  • Provide the Phone Model
  • Provide the Call Platform (aka openSIP,Skype for Business Online, Skype for Business on Premise, Lync)
  • Additional Polycom Infrastructure (RPRM,PDMS or BToE)
  • If applicable provide a backup of the phone in question

UC Software 4.0.0 or later via the Web Interface Utilities > Phone Backup & Restore > Phone Backup > Phone Backup

  • If possible provide a Log and either attach them or use the Code Tag.Consult the Troubleshooting Section found within the FAQ if applicable
  • If possible provide the MAC Address or Serial of the device
  • Provide details if the issue is a day 1 issue or only happened after an upgrade or any other relevant details

Whilst providing some of these details may not directly impact any possible answer the community can provide, it does enable Polycom to have an overview of the current software used. In addition other details allow us to check logs or look up a potential support partners if an issue needs to come into support. It also enables us to verify the entitlement for using features.

 

Please ensure you always check the FAQ's and/or utilize the community search before posting any new topics or follow up post’s.

 

Looking at your log I assume this is a firewall issue:

1113113454|pgui |4|00|[EWS AutoDiscover] Fetching DP OAuth token for URL 'https://outlook.office365.com/autodiscover/autodiscover.xml'
1113113454|auth |4|00|eReqRspID[18] HttpCode[480] message[]

Not having provided all the relevant data also makes me worry about these:

 

1113113439|copy |4|00|SSL_connect error Peer certificate cannot be authenticated with known CA certificates.

 

I suggest you get your network team to check the firewall.

 

Other community members are welcome to make their suggestions and/or use the search facility.

 

If this all fails please open a ticket via Polycom support.

In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

SCANSOURCE COMMUNICATIONS sold the unit back in 26/07/2018

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 2