Plantronics + Polycom. Now together as Poly Logo

Exchange Autodiscover not working, limitations?

SOLVED
Occasional Advisor

Exchange Autodiscover not working, limitations?

I'm using a VVX601 with Skype for Business Online (Office 365) and Exchange Autodiscover is failing.

 

Our setup is:

  • Primariy SMTP address = SIP = UPN
  • Autodiscover.<SMTP domain> A record
  • http redirect to autodiscover.maildomain.com
  • AD Remote Mailbox object with targetAddress = username@tenant.mail.onmicrosoft.com

This setup is pretty standard and works fine with Outlook and other clients. I suspect the Polycom UC client does either not support the http redirect method, or the second redirect to the targetAddress.

 

I checked the logs on the device but I can't figure out why it's failing:

 

1227115212|ec   |4|00|Email id availability status is 1.
1227115212|ec   |4|00|CSoapTransaction network error = Host  not found (3)
1227115212|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115217|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115217|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115223|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115223|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115231|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115231|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115232|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115232|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115232|ec   |4|00|Auto discovered EWS internal URL is '' and external URL is ''
1227115532|ec   |4|00|CSoapTransaction network error = Host  not found (3)
1227115532|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115537|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115537|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115543|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115543|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115551|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115551|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115552|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115552|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115852|ec   |4|00|CSoapTransaction network error = Host  not found (3)
1227115852|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115857|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115857|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115902|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227115902|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115910|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115910|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227115912|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227115912|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227120112|app1 |4|00|[AppExchangeUiC::populateAutoDiscoverUrl] Internal & External EWS url's are empty
1227120112|ec   |4|00|Removing 'autodisc' service
1227120112|ec   |4|00|'autodisc' service removed
Message 1 of 5
4 REPLIES 4
Occasional Advisor

Re: Exchange Autodiscover not working, limitations?

Raised the logging level for Exchange Client, this added the actual urls to the log. This shows that the HTTP-redirect is working fine, but authentication of the Autodiscover POST fails. The server then tries to use FBA which obviously fails.

 

Does anyone know what authentication method the client uses for Autodiscover?

 

1227161529|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161529|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://domain.com/autodiscover/autodiscover.xml' and method 'POST'
1227161529|ec   |4|00|CSoapTransaction network error = Host  not found (3)
1227161529|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227161529|ec   |3|00|Resetting timer for service 'autodisc' and period 5000
1227161534|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161534|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://autodiscover.domain.com/autodiscover/autodiscover.xml' and method 'GET'
1227161534|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227161534|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227161534|ec   |3|00|Resetting timer for service 'autodisc' and period 5000
1227161539|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161539|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://autodiscover.domain.com/autodiscover/autodiscover.xml' and method 'POST'
1227161539|ec   |4|00|CSoapTransaction network error = Connection refused (1)
1227161539|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227161539|ec   |3|00|Resetting timer for service 'autodisc' and period 5000
1227161544|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161544|ec   |3|00|[EWS AutoDiscover]Querying with URL 'http://autodiscover.domain.com/autodiscover/autodiscover.xml' and method 'GET'
1227161545|ec   |2|00|CSoapTransaction redirect url is = https://autodiscover.servicedomain.com/autodiscover/autodiscover.xml
1227161545|ec   |3|00|[EWS AutoDiscover] Resending request to a new URL [https://autodiscover.servicedomain.com/autodiscover/autodiscover.xml]
1227161545|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161545|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://autodiscover.servicedomain.com/autodiscover/autodiscover.xml' and method 'GET'
1227161546|ec   |2|00|CSoapTransaction redirect url is = https://autodiscover.servicedomain.com/CookieAuth.dll?GetLogon?curl=Z2FautodiscoverZ2Fautodiscover.xml&reason=0&formdir=3
1227161546|ec   |3|00|[EWS AutoDiscover] Resending request to a new URL [https://autodiscover.servicedomain.com/CookieAuth.dll?GetLogon?curl=Z2FautodiscoverZ2Fautodiscover.xml&reason=0&formdir=3]
1227161546|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161546|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://autodiscover.servicedomain.com/CookieAuth.dll?GetLogon?curl=Z2FautodiscoverZ2Fautodiscover.xml&reason=0&formdir=3' and method 'GET'
1227161548|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227161548|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227161548|ec   |3|00|[EWS AutoDiscover]Querying with Email jetze.mellema@domain.com
1227161548|ec   |3|00|[EWS AutoDiscover]Querying with URL 'https://autodiscover.servicedomain.com/CookieAuth.dll?GetLogon?curl=Z2FautodiscoverZ2Fautodiscover.xml&reason=0&formdir=3' and method 'POST'
1227161549|ec   |4|00|CSoapTransaction error parsing SOAP response message, error is "unexpected character", line 1, col 62
1227161549|ec   |4|00|[EWS Autodiscover] WSSecurity header X-WSSecurity-Enabled= and X-WSSecurity-For=
1227161549|ec   |3|00|[EWS AutoDiscover] Resetting the configurations. Retry the discovery after 180000 sec
1227161549|ec   |3|00|Resetting timer for service 'autodisc' and period 180000
Message 2 of 5
Polycom Employee & Community Manager

Re: Exchange Autodiscover not working, limitations?

Software version?

Replied via a mobile device



<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 3 of 5
Occasional Advisor

Re: Exchange Autodiscover not working, limitations?

Apologies, forgot to mention that this accors with 5.4.1.17954.

 

I solved the issue with an upgrade to 5.5.1.11526.

 

By the way, I noticed that my post was edited. Was there a problem with the content?

Message 4 of 5
Polycom Employee & Community Manager

Re: Exchange Autodiscover not working, limitations?

Hello JetzeMellema,

welcome to the Polycom Community.

I simply edited the post to add code tags around the logs.

 

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 5 of 5