Plantronics + Polycom. Now together as Poly Logo

[Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

SOLVED
Occasional Visitor

[Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Hi There
(sorry for my very bad english)
We are using several Polycom Trio 8800 in our Company. I now had to configure a new one for a "new Meetingroom". Well, as always, i Upgrade the new device to the newest firmware, load all our settings and install the device. I got now the error from the customers, that the Calender is not shown on the Polycom Screen. Well, i checked every settings and i just found the different, that on the new Polycom, he does not get the Exchange EWS Data. So, i upgraded an other Trio 8800 to the newest frimware, any everything worked. So, i logged out and logged in again in Skype for Business on the 2nd Device and saw, that i have the same problem now, as on the new one.  So i decided to "Downgrad" the Firmware from 5.9.1.11135 to 5.9.0.11398. Now it works on both devices. But for me, that cant be a final solution. 

I also found the following link: 

https://support.polycom.com/content/dam/polycom-support/products/voice/polycom-uc/other-documents/en...

But if i understand that correctly, that is not an issue of mine.

For better understanding. We have Skype for Business Enterprise. That means, we also can call "normal Numbers" without Skype Account. Our Serverfarm of Skype for Business is "OnSide". But we use Office365. So Exchange and stuff, is reachable over outlook.office365.com, where he needs to connect to get the "Calendar". We also use AzureAD. In the logs there i could see, that the "Connection" Methode with the new Firmware is not the same anymore.


Data from Azure AD

Application ID unsuccessfull (newest Firmware)
a850aaae-d5a5-4e82-877c-ce54ff916282

Application ID phone (older Firmware)
131c22db-3591-4fc8-a305-55444fa5ccd3


Detail Information of "unsuccessfull"
Date
11/29/2019, 8:07:44 AM

Request ID
4326c60c-5782-4bc1-8091-4c85a1570c00

Correlation ID
3c5f2022-21f0-4f5e-baf8-d87885230bc6

Status
Interrupted

Sign-in error code
65001

Failure reason
Application X doesn't have permission to access application Y or the permission has been revoked. Or The user or administrator has not consented to use the application with ID X. Send an interactive authorization request for this user and resource. Or The user or administrator has not consented to use the application with ID X. Send an authorization request to your tenant admin to act on behalf of the App : Y for Resource : Z.

User
***

Username
***

User ID
***

Alternate sign-in name
***

Application
Polycom - Skype for Business Certified Phone

Application ID
a850aaae-d5a5-4e82-877c-ce54ff916282

Resource
Skype for Business Online

Resource ID
00000004-0000-0ff1-ce00-000000000000

Client app
Mobile Apps and Desktop clients

 

 

If i understand everything correctly, AzureAD has problem with the new "Methode" of Polycom. Does anyone know, how on AzureAD i have to configure something or if i need to do something on the Polycom itself?

Message 1 of 7
6 REPLIES 6
Polycom Employee & Community Manager

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Hello @disler ,

 

Welcome to the Poly Community.


Microsoft has announced changes related to the Microsoft Online device registration requirement. These changes affect Polycom Trio 8800 systems registered for Skype for Business accounts. Before upgrading your Microsoft environment Polycom Trio 8800 system to version 5.9.1 Rev AA or later, see the Technical Advisory for specific changes and actions required.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 7
Occasional Visitor

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Hi @SteffenBaierUK

We already tried this with the Application on the AzureAD(your added document).

 

I added a part of the Logfile. As i can see, I got a Error 400 from the EWS.

1202125204|auth |2|00|CAuthSvcUpdateTokenNotifier:: UserMode = [False]
1202125204|auth |2|00|Policy Dest:(201)AuthServicePolicyServiceKey:(106)AuthServiceOAuthMsgKey:(206)AuthSvcAOServiceReplyKey
Caller Service(145)AuthServiceCallerEwsAutoDisc:IndicationCode(400)Failed to Get UT
,TransactionID(1894352632)

Funny fact is, that i have upgraded two Polycom to the newest Firmware to make test. Both have the same settings.

Room A

EWS Information	EWS not deployed
Email	room-one@company.com
Configured Exchange URL	
EWS Internal URL	
EWS External URL	
Exchange Calendar	Not Available
Exchange Call logs	Not Available
Exchange Voicemail	Not Available
Exchange Outlook Contacts	Not Available
Server Missed Call Status	Not Available

Room B

EWS Information	EWS deployed
Email	room-two@company.com
Configured Exchange URL	outlook.office365.com
EWS Internal URL	
EWS External URL	
Exchange Calendar	Not Available
Exchange Call logs	Not Available
Exchange Voicemail	Not Available
Exchange Outlook Contacts	Not Available
Server Missed Call Status	Not Available


There is no differenz between the romm config sections... But also, when EWS is deployed, i do not get the Exchagne Calendar. Any Idea?

Message 3 of 7
Highlighted
Polycom Employee & Community Manager

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Hello @disler ,

 

the next step would be a ticket or stay on the older release.


In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support.

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 7
Occasional Visitor

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Problem has been solved on our side now. You have to do some configuration on Azure and on the Firewall, to make it work. Can be closed for here now :)

Message 5 of 7
Polycom Employee & Community Manager

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

Hello @disler 

 

posting something in the community does not open a support ticket.

 

Best regards

 

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 7
Occasional Visitor

Re: [Firmware Upgrade] Trio 8800 Issue Skype for Business Enterprise

@SteffenBaierUK
I was already in contact with our reseller and polycom support. The problem is solved and the callendar is shown by now.

Message 7 of 7