Plantronics + Polycom. Now together as Poly Logo

Problems with Polycom Communicator CX100 and Windows 10 with Skype for Business

Highlighted
Visitor

Problems with Polycom Communicator CX100 and Windows 10 with Skype for Business

We used round about 60 CX100 with Windows 7 and Lync 2010 on DELL Notebooks without any problems. Now we changed to new DELL Laptops with Windows 10 and Skype for Business 2016 (32bit). we experinece big problems like echoes, surround sound problems, voice funktion stopping and so on. Looks like a system problem. Is there any restriction with CX 100 that are some years old (e.g. old Firmware)?

We know that the driver should come with SfB client (written in this ciommunity!) and we have installed all current updates.

 

Thanks,

Helpdesk DE

Message 1 of 2
1 REPLY 1
Highlighted
Polycom Employee & Community Manager

Re: Problems with Polycom Communicator CX100 and Windows 10 with Skype for Business

Hello Helpdesk DE,

welcome to the Polycom Community.

There are no separate drivers for the CX100 and if the device worked before it can only be the new hardware you are using.

 

Try to disable any special effects via the Sound Card and/or raise a Support Ticket with the laptop vendor if that does not help. 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 2