Plantronics + Polycom. Now together as Poly Logo

Unable to disable automatic device update

SOLVED
Highlighted
Occasional Advisor

Unable to disable automatic device update

Phone Information
Phone ModelVVX 601
Part Number3111-48600-001 Rev:A
MAC Address64:16:7F:37:47:7D
IP ModeIPv4
IP Address192.168.200.6
UC Software Version5.9.0.9373
Updater Version5.9.7.11143

 

Microsoft Teams-only environment.

I'm attempting to prevent automatic update of the UC software from MSFT's provisioning server on this particular phone but having trouble applying the configuration setting I'm importing.

Via the web admin console, I import the attached device setting config file (which was found elsewhere here on Poly's community forum, and I have used many times successfully on other phones). When I subsequently check the device configuration via "export device configuration only" (also attached) from the web admin interface, the value of device.prov.lyncDeviceUpdateEnabled="1", instead of "0", which it was set to in the import, and as a result, the device downgrades itself whenever I attempt to update the UC to a version beyond that which MSFT has provided on their server. 

 

I've attempted to reboot and restart the phone after importing the attached config, but it seems to revert almost immediately back to a value of "1" for the aforementioned parameter - in other words, I can't seem to get it to apply/stick.

 

Can someone advise what I might be doing wrong?

 

Thanks,

Bob

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: Unable to disable automatic device update

Hello @rmanjoney 

 

for your new issue, I suggest you use LyncProvisionDeviceParams. and potentially also add:

<device device.set="1"
	device.prov.upgradeServer.set="1"
		device.prov.upgradeServer="" />

 

aka make this:

<LYNCUpdate device.set="1" 
		device.prov.lyncDeviceUpdateEnabled.set="1" 
		device.prov.lyncDeviceUpdateEnabled="0" 
		lync.provisionDeviceParams.enabled="0" 
		device.prov.upgradeServer.set="1"
		device.prov.upgradeServer=""/>

 

For your older issue your last comment was:

 

  • I'm just letting the OP know that this may not be just an isolated problem and that I and others are seeing it as well, for his benefit and the benefit of others who might have stumbled upon this issue. I intend to report the problem as outlined. 

 

I usually check what previous posts users made and if they have been marked accordingly and therefore ask and never report anything back.

 

We are all volunteers here and if support is required you will need to contact either your reseller and/or Poly support.


End Customers are usually unable to open a ticket directly with Poly support.

 

Available End User Poly services offerings are detailed here

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here


Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 6 of 7
6 REPLIES 6
Highlighted
Polycom Employee & Community Manager

Re: Unable to disable automatic device update

Hello @rmanjoney ,

Welcome back to the Poly community.

Some or a couple of your old post or reply to them => here <= is still open/pending as you have not provided some form of feedback or answer to a Poly Ticket reference or how this was solved.

If they are in this state nobody finding them via a community search will know if an answer or advice provided was useful and has maybe helped you.

Could you therefore kindly go over them and mark or answer as appropriate?

If they are marked as "Accept as a solution" other users can find these easier and it helps them to utilise the community more efficiently. Please do not simply mark them without any type of feedback.

For your new issue, the MAC provided is not a Microsoft SKU and therefore we require either proof of the purchase of a separate per device Microsoft Skype/Lync license.

 

Please be aware of the following when utilizing UCS 4.1.0 or later:

The use of Polycom UC Software versions 4.1.X (“Software”) requires the purchase of a separate Software license for every device that will use the Software in a LYNC / Skype for Business environment. You may not install, access, or use the Software in a LYNC / Skype for Business environment on more devices than are listed on your license until additional licenses have been purchased and authorized by Polycom. These licenses should be purchased from the same company from which you purchased the devices. You may operate devices against a LYNC / Skype for Business server for trial purposes for up to 30 days without purchasing a license. Use of the Software is subject to the terms and conditions of the End User License Agreement.

Polycom reserves the right to audit your deployment to verify that you have sufficient licenses to match the number of devices being used.

Information in regards to License Part Numbers can be found here

 

The phone shows as a VVX601 2200-48600-001 sold by Verizon Business (UK) back in 26/02/2018

 

All phones require either to be a -019 SKU or a separate license which can be purchased.

 

Best regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
Highlighted
Occasional Advisor

Re: Unable to disable automatic device update

I inherited a bunch of phones at this client, apparently some licensed, some not. I believe I just found this same issue with another -019 SKU licensed phone (at least the sticker on the back of the phone says "SKYPE"). I have attached the config for that phone which also is exhibiting the same behavior of not being able to disable auto updating. 

Phone Information
Phone Model
VVX 411
Part Number 3111-48450-001 Rev:A 
MAC Address 64:16:7F:33:DA:09
IP ModeIPv4
IP Address192.168.2.200
UC Software Version 5.9.0.9373
Updater Version 5.9.7.11143


(The other posting that is not marked as "Answered" was never resolved; the client decided to abandon in frustration. I never was able to obtain a support ticket from the original vendor, so there's never been any resolution on that item, and hence it has not been answered. Does this forum has a mechanism to "close" a discussion as "not resolved"? )

Highlighted
Polycom Employee & Community Manager

Re: Unable to disable automatic device update

Hello @rmanjoney ,

 

all of these phones need to purchase the license before they can be used with Skype. This is 15$ per phone.

 

We do not close any topics as this is a simple discussion forum run by volunteers.


Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 7
Highlighted
Occasional Advisor

Re: Unable to disable automatic device update

I'm being told that the license was purchased for this phone, Feb 13th 2017 direct from Poly(com) and that the license # is as follows. Perhaps the purchaser didn't associate the MAC with the license? Regardless:

Polycom Order No 1602888 with license #C1859-9878-5985-7219.


(Can you advise as to what I'm supposed to do about your request to provide feedback about an unrelated open discussion that hasn't been solved? What's the recommended waiting time before giving up on getting an answer from the community? The discussion will still be "open/pending" if no answer is forthcoming regardless, correct?)

Message 5 of 7
Highlighted
Polycom Employee & Community Manager

Re: Unable to disable automatic device update

Hello @rmanjoney 

 

for your new issue, I suggest you use LyncProvisionDeviceParams. and potentially also add:

<device device.set="1"
	device.prov.upgradeServer.set="1"
		device.prov.upgradeServer="" />

 

aka make this:

<LYNCUpdate device.set="1" 
		device.prov.lyncDeviceUpdateEnabled.set="1" 
		device.prov.lyncDeviceUpdateEnabled="0" 
		lync.provisionDeviceParams.enabled="0" 
		device.prov.upgradeServer.set="1"
		device.prov.upgradeServer=""/>

 

For your older issue your last comment was:

 

  • I'm just letting the OP know that this may not be just an isolated problem and that I and others are seeing it as well, for his benefit and the benefit of others who might have stumbled upon this issue. I intend to report the problem as outlined. 

 

I usually check what previous posts users made and if they have been marked accordingly and therefore ask and never report anything back.

 

We are all volunteers here and if support is required you will need to contact either your reseller and/or Poly support.


End Customers are usually unable to open a ticket directly with Poly support.

 

Available End User Poly services offerings are detailed here

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here


Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 6 of 7
Highlighted
Advisor

Re: Unable to disable automatic device update

Hi rmanjoney 

 

You can also follow this Poly document to disable automatic updates globally:

https://support.polycom.com/content/dam/polycom-support/products/voice/polycom-uc/other-documents/en... 

 

Page 7 - Disable Device Updates via Microsoft PowerShell

Message 7 of 7