Plantronics + Polycom. Now together as Poly Logo

Upgrade from UCS 5.4 to 5.9 together with btoe

Highlighted
Occasional Contributor

Upgrade from UCS 5.4 to 5.9 together with btoe

Hello all,

I have another problem. In one site in Germany we still have all our VVX phones running with UCS 5.4. Most of them are using btoe. When I now update to the actual SfB UCS version 5.9.0 btoe pairing is lost since that need at least btoe v3.8. But 3.8 already does not support UCS below 5.8. And even 5.8.0.12848 is not supported by btoe v3.7. So how can I upgrade the firmware without interrupting the users? I can easily distribute a new btoe version to all computers over night but the phones are randomly polling between 2am to 5am and I'm pretty sure that not all 60 will get the firmware update in the same night.

Or maybe I should better ask which is the maximum UCS version supported with 3.7? Is there anywhere a compatibility matrix?

Regards Robert

Message 1 of 5
4 REPLIES 4
Polycom Employee & Community Manager

Re: Upgrade from UCS 5.4 to 5.9 together with btoe

Hello @Robert_D ,

Welcome back to the Poly community.

Some or a couple of your old post(s) or reply(s) to them => here <= are still open/pending as you have not marked these as "Accept as a solution" or at least provide some form of feedback or answer.

If they are in this state nobody finding them via a community search will know if an answer or advice provided was useful and has maybe helped you.

Could you therefore kindly go over them and mark or answer as appropriate?

If they are marked as "Accept as a solution" other users can find these easier and it helps them to utilise the community more efficiently. Please do not simply mark them without any type of feedback.

 

For your new issue check >here<

 

Btw. UC Software 5.9.5 is the latest software for Skype for Business.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 5
Occasional Contributor

Re: Upgrade from UCS 5.4 to 5.9 together with btoe

Hi Steffen,

 

thanks for the fast answer and sorry for missing the reply on my old post. I have corrected that.

But for my actual Problem the support Matrix does not help me only for future updates. I still have Btoe 3.7 maximum and UCS 5.4 and I need a valid update path for these. So update UCS to some version which is still compatible with btoe 3.7 and then a few days later update btoe to a newer version which is still compatible with the then current UCS version and then another few days later finally update UCS to 5.9.

BTW: As ususual I'm struggling to find and understand the correct UCS version for SfB. Here is stated Polycom UC Software 5.9.0.9373 -Latest Maintenance Release UCS 5.9.5.0614 and on this page I can download 5.9.0.9373 where the link to 5.9.5 leeds to the general UCS page where I could also download 6.1. Am I correct assuming that MS apporves only Major and minor releases like 5.7, 5.9 or 6.1 but no maintenace release from the 3 digit onwards? Then it would be pretty convinient to link the latest approved release like in this case 5.9.5.0614 directly on the UCS page for SfB.

Regards Robert

Message 3 of 5
Polycom Employee & Community Manager

Re: Upgrade from UCS 5.4 to 5.9 together with btoe

Hello @Robert_D ,

 

I can only refer you to the Skype for Business FAQ:

 

Nov 6. 2019 Question: Is there a difference between the Software Microsoft supplies via Skype for Business to other versions supplied by Poly?

Resolution: Microsoft does not always host the latest software. Poly supported software for Skype for Business can always be found >here< and questions around support are answered >here<. In order to prevent Skype to downgrade the software check => here <=

 

We, Poly, support Skype for Business with UC Software 5.9.5.

 

We have customers who run 6.1.0 for specific issues or features with Skype for Business on Premise. Microsoft has not approved any software later than 5.9.5 on Skype for Business online and actively blocks the registration of these.

 

BToE should always be backward compatible.

 

If you still struggle please work with your Polycom reseller.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 5
Occasional Contributor

Re: Upgrade from UCS 5.4 to 5.9 together with btoe

Hi Steffen,

sorry but BToE is NOT backwards compatible. Here it is clearly stated:

"If you are running UC Software versions earlier than version 5.8.0 with BToE Connector 3.8.0, any
mode of pairing is strictly not supported. Pairing with BToE Connector 3.8.0 is only supported from
UC Software 5.8.0 or later"

And that is also according with my tests. You need to do a simultaneous update of btoe 3.7 to 3.8 and UCS 5.7 to 5.8. From there on all combinations work again.

 

So I will contact my polycom reseller for support.

Regards Robert

Message 5 of 5