Plantronics + Polycom. Now together as Poly Logo

Upgrade to 5.4.2 RTS12D version still use the old customized.cfg file

Highlighted
Occasional Advisor

Upgrade to 5.4.2 RTS12D version still use the old customized.cfg file

We are using a Windows 2012 server dedicated for Polycom provisioning and its version is

5.4.0.5841.
 
That 0000000000.cfg file is using a customization.cfg file which includes many customization settings.
 
I downloaded the 5.4.1 version before Christmas and put it under a subfolder like below:
C:\inetpub\wwwroot\PolycomProvisioning\Polycom_UC_Software_5_4_1_rts55_release_sig_split
I created a ucs.xml file include the version and path like below:
 
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<PHONE_IMAGES>
  <REVISION ID="">
    <PHONE_IMAGE>
      <VERSION>5.4.1.14510</VERSION>
      <PATH>http://polycom.air.abc.com/Polycom_UC_Software_5_4_1_rts55_release_sig_split/</PATH>
    </PHONE_IMAGE>
  </REVISION>
</PHONE_IMAGES>
 
Then I logged into a test phone's webpage https://172.16.7.8, login as admin
choose Utilitise -- software upgrade, server type choose custom server, custom server address put:
Then click Install, accept, all went well.
The phone rebooted, and I saw a new interface and welcome message which is different with current other phones in 5.4.0.5841.
 
However after 4 months today when i tried to do that again towards several other phones, those phones after upgrade there were no welcome messages nor interface changes, just like the upgrade did not happen.
 
But upon checking the version it shown as newer version, but that new version i guess it is retrieve from what I put in the ucs.xml but not really from the installation files.
Exactly same files but before Christmas I saw the interface change and welcome message but now there are none, no any changes so far as i can see.
I downloaded again and replace the files, I downloaded the 5.4.2 R2 version which is the latest one, put them in another folder and test accordingly, still, there were no errors, all seems success, but just no interface changes at all.
 
The other thing I noticed is that upon checking those upgraded phones, Settings -- Status -- Platform -- Configuration
They are still using the old configuration files, which is under
C:\inetpub\wwwroot\PolycomProvisioning folder for the old exisiting system.
But not using the upgrade new system path as I pointed them to in the webpage, which is
C:\inetpub\wwwroot\PolycomProvisioning\Polycom_UC_Software_5_4_1_rts55_release_sig_split
Which doesn't have a customization.cfg, jsut come naturally with factory 000000000000.cfg.
 
Anyone see this ?
 
Message 1 of 4
3 REPLIES 3
Highlighted
Polycom Employee & Community Manager

Re: Upgrade to 5.4.2 RTS12D version still use the old customized.cfg file

Hello kuberk,

I suggest you check the phone <mac>-app.log on the server and your IIS logs to see what the phone is actually downloading.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 4
Highlighted
Occasional Advisor

Re: Upgrade to 5.4.2 RTS12D version still use the old customized.cfg file

The IIS logs shown the IP address of the test phone is getting config files from the main folder, not the subfolder where I point them to.

 

From the phone's log it shown as below, just prior to the phone finishes reboot.

 

000333.285|log  |*|00|Install file upload callback for 'so'
000333.513|clist|*|00|Initial log entry. Current logging level 4
0317140250|wdog |*|00|Failed to open Hw watchdog interface from polyapp, Error: Device or resource busy

 

I also noticed below error saying failed to update serialconfig

 

000331.012|cfg  |4|00|RT|cfgFlashUpdateFromConfig: Failed to update SerialConfig
000331.042|cfg  |*|00|Prov|Finished updating configuration
000331.043|sec  |*|00|Initial log entry. Current logging level 4
000331.045|so   |*|00|Configuration files: customisations.cfg

 

Message 3 of 4
Highlighted
Polycom Employee & Community Manager

Re: Upgrade to 5.4.2 RTS12D version still use the old customized.cfg file

Hello kuberk,

These error or log messages are not relevant to the actual issue at hand.

 

I suggest you lower the CURL and COPY logging levels and maybe use a syslog server to capture the data from the phone when booting.

 

Something in your configuration or logic of the setup is incorrect and needs fixing and you should consider contacting your Polycom reseller as they are your Tier 1 support contact.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 4