cancel
Showing results for 
Search instead for 
Did you mean: 

VVX 400 SfB Online won't connect

Occasional Advisor

VVX 400 SfB Online won't connect

We're new to Polycom phones and I purchased a VVX 400 to test with SfB Online, for which I know I have the proper licenses set up (we're fully cloud but migrated from OCS on-prem years ago).  The phone has 5.4.0.10182, it's paired with BToE and gets a valid IP, I set up a firewall rule to allow all traffic from its IP and I can see outbound 5061 and 5067 packets, but it nearly always hangs on the sign-in screen and fails.  However, it was (seemingly randomly) signed in once when I came into work after this weekend, and worked as expected (I tested calling, VM and contacts) until I rebooted it, and it then returned to its previous pattern of sign-in failures.  I also have a VVX 310 which has always failed sign-in as well.  The fact that the VVX 400 was successful once makes me think that maybe it's a DNS or some other connectivity issue, but I'm at a loss as to how to troubleshoot next.  I also turned on DNS auditing on my internal DNS server and saw that records were being requested and returned...I believe that all of the required SfB Online DNS records are properly set up for us (https://testconnectivity.microsoft.com says so, anyway). My additional questions:

 

  1. Am I required to set up a local provisioning server with customized configs for phones even if I don't anticipate needing to change anything from defaults?
  2. I see a lot of log data being posted on the community site - is that captured via the provisioning server or from on-prem SfB, and what's the process for configuring logging?
  3. Does Polycom offer a network config checking tool like Microsoft does, which can simulate and diagnose the SfB Online connection process from their phones?  I don't expect that they do, but if not, they absolutely should. :)

Any help would be appreciated, I've burned countless hours trying to get things running.

Message 1 of 10
9 REPLIES
Polycom Employee & Community Manager

Re: VVX 400 SfB Online won't connect

Hello cseaman,

welcome to the Polycom Community.

  1. No you do not need a provisioning server but it makes things easier.

  2. Have a look at the newly created FAQ => here <=

  3. No we do not


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 2 of 10
Occasional Advisor

Re: VVX 400 SfB Online won't connect

Below are what I think are the relevant logs...what would cause the SSL_get_error Error code=5,rc(-1)?  Is that the core of the problem?

 

0117132648|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'fivestardev.com' found no records
0117132648|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'fivestardev.com' found no records
0117132648|sip |4|00|doDnsListLookup(tls): doDnsSrvLookupForARecordList 'sipinternal.fivestardev.com' found no records
0117132648|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipinternal.fivestardev.com' found no records
0117132648|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipexternal.fivestardev.com' found no records
0117132648|sip |*|00|User removed
0117132653|sip |4|00|Failed to connect to [132.245.1.25:5067] : Error[Operation now in progress]
0117132653|sip |4|00|SSL_get_error Error code=5,rc(-1)
0117132653|sip |4|00|TLS Listen Thread Exit
0117132653|sip |5|00|Send SSL_get_error nLen -1 nError 5 = error:00000000:lib(0):func(0):reason(0)
0117132701|cfg |5|00|Prm|Parameter feature.broadsoftUcOne.enabled requested type 2 but is of type 7
0117132716|sip |4|00|Registration failed User: cseaman, Error Code:480 Temporarily not available
0117132735|cfg |4|00|Prov|[CfgLyncSipSrvDiscover::cbFoundOption] Invalid STS-URI: '://:'
0117132735|cfg |4|00|Prov|[CfgLyncSipSrvDiscover::cbFoundOption] Invalid STS-URI: '://:'
0117132739|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'fivestardev.com' found no records
0117132739|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'fivestardev.com' found no records
0117132739|sip |4|00|doDnsListLookup(tls): doDnsSrvLookupForARecordList 'sipinternal.fivestardev.com' found no records
0117132739|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipinternal.fivestardev.com' found no records
0117132739|sip |4|00|doDnsListLookup(tcp): doDnsSrvLookupForARecordList 'sipexternal.fivestardev.com' found no records
0117132744|sip |4|00|Failed to connect to [52.112.64.140:5067] : Error[Operation now in progress]
0117132744|sip |4|00|SSL_get_error Error code=5,rc(-1)
0117132744|sip |4|00|TLS Listen Thread Exit
0117132744|sip |5|00|Send SSL_get_error nLen -1 nError 5 = error:00000000:lib(0):func(0):reason(0)
0117132832|cfg |4|00|Prov|[CfgLyncSipSrvDiscover::cbFoundOption] Invalid STS-URI: '://:'

 

Message 3 of 10
Polycom Employee & Community Manager

Re: VVX 400 SfB Online won't connect

Hello cseaman,

I believe the referenced FAQ should be informative enough for you to troubleshoot this

Replied via a Mobile Device
Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 4 of 10
Occasional Advisor

Re: VVX 400 SfB Online won't connect

The FAQ got me to the point of logging at the DEBUG level, but I'm still not sure of the cause...it's able to establish a TLS connection and send a SIP message, but then it encounters an error.  Not sure if I need to set any other modules to Debug logging or not...the relevant portion is here with suspect sections highlighted, I can send the full log if needed.  Ideas?

 

0117135504|sip |3|00|Open socket 172(0x40e33528)
0117135504|sip |1|00|SetRemoteAddress set SND BUF to 64000 OK
0117135504|sip |1|00|SetRemoteAddress set SEND TIMEOUT to 100ms OK
0117135504|sip |3|00|SetRemoteAddress OK on try 1 nPort 43941 0x40e33528
0117135504|sip |3|00|CTcpSocket::ConnectThreadLocal. Trying to connect IP 52.112.64.140:5061
0117135504|sip |1|00|Task name tTCPCnt172
0117135504|sip |1|00|CTcp::Send(TLS) exit for address 52.112.64.140 port 5061 can Connect 1 status 1 canFailOver 1 FoundSocket 0
0117135504|sip |2|00|CTrans::InitRetrans for UA Client Non-INVITE REGISTER state 'callingTrying' Server 2 of 19 (0x40e35e68)
0117135504|sip |3|00|CTcpSocket::~CTcpSocket socket 165(0x40e37568) close
0117135504|sip |3|00|connectNonBlock is successful
0117135504|sip |1|00|MsgSipTcpSocketStatus socket 172 status 1 m_bIsReconnectNeeded 0
0117135504|sip |2|00|CTcpSocket::OnSocketStatus socket 172(0x40e33528) bStatus 1
0117135504|sip |2|00|MakeTlsConnection: SSL_connect OK : TLS Handshake completed successfully
0117135504|sip |1|00|[TLS] hostname we are connected to is: 'sipdir.online.lync.com.' IP '52.112.64.140' port 5061
0117135504|sip |3|00|[TLS] Validating Subject Alternative Name(s) (SAN) and Common Name (CN) against the following:
0117135504|sip |3|00|[TLS] Hostname: fivestardev.com
0117135504|sip |3|00|[TLS] Outbound Proxy: fivestardev.com
0117135504|sip |3|00|[TLS] Hostname connection: sipdir.online.lync.com.
0117135504|sip |1|00|[TLS] Comparing certificate SAN type DNS: 'sipfed.online.lync.com'
0117135504|sip |1|00|[TLS] Comparing certificate SAN type DNS: '*.online.lync.com'
0117135504|sip |3|00|[TLS] Allowing Server certificate with Specifc SN/SAN
0117135504|sip |3|00|[TLS] Validating certificate SAN of type DNS with '*.online.lync.com'
0117135504|sip |3|00|[TLS] Server Certificate SAN or CN validation success. SSL verify result 0
0117135504|sip |1|00|MakeTlsConnection: post_connection_checks passed
0117135504|sip |3|00|MakeTlsConnection: connection succeeded
0117135504|sip |4|00|SSL_get_error Error code=1,rc(-1)
0117135504|sip |4|00|TLS Listen Thread Exit
0117135504|hw |4|00|rtosLinuxTask: tTLSListen172 - Cannot get attr, errno <3:No such process>
0117135504|hw |5|00|rtosLinuxTask: tTLSListen172 - Cannot set scheduling policy, priority 48, errno <3:No such process>
0117135504|sip |0|00|>>> Data Send TLS 52.112.64.140:5061
0117135504|sip |0|00| REGISTER sip:fivestardev.com;transport=tls SIP/2.0
0117135504|sip |0|00| Via: SIP/2.0/TLS 10.10.10.117:43941;branch=z9hG4bKa3d08d5858121A61
0117135504|sip |0|00| From: "xxxxxxxx" <sip:xxxxxxxx@fivestardev.com>;tag=54B40622-7D88D973;epid=0004f2c9b1f4
0117135504|sip |0|00| To: <sip:xxxxxxxx@fivestardev.com>
0117135504|sip |0|00| CSeq: 1 REGISTER
0117135504|sip |0|00| Call-ID: 14e9a85e-650c8f5f-e907acb4@10.10.10.117
0117135504|sip |0|00| Contact: <sip:xxxxxxxx@10.10.10.117:43941;transport=tls>;methods="INVITE, ACK, BYE, CANCEL, OPTIONS, INFO, MESSAGE, SUBSCRIBE, NOTIFY, PRACK, UPDATE, REFER, BENOTIFY";proxy=replace;+sip.instance="<urn:uuid:aec4167c-240c-5ccd-935b-948bbe0194cb>"
0117135504|sip |0|00| User-Agent: Polycom/5.4.0.10182 PolycomVVX-VVX_400-UA/5.4.0.10182
0117135504|sip |0|00| Accept-Language: en
0117135504|sip |0|00| Ms-device-info: MAC=00-04-F2-C9-B1-F4, vendor=POLYCOM, version=PolycomVVX-VVX_400-5.4.0.10182
0117135504|sip |0|00| ms-keep-alive: UAC;hop-hop=yes
0117135504|sip |0|00| Supported: msrtc-event-categories,adhoclist,ms-cluster-failover,ms-userservices-state-notification,gruu-10,gruu
0117135504|sip |0|00| Event: registration
0117135504|sip |0|00| ms-subnet: 10.10.10.0
0117135504|sip |0|00| Max-Forwards: 70
0117135504|sip |0|00| Content-Length: 0
0117135504|sip |0|00|
0117135504|sip |1|00|CTcpSocket::SendData TLS queuedTxData = 0 TotalLen 966 loop count 1 maxQueueDepth 40000
0117135504|sip |1|00|CTcpSocket::SendData TLS Sent -1 loop count 1
0117135504|sip |5|00|Send SSL_get_error nLen -1 nError 5 = error:00000000:lib(0):func(0):reason(0)
0117135504|sip |1|00|MsgSipTcpSocketStatus socket 172 status 0 m_bIsReconnectNeeded 0
0117135504|sip |2|00|CTcpSocket::OnSocketStatus socket 172(0x40e33528) bStatus 0
0117135504|sip |3|00|CTcpSocket::~CTcpSocket socket 172 entry for 0x40e33528
0117135504|sip |3|00|CTcpSocket::~CTcpSocket socket 172(0x40e33528) SSL_shutdown rc=-1, ltf(1)
0117135504|sip |3|00|CTcpSocket::~CTcpSocket socket 172(0x40e33528) close
0117135504|sip |3|00|CTcpSocket::~CTcpSocket Got lock
0117135527|sip |1|00|CTrans::TimeOut500ms m_nMainTimeoutCount == 0. Call SndMsgFail
0117135527|sip |3|00|CTrans::TimeOut500ms Self Generated 480 Response
0117135527|sip |3|00|UA Client Non-INVITE REGISTER trans state 'callingTrying'->'completed' by 480 resp 10 timeout(0x40e35e68)
0117135527|sip |2|00|CTrans:: REGISTER NonInv reTrans ALREADY stopped in 'completed' state at retryCount 0 code 480, timeout=10 (0x40e35e68)
0117135527|sip |1|00|CTrans:: ResponseProcess | Follow SIP logic
0117135527|sip |3|00|CTrans::ResponseProcess Self Generated 480. RROFO Invalidate Registration
Message 5 of 10
Polycom Employee & Community Manager

Re: VVX 400 SfB Online won't connect

Hello cseaman,

The Phone is able to send a Register message but the server is not responding:

 

0117135527|sip |3|00|UA Client Non-INVITE REGISTER trans state 'callingTrying'->'completed' by 480 resp 10 timeout(0x40e35e68)

After a certain time period we time out and send a 480 Error.

 

I can only assume this is some sort of firewall issue and you need to work with your local IT team to troubleshoot this.


Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 6 of 10
Occasional Advisor

Re: VVX 400 SfB Online won't connect

I am the local IT team, and trust me, the pipes are wide open. :)

 

Interestingly, I tried upgrading to the latest UC software, and guess what?  It worked right away.  Same with the VVX 310.  If other people run into similar issues, please suggest upgrading if it's feasible.  Now I just hope these phones don't end up getting automatically downgraded.

 

Last question:  The phone after 12 hours, the phone hasn't stopped showing a "Contacts: Synchronizing" message and a green "link" icon with a warning exclamation icon.  What problem and solution are behind that?

 

Thanks for the help!

Message 7 of 10
Polycom Employee & Community Manager

Re: VVX 400 SfB Online won't connect

Hello cseaman,

This should be dealt with in a different topic but I am running out of things that I can provide for free with this community.

 

You are more than welcome to post more logs in a new post but you should really open a ticket via your reseller.

 

This is free within warranty and requires a PPI / Pay Per Incident if outside of warranty,


A MAC I checked for you shows this was sold via WESTCON GROUP EUROPEAN OPERATIONS LTD back in 05/01/2016 so please work with them.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 8 of 10
Highlighted
Occasional Advisor

Re: VVX 400 SfB Online won't connect

I get it - and whether or not this is the place for feedback, I'll give you mine so you can forward it appropriately.  We were forced to deal with the reseller model in our old Mitel infrastructure, and it was an extremely poor experience.  For SMBs like us that are eager for simpler telecom solutions, the fact that at long last they're actually being cheaply delivered by Microsoft and others will (or should) force you guys to reconsider how you work directly with end users.

 

I grabbed my phones at retail from Amazon and will get the rest that way, I'm going to support them with a limited IT staff, and I'm really not going to be interested in tracking down resellers if I have to deal with warranty support.  But as the sole moderator of a community web site with the task of walking the narrow line you're being asked to walk regarding support, I'm sure you've seen that shift happening in recent years and I'm not telling you anything you don't know already. :)

 

Still, I appreciate the support you've been able to provide, and this community forum is a very useful resource.  Thanks again.

Message 9 of 10
Polycom Employee & Community Manager

Re: VVX 400 SfB Online won't connect

Hello cseaman,

Being a moderator is not my job and just a hobby. I am doing this in my free time etc. This has been explained on multiple occasions and there is only so much that I can do.

 

Mar 8, 2012 Question: What kind of support should I expect from the Community?
Clarification: Please check => here <=

 

The above explains this in detail.

 

If you are a SMB please provide me with your details via a private message and I can forward that to the relevant team to see if you can be added to our partners.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

Please be aware:

The purpose of these forums is to allow community members collaborate and help each other.
Questions posted here do not follow Polycom’s SLA guidelines.
If you require assistance from Polycom technical support, please open a
web service request or call us .

The above is necessary in order to track issue internally within Polycom.

You are welcome to post more questions or configuration or logs for other community members to look at but if your issue requires a fix via Polycom you must go via the official support structure.

Please ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Polycom employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.
Message 10 of 10