Plantronics + Polycom. Now together as Poly Logo

VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

SOLVED
Highlighted
Advisor

VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Hi,

I have deployed a FileZilla provisioning server.  I have DHCP configured on my network.  If I boot up a VVX500 or VVX600 it will boot up, automatically begin downloading new UC Software / Firmware if a newer version is available, pull the configuration file, everything works accordingly.  When I boot up a VVX 410 in the same scenario, it doesn't seem to automatically provisionion.  The phone will boot up successfully in it's default configuration.  If I manually define a provisioning server the phone will reboot, pull new UCS Software / Firmware, do it's configuration, and everything is fine.  What can I do to make it work by default?  My hunch is i am missing something in my master configuration file.

Thanks

-Matt

 

Here is my master configuration file (000000000000.cfg)

 

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<!-- Default Master SIP Configuration File-->
<!-- For information on configuring Polycom VoIP phones please refer to the -->
<!-- Configuration File Management white paper available from: -->
<!-- http://www.polycom.com/common/documents/whitepapers/configuration_file_management_on_soundpoint_ip_phones.pdf -->
<!-- $RCSfile$ $Revision: 135829 $ -->
<APPLICATION APP_FILE_PATH="software/release/sip.ld" CONFIG_FILES="configuration.cfg, qos.cfg" MISC_FILES="" LOG_FILE_DIRECTORY="logs" OVERRIDES_DIRECTORY="overrides" CONTACTS_DIRECTORY="contacts" LICENSE_DIRECTORY="" USER_PROFILES_DIRECTORY="" CALL_LISTS_DIRECTORY="calls">
<APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_213.ld" CONFIG_FILES_SPIP300="phone1_213.cfg, sip_213.cfg" />
<APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_213.ld" CONFIG_FILES_SPIP500="phone1_213.cfg, sip_213.cfg" />
<APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP320 APP_FILE_PATH_SPIP320="sip_334.ld" CONFIG_FILES_SPIP320="" />
<APPLICATION_SPIP330 APP_FILE_PATH_SPIP330="sip_334.ld" CONFIG_FILES_SPIP330="" />
<APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_327.ld" CONFIG_FILES_SPIP430="phone1_327.cfg, sip_327.cfg" />
<APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SPIP670 APP_FILE_PATH_SPIP670="sip_403.ld" CONFIG_FILES_SPIP670="" />
<APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000="phone1_318.cfg, sip_318.cfg" />
<APPLICATION_SSIP6000 APP_FILE_PATH_SSIP6000="sip_404.ld" CONFIG_FILES_SSIP6000="" />
<APPLICATION_SSIP7000 APP_FILE_PATH_SSIP7000="sip_403.ld" CONFIG_FILES_SSIP7000="" />
</APPLICATION>
Message 1 of 7
6 REPLIES 6
Polycom Employee

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Matt, all the VVX phones use the initial <APPLICATION> tag to find their configuration information so if it's working for one phone then it'll work the same for all models.

 

My best guess is that the 410 is not getting the provisioning server location due to it being a different SKU than the other phones which will look at a different custom DHCP Option for the provisioning server URL. You may be using DHCP Option 160 and the phone that is not working is looking at 161 bt default, or vice versa.  

 

Take a look at the customer configuration on the phone to insure that the same customer value is configured on all phones.

-
Jeff Schertz - Microsoft Solutions Architect [Blog]
Message 2 of 7
Advisor

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Thanks for the reply Jeff!  I was only using option 160, once i basically added option 161 it worked perfectly.  Thanks again!

Message 3 of 7
Frequent Advisor

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Sorry but can you eplain me why our 200 & more old VVX500 automatically get the DHCP option 160 and the new ones we have just receive doesn't work ?

 

What I have to do if I don't want to set option 161 for new phones ?

 

Message 4 of 7
Polycom Employee & Community Manager

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Hello Doum,

welcome back to the Polycom Community.

The "original" Polycom provisioning method prior to introducing separate LYNC / Skype for Business Hardware was always Option 160 and then fall back to Option 66.

 

Since the introduction of the separate LYNC / Skype for Business Hardware we utilize Option 161 and then fall back to Option 66.

 

This ensures that customer using the VVX phones for SIP whilst moving to LYNC / Skype for Business can do this seamlessly.

 

In order to change this you need to pre-provision the phone using device.set parameters to change the DHCP Option.

 

device.set
device.dhcp.bootSrvOpt.set="1"
device.dhcp.bootSrvOpt="160"

Please remember that for the 200+ Phones you already use with LYNC / Skype that you require the relevant per phone Licenses from Polycom.

 

Your known Sales Engineer can be consulted for any follow up questions.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 5 of 7
Frequent Advisor

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Ok so for us the easiest solution is to set option 160 & option 161 with the same provisioning server so all our phones will work

 

 

Message 6 of 7
Polycom Employee & Community Manager

Re: VVX410 wont automatically provision/update firmware/configure, VVX500/600 do.

Hello Doum,

 

yes, simply copy the Option 160 and create a Option 161 as well.

 

Please ensure you have the relevant licenses for the phones not in LYNC SKU.


Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 7 of 7