Plantronics + Polycom. Now together as Poly Logo

VVX501 Lync/Skype Directory Search Fails

Occasional Advisor

VVX501 Lync/Skype Directory Search Fails

All the VVX501 phones in our environment are unable to utalize the Lync Directory search. Every attempted search shows the follow: "No Search Results".  The logs show the below information when a Lync Directory search is performed.  The directory search works as intended when using the computer client but not on any of the phones.

 

0113132052|abs |1|00|[CAbsDirectory::getContacts] sending message to abs task
0113132052|abs |1|00|[CAbsDirectory::processFetchTaskMsg] recieved message of type 1
0113132052|abs |1|00|[CAbsDirectory::getContactsFromServer] invoking so webticket api for fetching contacts for John search string
0113132052|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/public.crt doesn't exist or is empty
0113132052|tickt|5|00|soWebTicketTicketGetWithclientCert: Could not load the client cert file
0113132052|tickt|5|00|soWebTicketABSQueryUsingWebTicket: soWebTicketTicketGetWithclientCert Failed. Unable to get webTicket
0113132052|abs |4|00|[CAbsDirectory::getContactsFromServer] received empty response or error code = 6

 

Phone Model: VVX501

UC Software Version: 5.4.5.6770

 

Has anyone else encountered this issue?

Message 1 of 13
12 REPLIES 12
Polycom Employee & Community Manager

Re: VVX501 Lync/Skype Directory Search Fails

Hello BDengler,

welcome to the Polycom Community.

 

  • Did this ever work or is this a day one issue?
  • Have you tested UC Software 5.5.1 yet?
  • Is this Extension & Pin or Single Sign In / SSI?


Please change the logging to:

 

Settings > Logging > Global Log Level Limit > Debug
Settings > Logging > Log File Size (Kbytes) > 160
Settings > Logging > Module Log Level Limits > LYNC ABS > Debug
Settings > Logging > Module Log Level Limits > Web Ticket > Debug


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 13
Occasional Advisor

Re: VVX501 Lync/Skype Directory Search Fails

Hi Steffen,

 

Thank you for your response.  Please see my answers and some addition information below.

 

  • Did this ever work or is this a day one issue?  
    • This worked at one point in the pilot stages of this project but stopped working before we began any of the rollout.
  • Have you tested UC Software 5.5.1 yet?
    • Yes, the results are the same with the new firmware.
  • Is this Extension & Pin or Single Sign In / SSI?
    • We are using BToE to login to the phone.

I increased the logging and below are the results when initiating a search:

 

0117115317|abs |0|00|[CAbsDirectory::getContacts]
0117115317|abs |1|00|[CAbsDirectory::getContacts] sending message to abs task
0117115317|abs |1|00|[CAbsDirectory::processFetchTaskMsg] recieved message of type 1
0117115317|abs |0|00|[CAbsDirectory::getContactsFromServer]
0117115317|abs |1|00|[CAbsDirectory::getContactsFromServer] invoking so webticket api for fetching contacts for John search string
0117115317|tickt|0|00|soWebTicket: msg deadbeaf 0 0 b5ab3708
0117115317|tickt|1|00|soWebTicketABSMexDocGet: request URI is https://<INTERNAL_URL>:443/groupexpansion/service.svc/mex
0117115317|tickt|0|00|Ntlm Version Mode = 2:NTLMv2
0117115317|tickt|1|00|Provisioning:Cipher suite = ALL:!aNULL:!eNULL:!DSS:!SEED:!ECDSA:!IDEA:!MEDIUM:!LOW:!EXP:!ADH:!ECDH:!PSK:!MD5:!RC4:@STRENGTH
0117115317|tickt|1|00|soWebTicketABSMexDocGet: Got response 1 code 200
0117115317|tickt|0|00|Got response 1 code 200 data:
<?xml version="1.0" encoding="utf-8"?><wsdl:definitions name="Service" targetNamespace="DistributionListExpander" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressing/p
0117115317|tickt|3|00|soWebTicketLISMexDocGet: WebTicketMexAddress is https://<INTERNAL_URL>/WebTicket/WebTicketService.svc
0117115317|tickt|1|00|soWebTicketABSMexDocGet: request URI is https://<INTERNAL_URL>:443/groupexpansion/service.svc/mex
0117115317|tickt|0|00|Ntlm Version Mode = 2:NTLMv2
0117115317|tickt|1|00|Provisioning:Cipher suite = ALL:!aNULL:!eNULL:!DSS:!SEED:!ECDSA:!IDEA:!MEDIUM:!LOW:!EXP:!ADH:!ECDH:!PSK:!MD5:!RC4:@STRENGTH
0117115317|tickt|1|00|soWebTicketABSMexDocGet: Got response 1 code 200
0117115317|tickt|0|00|Got response 1 code 200 data:
<?xml version="1.0" encoding="utf-8"?><wsdl:definitions name="Service" targetNamespace="DistributionListExpander" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressing/p
0117115317|tickt|3|00|soWebTicketLISMexDocGet: WebTicketMexAddress is //<INTERNAL_URL>/groupexpansion/service.svc/WebTicket_Bearer
0117115317|tickt|1|00|soWebticketGetAllUserInfo: hack prepended https: to the web ticket PIN service URL
0117115317|tickt|1|00|soWebTicketABSCertURIGet: request URI is https://<INTERNAL_URL>/WebTicket/WebTicketService.svc/mex
0117115317|tickt|0|00|Ntlm Version Mode = 2:NTLMv2
0117115317|tickt|1|00|Provisioning:Cipher suite = ALL:!aNULL:!eNULL:!DSS:!SEED:!ECDSA:!IDEA:!MEDIUM:!LOW:!EXP:!ADH:!ECDH:!PSK:!MD5:!RC4:@STRENGTH
0117115317|tickt|1|00|soWebTicketABSCertURIGet: Got response 1 code 200
0117115317|tickt|0|00|Got response 1 code 200 data:
<?xml version="1.0" encoding="utf-8"?><wsdl:definitions name="WebTicketService" targetNamespace="http://tempuri.org/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressi
0117115317|tickt|3|00|soWebTicketABSCertURIGet: WebTicketMexAddress is //<INTERNAL_URL>/WebTicket/WebTicketService.svc/cert
0117115317|tickt|1|00|soWebticketGetAllUserInfo: hack prepended https: to the web ticket PIN service URL
0117115317|tickt|0|00|soWebTicket: msg deadbeaf 0 0 b0e33988
0117115317|utilm|4|00|uBLFUnCompressed: File /ffs0/Config/Local/WebTicket/0/public.crt doesn't exist or is empty
0117115317|tickt|5|00|soWebTicketTicketGetWithclientCert: Could not load the client cert file
0117115317|tickt|5|00|soWebTicketABSQueryUsingWebTicket: soWebTicketTicketGetWithclientCert Failed. Unable to get webTicket
0117115317|abs |4|00|[CAbsDirectory::getContactsFromServer] received empty response or error code = 6
0117115317|abs |1|00|[CAbsDirectory::processFetchTaskMsg] waiting for message

 

Message 3 of 13
Polycom Employee & Community Manager

Re: VVX501 Lync/Skype Directory Search Fails

Hello BDengler,

I am unsure if you obscured these on purpose or if these URL's are not set:

 

0117115317|tickt|3|00|soWebTicketLISMexDocGet: WebTicketMexAddress is https://<INTERNAL_URL>/WebTicket/WebTicketService.svc
0117115317|tickt|3|00|soWebTicketLISMexDocGet: WebTicketMexAddress is //<INTERNAL_URL>/groupexpansion/service.svc/WebTicket_Bearer
0117115317|tickt|3|00|soWebTicketABSCertURIGet: WebTicketMexAddress is //<INTERNAL_URL>/WebTicket/WebTicketService.svc/cert

but as a result:

 

0117115317|tickt|5|00|soWebTicketTicketGetWithclientCert: Could not load the client cert file
0117115317|tickt|5|00|soWebTicketABSQueryUsingWebTicket: soWebTicketTicketGetWithclientCert Failed. Unable to get webTicket
0117115317|abs |4|00|[CAbsDirectory::getContactsFromServer] received empty response or error code = 6
0117115317|abs |1|00|[CAbsDirectory::processFetchTaskMsg] waiting for message


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 13
Occasional Advisor

Re: VVX501 Lync/Skype Directory Search Fails

Hi Steffen, 

 

Yes, the web addresses below were obscured on purpose.  The addresses are correct and point to the internal website of our Skype Front End pool.

 

Let me know if you have any other thoughts for the webticket issue.

 

Thanks!

 

 

Bradley

Message 5 of 13
Polycom Employee & Community Manager

Re: VVX501 Lync/Skype Directory Search Fails

Hello Bradley,

 

I am running out of things that I can provide for free with this community.

 

You are more than welcome to post more logs in a new post but you should really open a ticket.

In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

If this is some sort of an Internet discounter please post your phone's MAC address so I can look up who would be able to support you.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 13
Occasional Advisor

Re: VVX501 Lync/Skype Directory Search Fails

Hi Steffen,

 

I completly understand.  Thanks for your assistance!

 

Bradley

Message 7 of 13
Advisor

Re: VVX501 Lync/Skype Directory Search Fails

Turn on your address book service

 

feature.lync.abs.enabled="1"

 

feature.lync.abs.maxrResult="12"

Message 8 of 13
Polycom Employee & Community Manager

Re: VVX501 Lync/Skype Directory Search Fails

@magicmike

 

These Parameters are standard setting when running a phone in Skype for Business mode

 

Replied via a mobile device




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 9 of 13
Advisor

Re: VVX501 Lync/Skype Directory Search Fails

True, unless they are using custom .cfgs in their auto provisioning or they're missing the .cfgs that polycom provides.

 

I had the same thing happen to me while doing some testing. Was only getting outlook search. Added those features and skype directory came back.

 

 

Message 10 of 13