Plantronics + Polycom. Now together as Poly Logo

"Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB provisionig)

Occasional Visitor

"Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB provisionig)

Hi Team,

Please help with strange behavior of polycom Trio 8800 boot process.

I have deployed firmware provisionging from Skype for Business server, and some devices shows on every boot "Completing Provisioning..."

Current build for provisioning is 5.7.1.4133

If we look to boot log - we can see, that problem occurs because device trying to upload "core file" to somewhere. And if we look at corefile name - we can examine, that filename have named as previous build (5.5.4.2255). Note that device already updated up to 5.7.1.4133 firmware

Process of unsuccesfull uploading take 198 seconds at boot time (3,3 minutes)   

 

000122.826|cfg |4|00|Prov|Trying to boot from existing configuration
000122.826|cfg |4|00|Prov|Provisioning failed
000122.828|cfg |*|00|Prov|Finished updating configuration
000125.828|cfg |*|00|Core|Uploading 3 core files
000125.829|cfg |*|00|Core|Found core file 64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz, uploading to the server
000127.597|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz' feof
000127.627|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000145.645|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") found, trying to upload to the default directory
000145.645|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000203.667|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") to the server, result=10
000203.669|cfg |*|00|Core|Found core file 64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz, uploading to the server
000205.561|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz' feof
000205.581|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000223.640|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") found, trying to upload to the default directory
000223.640|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000241.666|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") to the server, result=10
000241.669|cfg |*|00|Core|Found core file 64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz, uploading to the server
000243.769|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz' feof
000243.788|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000301.809|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") found, trying to upload to the default directory
000301.810|copy |4|00|[resolveProxies] Failed to execute service request. Indication code '-1'
000319.992|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") to the server, result=10
000319.995|cfg |*|00|Core|3 core/panic file(s) found, 0 uploaded to the server
000319.996|sec |*|00|Initial log entry. Current logging level 4
000320.004|so |*|00|Configuration files:
000320.004|so |3|00|Ethernet flow control set (tx=1, rx=1)

 

Also device try to send this core files every hour

 

0907071006|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz' feof
0907071024|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") found, trying to upload to the default directory
0907071042|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") to the server, result=-1
0907071045|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz' feof
0907071103|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") found, trying to upload to the default directory
0907071121|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") to the server, result=-1
0907071123|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz' feof
0907071141|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") found, trying to upload to the default directory
0907071159|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") to the server, result=-1
......
......
0907081204|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz' feof
0907081222|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") found, trying to upload to the default directory
0907081240|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") to the server, result=-1
0907081243|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz' feof
0907081301|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") found, trying to upload to the default directory
0907081319|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") to the server, result=-1
0907081321|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz' feof
0907081339|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") found, trying to upload to the default directory
0907081357|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") to the server, result=-1

.......
.......

0907091402|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz' feof
0907091420|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") found, trying to upload to the default directory
0907091438|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525346317.gz.tar.gz") to the server, result=-1
0907091441|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz' feof
0907091459|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") found, trying to upload to the default directory
0907091517|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.4.1525427848.gz.tar.gz") to the server, result=-1
0907091519|cfg |4|00|Core|Encrypting core file '/data/polycom/rfs0/64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz' feof
0907091537|cfg |4|00|Core|No sub-directory ("enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") found, trying to upload to the default directory
0907091555|cfg |4|00|Core|Problem uploading core file ("/data/polycom/rfs0/enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz", "enc.64(our_mac_addr)a0-5.5.4.2255-core.tAndComm.11.1525429018.gz.tar.gz") to the server, result=-1

 

And one thing - that i have another trio with same bevavior but corefile name is contains 5.5.3.3441-core (device also updated to 5.7.1 firmware). Also i have trio that updated thru SFB provisioning server without any issues.

 

So i tested 4 devices and 3  of them had problems with "Completing provisioning"

 

Please tell what can it be? Is it firmware update process bug? How can i delete this core files for boot process speedup? Is it workaround avialiable?

 

I would like to deploy firmware to 12 more devices but cannot start this process with issues like this.

Message 1 of 8
7 REPLIES 7
Polycom Employee & Community Manager

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Hello @ASUserAlfa,

welcome to the Polycom Community.

I am quite sure I had seen this before but upgrading to UC Software 5.7.1 should get rid of this message.

 

In regards to the Core Dump you can add this to your configuration:

 

diags.dumpcore.enabled="1"

Usually they contain data for us to analyze so you should consider getting this into support.

 

Use 1-8907590963 / EN-92841 as a reference with a similar issue and the "Completing provisioning." message.


In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you. This may not be who you purchased the Polycom device from.

If the unit is no longer within warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 8
Occasional Visitor

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Hi, Steffen

Thanks for your answer. I tryed to import this configuration, but it still not resolve my issue.

My Trio is already upgraded to firmware 5.7.1.4133 and this is realy strange, that core file named as part of previous installed firmware name (5.4.4)

 

I have also examined, that if i disable ZTP (this enabled by default) in advanced config, or import configuration below -

"Completing provisioning..." is also displayed at boot time, but device boot time is about 1,5 or 2 minutes, that is normal.

		device.prov.ztpEnabled.set="1"
		device.prov.ztpEnabled="0"

 

With disabled ZTP boot log shows information like that

000100.096|so   |2|00|Starting cfgProvUpdate
000100.096|so   |*|00|soUsbProvSetup: Not provisioning from USB
000100.097|cfg  |*|00|Prov|Starting to provision
000100.100|cfg  |*|00|Prov|Starting to update 
000100.136|copy |4|00|Configuration of URL failed
000100.136|copy |4|00|Configuration of URL failed
000100.136|cfg  |4|00|Prov|Download of master configuration file failed
000100.136|cfg  |4|00|Prov|Trying to boot from existing configuration
000100.136|cfg  |4|00|Prov|Provisioning failed
000100.138|cfg  |*|00|Prov|Finished updating configuration
000103.138|cfg  |*|00|Core|Delaying upload of 3 core files

Maybe device will try to send files at different time.

 

So how can i completley delete this core files and skip "Completing provisioning..." at boot time?

Message 3 of 8
Polycom Employee & Community Manager

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Hello @ASUserAlfa,

The creation cannot be reversed aka once a file exists you can only factory default the unit to get rid of it.

 

The suggested configuration only disables the general creation of these files which we can analyze in support.

 

ZTP disabled would require this configuration:

 

device.set="1"
device.prov.ztpEnabled.set="1" device.prov.ztpEnabled="0"

 

without a complete log and the Corefiles we cannot tell why they have been created.

 

In order to raise a support ticket you need to work with your Polycom reseller as they need to do this for you.

End Customers are unable to open a ticket directly with Polycom support.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you. This may not be who you purchased the Polycom device from.

If the unit is no longer within warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 8
Occasional Visitor

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

So, if i'll make factory reset of device and apply setting

diags.dumpcore.enabled="0"

Core files will not create in future if error happend?

 

Core files can be only sent to polycom in automatic mode or i can download it from my device and attach it here?

Message 5 of 8
Polycom Employee & Community Manager

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Hello @ASUserAlfa,

Yes that should work.

 

Its not good practise to disable the core dump as this contains vital information for Polycom support.

 

You cannot attach here as only Polycom support can analyze this and the community is not the official way into support.

 

Mar 8, 2012 Question: What kind of support should I expect from the Community?
Clarification: Please check => here <=

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 8
Occasional Visitor

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Thank you for support!

 

Please can you tell is there any setting available to disable attempts to send core files during boot?

How i wrote at previous posts Trio trying to do this every hour after boot.

If not can Polycom add this feature in next firmware releases?

Message 7 of 8
Polycom Employee & Community Manager

Re: "Completing provisioning.." on every boot for 3.3 minutes (after deployed firmware SfB

Hello @ASUserAlfa,

Not using any kind of Polycom Infrastructure or in very basic way an FTP server there is no way to stop the device uploading core dumps which already exist.

 

Polycom offers / supports the following Products:

 

  • Polycom Resource Manager aka a solution which is installed locally and can be utilized to configure and monitor Polycom Voice and Video Products

  • Polycom Device Managed Services aka PDMS a cloud solution

  • A local FTP server or HTTP server as explained => here <=

For any changes:

 

Jan 03, 2013 Question: How can I request a change to the current Polycom SIP / UC Software?

Resolution: Please check => here <=


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 8