Plantronics + Polycom. Now together as Poly Logo

vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

Highlighted
Advisor

vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

Environment: Polycom vvx411 firmware 5.6.0.17325

 

 

We have an ACD application for our call center.  When calls are placed through the ACD application and an agent picks up the call on the Polycom 5.6.0.17325, the call will disconnect after about 26 seconds.  The call does NOT disconnect after 26 seconds if called directly, outside the ACD.

 

What's weird is any version of the Polycom 5.5 firmware disconnects the call immediately, and firmware 5.4.7.1696 the call stays connected and does NOT disconnect.  5.4.7.1969 is the latest firmware.  Something with 5.5.x and 5.6.x is causing the call to teardown and send a BYE.

 

Here is a log from a call that disconnects after 26 seconds.

 

 

1030131412|app1 |5|00|AppHybridC::LookupContactAttribute Label is prepending to string
1030131412|cfg  |5|00|Prm|Parameter lync.qos.dscpVoice requested type 2 but is of type 0
1030131417|app1 |4|00|Event: Unrecognizable key - appKeyFunc = 330, scan code 0
1030131417|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
1030131417|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
1030131417|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
1030131417|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
1030131417|ec   |4|00|CEcLayoutMgr::onNewDocument Phone Busy with call = 1
1030131442|so   |4|00|[SoMediaSessC]: iceSessionCb event SoIceSessionEvent_CheckFailed, (direction=1, state=6) previous m_iceChecksState = 2
1030131442|so   |4|00|[SoMediaSessC]: Unexpected Event: State: SoMediaSessStateFree, Event: SoMediaSessEvLclIceCallCompletionStatusAvailable (0x4198cad8)
1030131442|ec   |4|00|CEcLayoutMgr::onNewDocument Phone Busy with call = 0

 

I'm trying to raise a ticket, but my reseller is having issues submitting a request.

 

Thanks

Message 1 of 5
4 REPLIES 4
Polycom Employee & Community Manager

Re: vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

Hello Karnov,

welcome back to the Polycom Community.

I am unsure why they would have an issue raising a ticket for you.

If this is some sort of an Internet discounter please post either your phone's MAC address or your Polycom devices serial so I can look up who would be able to support you. This may not be who you purchased the Polycom device from.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 5
Advisor

Re: vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

We ran into the same issue with some of our phones.  We are a Skype for Business environment using Polycom UCS 5.6.0 on various VVX phones.  For some reason, when making a call from a Cisco device in our CUCM environment the call would disconnect after about 26-27 seconds.  In the reverse direction, Polycom VVX to Cisco, no issues.  Also if the user was logged into their computer and answered on Skype, no issues. 

 

I cleared logs on one of my test phones, then took careful note of the call.  Here are the logs generated when the call was offered and answered:

 

0416140808|cfg  |5|00|Prm|Parameter lync.qos.dscpVoice requested type 2 but is of type 0
0416140808|cfg  |5|00|Prm|Parameter call.autoAnswer.SIP requested type 2 but is of type 7
0416140810|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
0416140810|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
0416140811|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
0416140811|so   |4|00|soStreamAddrSet DestIP: Ignoring for ICE
0416140811|ec   |4|00|CEcLayoutMgr::onNewDocument Phone Busy with call = 1

 

Here are the logs generated when the call auto-disconnected:

 

0416140839|so   |4|00|[SoMediaSessC]: iceSessionCb event SoIceSessionEvent_CheckFailed, (direction=1, state=6) previous m_iceChecksState = 2
0416140839|so   |4|00|[SoMediaSessC]: Unexpected Event: State: SoMediaSessStateFree, Event: SoMediaSessEvLclIceCallCompletionStatusAvailable (0x41b7c558)
0416140839|ec   |4|00|CEcLayoutMgr::onNewDocument Phone Busy with call = 0

 

I noted on the release notes for 5.6.2 two items of interest that are resolved bugs:

 

Call Management EN-64080 -  On the VVX business media phone, calls fail after 30 seconds when the gateway sends a REFRESH INVITE before ICE reINVITE is completed.

 

Call Management EN-61910 - When the VVX business media phone sends ICE connectivity directly and not through the relay, the call gets disconnected after 30 seconds.

Message 3 of 5
Occasional Visitor

Re: vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

I have the same issue but with VVX 311 devices with detail info :

Phone Information

 

Phone Model VVX 311

Part Number 3111-48350-001 Rev:A

MAC Address 64:16:7F:23:BF:64

IP Mode IPv4

IP Address X.X.X.X

UC Software Version 5.8.0.12848

Updater Version 5.9.5.13643

 

The issue is i call the RGS Skype for business from mobile phone and then RGS do transfer (consult) to the other mobile phone (not pick up by design) , the caller after 10-20 second then drop call but the user destination still ringing.

i have upgrade firmware from 5.7.0 to 5.8.0.12848 but the issue still the same.

 

Regards,

Hadi Supriyadi

Message 4 of 5
Polycom Employee & Community Manager

Re: vvx411 5.6.0 Calls disconnected after 26 seconds through our ACD application

Hello @Hadi Supriyadi,

please work with PT. Ingram Micro Indonesia as they sold the phone back in 16/02/2018


End Customers are unable to open a ticket directly with Polycom support.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 5 of 5