Plantronics + Polycom. Now together as Poly Logo

3.1.9 command to adjust keep alive

ThisGuyJoe
Occasional Visitor

3.1.9 command to adjust keep alive

I found a post on this forum that explained how to adjust the keep alive for 3.0.0 - see below

 

http://community.polycom.com/t5/Video-Endpoints/HDX-7000-Dropping-Calls/td-p/60146

 

Is this functionality still available in 3.1.9? When I try using the command I don't get anything in return.

 

I've also tried downloading the guides that help with this, but they never fully load and I can't effectively use them as a resource.

 

If anyone can help, it would be greatly appreciated.

 

thanks!

Message 1 of 5
4 REPLIES 4
GaryMiyakawa
Respected Contributor

Re: 3.1.9 command to adjust keep alive

I just tested this on an HDX 8000 and it worked fine.  Please be aware..

 

1.System MUST not be in a call (the command will be rejected).

2. This is a TELNET command that must be run against Telnet Port 23 NOT the Polycom API Control Port 24.

 

Cheers,

 

Gary M

Wanna' Test your H.323 System? (71.14.2.157 or 71.14.2.158)
cb157.miyakawa.us and cb158.miyakawa.us
www.miyakawa.us
www.codecsidekick.com
Message 2 of 5
ThisGuyJoe
Occasional Visitor

Re: 3.1.9 command to adjust keep alive

I use putty to telnet to my Polycom HDX 7000 HD and use my administrator password when prompted "Welcome to ViewStation
Password:"

 

after entering the password I get the below:

 

R: telnet /tmp/apiasynclisteners/psh0 /dev/pts/0

 

Polycom Command Shell
XCOM host:    localhost port: 4121
TTY name:     /dev/pts/0
Session type: telnet

 

from this point i enter "tcp kainterval" which should give me the current interval, but I get nothing in return.

So I try "tcp ka interval 180" and I get nothing in return.

 

neither gives me an error, but there is basically no response to those commands at all.

 

I'm wondering if I need to be logging in as the administrator. Plus, this is not during a call.

Message 3 of 5
GaryMiyakawa
Respected Contributor

Re: 3.1.9 command to adjust keep alive

I just tested with Putty and HDX 8000 and HDX 9000..     this is what I got...

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2016.04.15 09:06:59 =~=~=~=~=~=~=~=~=~=~=~=

Welcome to ViewStation
Password:

R: telnet /tmp/apiasynclisteners/psh0 /dev/pts/0
Polycom Command Shell
XCOM host:    localhost port: 4121
TTY name:     /dev/pts/0
Session type: telnet

tcp kainterval
2016-04-15 13:07:05 DEBUG avc: pc[0]: uimsg: [C: tcp kainterval]
2016-04-15 13:07:05 DEBUG avc: pc[0]: APPCOM: C: tcp kainterval cmd response is 0
2016-04-15 13:07:05 DEBUG avc: pc[0]: 1900
tcp kainterval 1000
2016-04-15 13:07:12 DEBUG avc: pc[0]: uimsg: [C: tcp kainterval 1000]
2016-04-15 13:07:12 DEBUG avc: pc[0]: APPCOM: C: tcp kainterval 1000 cmd response is 0
2016-04-15 13:07:12 INFO avc: pc[0]: config: tcpkeepalivetime[0]:1000
tcp kainterval
2016-04-15 13:07:32 DEBUG avc: pc[0]: uimsg: [C: tcp kainterval]
2016-04-15 13:07:32 DEBUG avc: pc[0]: APPCOM: C: tcp kainterval cmd response is 0
2016-04-15 13:07:32 DEBUG avc: pc[0]: 1000
exit

 

 

I was signed on as Administrator (from a windows standpoint) but I don't believe that has any effect to this issue.

I've also used the windows "Telnet" command and it worked the same.

 

In your description, you said you used a command of "tcp ka interval nnnn"    The command is "tcp kainterval nnnn".  I don't know if that was a typo or not on your statement.

 

Cheers,

 

Gary M 

Wanna' Test your H.323 System? (71.14.2.157 or 71.14.2.158)
cb157.miyakawa.us and cb158.miyakawa.us
www.miyakawa.us
www.codecsidekick.com
Message 4 of 5
ThisGuyJoe
Occasional Visitor

Re: 3.1.9 command to adjust keep alive

that statement was a typo. I will escilate this with our purchased support for our  team to see if I am missing anything.

Message 5 of 5