Plantronics + Polycom. Now together as Poly Logo

Downgrade Studio to 3.5.0

SOLVED
JordyM
Occasional Visitor

Downgrade Studio to 3.5.0

Hi,

 

We're using Polycom at different customers for about a year and the there is not a single firmware where everything works smooth.

 

I've just wasted another complete day by upgrading to version 3.6.0. The camera doens't work, its just flickering in the TC8.

 

I see that other people have also made a topic and that downgrading to 3.5.0 should work.

However I made a FAT32 stick, put the Poly in Poly mode and extracted the correct folders. The downgrade does not start.

 

Is there a custom URL that I can try? I fabricated one myself

 

swupdate.lens.poly.com/polyos/3.5.0/344025 , that does find versions, but after pressing "upgrade all" it fails, can anyone give me the correct URL?

 

in version 3.2.3 (where the downgrade does work) the initial issue where I have a blackscreen with external meetings is back and that is why I want to upgrade in the first place.

 

Hope to get a reply soon.

 

 

Message 1 of 6
1 ACCEPTED SOLUTION

Accepted Solutions
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrade Studio to 3.5.0

Hello @JordyM ,

 

Welcome to the Poly Community.


This should really come into our official support organisation but try 

https://swupdate.lens.poly.com/polyos/3.5.0/344025

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 6
5 REPLIES 5
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrade Studio to 3.5.0

Hello @JordyM ,

 

Welcome to the Poly Community.


This should really come into our official support organisation but try 

https://swupdate.lens.poly.com/polyos/3.5.0/344025

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 6
JordyM
Occasional Visitor

Re: Downgrade Studio to 3.5.0

Downgrading now! I tried http not https.. my bad..

But luckily its downgrading, will test if this solves my initial issue and report back.

 

 

Message 3 of 6
JordyM
Occasional Visitor

Re: Downgrade Studio to 3.5.0

Issue is fixed with downgrade to 3.5.0

Message 4 of 6
rho
Occasional Advisor

Re: Downgrade Studio to 3.5.0

you need to reboot once more after upgrade to 3.6.0 for the camera to work again.

 

But yes, the X30/MS Teams software after does leave much to be desired. I'm getting complaints from the users on a daily basis.

  - Video preview works but not transmitting Video, (improved since 3.5.0, but still happens)

  - Touch console out of sync - cannot answer/disconnect calls on TC8 (improved since 3.5.0, i think this is fixed)

  - Console randomly disconnects/unpairs itself (still happens on occasion, but getting rarer)

  - Cannot unmute call - reported on 3.5.0, haven't seen it yet since

  - Calendar Teams invite forwarded on Outlook on PC doesn't show up on TC8 (technically that's a Microsoft problem though...)

 

Good luck on your deployments.

Message 5 of 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Downgrade Studio to 3.5.0

Hello @rho ,

 

Welcome back to the Poly Community.


The Teams components are supplied by our partner Microsoft and they are aware of the issues. I can only ask uses experiencing these to open a ticket with Microsoft support as Poly cannot do this for them.

 

You can then open a Poly support ticket and provide the Microsoft reference so we can keep track of this.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6