Plantronics + Polycom. Now together as Poly Logo

G7500: No device mode prompt

SOLVED
jbass@srcinc
Valued Contributor

G7500: No device mode prompt

X50: UC 3.5.0

G7500: 3.5.0

Trio C60: 7.1.1

Our standard config is an X50 w/a C60 controller and just recently I happened to notice that if I had device mode enabled and I connected an X50 to a PC via USB there would be a prompt on the C60 to enter BYOD mode (see attached photo), This was great because it gives us the flexibility to use other UC tools. The issue that I am having is that I do not get the same prompt when I use a G7500, in fact there is no prompt at all. If the system is connected to a touchscreen display then device mode can be initiated by swiping left. I performed a factory reset and started from scratch and there was no change. Is there something that I am missing or is this not an option on the G7500? I don’t see any reason why it shouldn’t work, it's essentially the same software.

 

Thanks,

James

Message 1 of 7
1 ACCEPTED SOLUTION

Accepted Solutions
jbass@srcinc
Valued Contributor

Re: G7500: No device mode prompt

Seems to be performing better after reinstalling UC 3.5.0-344025.

#fingercrossed

View solution in original post

Message 7 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: G7500: No device mode prompt

Hello jbass@srcinc ,

 

Welcome back to the Poly Community.


Is this in Zoom provider mode or Poly mode? In order to get an official answer please raise a ticket with our support organization.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
jbass@srcinc
Valued Contributor

Re: G7500: No device mode prompt

Zoom provider, Works w/an X50 & C60 but not a G7500 & C60. 

 

Thanks

Message 3 of 7
jbass@srcinc
Valued Contributor

Re: G7500: No device mode prompt

Service Request Number 1-23110610261

Message 4 of 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: G7500: No device mode prompt

Hello jbass@srcinc ,

 

My colleagues most likely will contact you but is device mode enabled in the G7500?

 

  • General Settings > System Settings > Collaboration Tools > Enable Device Mode
  • Is the USB cable being connected to the Trio C60 or the G7500? I assume it is connected to the G7500
  • Is the USB cable being connected to the G7500 USB-C port or a USB-A port? It must be the USB-C port.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 7
jbass@srcinc
Valued Contributor

Re: G7500: No device mode prompt

Is device mode enabled in the G7500? Yes

  • General Settings > System Settings > Collaboration Tools > Enable Device Mode
  • Is the USB cable being connected to the Trio C60 or the G7500? I assume it is connected to the G7500 G7500, Yes
  • Is the USB cable being connected to the G7500 USB-C port or a USB-A port? It must be the USB-C port. Tried both, neither produced a prompt. Device mode can be initiated via a touchscreen display.

    I did a factory reset on the G7500 and after reconfiguring for Zoom you would receive a prompt for device mode however there is no video (the privacy shutter is open). See attached screenshot. The PC is connected via USB-C and the EagleEye Cube is connected via USB-A. If disconnect the EagleEye camera and replace it w/a an Aver CAM520 Pro it works fine. The EagleEye camera is running version 1.3.1.001267 and it works fine when connected directly to a PC via USB-C.
jbass@srcinc
Valued Contributor

Re: G7500: No device mode prompt

Seems to be performing better after reinstalling UC 3.5.0-344025.

#fingercrossed

View solution in original post

Message 7 of 7