Plantronics + Polycom. Now together as Poly Logo

Group 500 - sleep API (v5.0)

Occasional Contributor

Group 500 - sleep API (v5.0)

Our customer has a Polycom Group 500 system with EagleEyeIV-12x camera that is controlled from a Crestron control system with touchpanel.

The control worked just fine until we upgraded to v5.0 firmware on the Group 500 system. Reason for upgrade was that the 4.2 software did not work on the new Lync platform.

I am also using the Crestron Control module v2.5 for Polycom Group Series in the Crestron programming.


The problem is that camera does not work at all every second time after the system has been awaken from sleep mode. We get a blue image and cant select the camera. When we then put the system to sleep again and wake it up the camera works fine again.


I have tested out some different timings on when diffrent commands are beeing sendt when shutting down:

1. Send the command "hangup all calls"  '(whitout the ", and all commands ends with \x0D)

2. 1 second after that, send the command "autoanswer donotdisturb"

3. 1 second after that, send the command "sleep"


And normaly the camera should turn around, now it do that every second time the system goes to sleep. And after wakeup the camera does not work. I have tried with delay from 1 to 10 seconds delay between commands are sendt with no diffrence in the outcome.


This is the sequence to start up system again is like this:

1. Send the command "wake" for waking up system

2. 2 second after that, send the command "autoanswer no" for turning of the do-not-disturbe mode.

3. 10 second after that, send the command "vcbutton stop" to stop automatic start of content that is connected at this point.

4.  10 second after that, send the command "preset near go 2" to activate camera preset number 2.


And then the system is active but with no camera input. It is not possible to select the camera either. Seems like camera is not connected. I can either reboot the codec at this time and the camera is back again, or I can set the system in sleep mode and wake it up again and the camera is back with no other commands sendt to the system. Also here I have been testing out diffrent delays between commands from 1 to 20 seconds with no differnces.


When using the remote to activate sleep or wake system up, the camera works as it was befor you set it in sleep mode.


I have also noticed that I get a feedback from the Group system after the last sleep command was sendt and before the camera starts working again:

"camera near 1\x0D\x0Anotification:vidsourcechange:near:1:Main:people\x0D\x0A"

At this point the camera does not turn around either. It is now moved to the last preset activated. But codec responds that it is in sleep mode.


I have for the moment just made a temporary workaround by NOT putting the system in sleep mode, just turning the camera to one side when turning the system off (turning monitors and all other things off).


Anyone that have experienced this or know of a fix for it?


On another system with Group 500 (with the same v5.0 firmware) but with the EagleEye III camera I see a blue camera image for a few second after waking up the system, but it always comes on here.

Message 1 of 2
Polycom Video EP PLM
Polycom Employee & Moderator

Re: Group 500 - sleep API (v5.0)

I reached out to some people and basically they are recommending that you call into service so the information that would be needed for the investigation can be gathered.

Message 2 of 2