Plantronics + Polycom. Now together as Poly Logo

HDX 9002 pulsating video/potential NAT issues

Advisor

HDX 9002 pulsating video/potential NAT issues

Hello,

 

I have a Polycom HDX 9002 codec connected to a PPPoA connection in the UK. I have tried a number of routers, but presently I am using a ZyXel P-660r-D1. Even though I have done all the port forwarding, and tried DMZ, I am experiencing the following issues:

 

- Although I can connect to every system and everyone can connect to me, loopback server gives me a 'potential NAT conflict' as here: http://71.14.2.154/CA63K4SS638

 

- Video that I am sending seems to be refreshing every 10 seconds or so, which gives an impression of it pulsating. The pulse is not frequent but it can be detected.

 

I have manually switched on NAT and hard-coded the public IP address.

 

Anyone can help out?

Thanks 

Message 1 of 11
10 REPLIES 10
Polycom Employee

Re: HDX 9002 pulsating video/potential NAT issues

The HDX does not care what happens to the packets once it puts them out on the wire. You say the video you send is pulsing, is this being reported at every site that you connect to?  If yes and every site is on a different network with different firewalls etc then the issue is local to you. (but you may have already considered that)

 

I think we need a better definition of the term pulsing.  Usually if there is a NAT or port issue the call never goes through or there is one way video.

 

Have you tried staying local by placing a call between two systems on the same subnet?  If needed you can download the Polycom m100 Telepresence software to a laptop and install it. This will turn the laptop into a full H323 video system.  There is a full version trial for 30 days. (below)

 

http://support.polycom.com/PolycomService/support/us/support/video/personal_telepresence/m100.html

 

Perhaps we can learn more by looking at the internal logs the HDX generates.  Contact our support center in the UK and have them open a case. They can tell you how to extract the logs so they can analyze them.  

We may also request some WireShark traces.

 

http://support.polycom.com/PolycomService/support/us/support/Contact_Us.html

Ken
Polycom
Sr. Product Support Technician
Message 2 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

Hello,

 

Thanks for your reply. The 'pulse' does get reported on every site. I saw how it looks on a loop-back server. ''Pulse' might not be the best word to describe what is happening to the video. The video basically seems to refresh every 10-12 seconds (I don't think that the gap between pulses is constant). When I say refresh or 'pulse', I mean that it shakes (once) and gets pixelated a bit. This lasts for about half a second each time.

 

I have a hub for Wireshark traces and I've done them before so it isn't a problem. I will also try to make a local call by connecting my laptop with that software installed on it. The only thing I am concerned about is port forwarding. If I have two machines on the same router, would I be able to change port 1720 for the laptop so that h.323 calls get initiated on another port? (I am not an expert so sorry if this sounds silly).

 

Thanks very much.

Message 3 of 11
Polycom Employee

Re: HDX 9002 pulsating video/potential NAT issues

You do not need to worry about port forwarding with two systems on the same switch.  The ports are only to get through a firewall. Behind the firewall all you need is the basic LAN configuration. For instance if your router gives an IP address of 192.168.1.x for each system then that is the IP you will dial.

It does sound like something on your network side causing the pulse. Look for packet loss and/or jitter in the call stats on the Diagnostic screen under the System settings.

Also is the firewall doing some sort of packet inspection like H.323 fix up?  This can slow the packets down just enough to cause packet loss. How about bandwidth.  Is it symmetrical and is there enough (if asymmetrical is there enough to support the call plus overhead)?  Is the same pipe being used by other devices on the network? Is there QoS configured? Have you matched the port speed of the HDX to the switch port?  

Ken
Polycom
Sr. Product Support Technician
Message 4 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

Hello,

 

I have connected to the codec with my laptop via a switch and there was no pulsation, so clearly it is an issue with the router.

 

I think I will just replace the router, but because I have already tried a few, I would like to get an advice: I have a PPPoA connection so I can not full-bridge the codec to the internet like I used to. The codec is the only device that uses the connection. I tried half-bridge but it did not work, so I need a router that would forward everything from the public IP to the LAN IP without causing any problems with inspections and things like that. I obviously don't need wireless, etc. Would you have any in mind?

 

Thanks.

Message 5 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

(it is ADSL2+)

Message 6 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

Hi,

 

I have now replaced my router with a Linksys and I got rid of the NAT issues on the loopback server (71.14.2.154).

 

The first time I connceted to the server, the video was great, the report is here:

 

http://71.14.2.154/1AK8F567


As you can see, the roundtrip time is very good and packet loss statistics are good too. The view was also exactly as what I see on the TV before connecting, i.e. it wasn't zoomed in. Unfortunately, every subsequent attempt to connect resulted in a view that was zoomed in and lots of pulses that appeared as packet loss. There was no jitter on my end and about 5ms of jitter on the far end. Connection statistics from the codec said that there was no packet loss, but you can see the full statistics here.

 

http://71.14.2.154/AK84Y58AA

http://71.14.2.154/5AKY8CK74

 

I can't seem to be able to connect properly (like the first time) any more.

 

Any ideas?

Thanks.

Message 7 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

I have been trying for far too long now to solve this, I am really losing hope. Could this be a hardware problem of some sort?

Message 8 of 11
Polycom Employee & Community Manager

Re: HDX 9002 pulsating video/potential NAT issues

Hello BM3000,

 

as advised by Kendo => here <= I would contact your Polycom Reseller or Polycom Support directly.

 

Best Regards

 

Steffen Baier

 

Polycom Global Services

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 11
Advisor

Re: HDX 9002 pulsating video/potential NAT issues

Thanks, will do. 

 

Just one last thing: could you please take a look at this video? You can see the problematic bits in the description so just click on those times and you will see what I am talking about. I also switch to the call statistics in the end.

 

Any advice appreciated.

 

http://youtu.be/qI7J371_yTw

Message 10 of 11