Plantronics + Polycom. Now together as Poly Logo

Initial X50 Teams Setup

SOLVED
Highlighted
Occasional Advisor

Initial X50 Teams Setup

Hey there,

 

I'm having an issue with using my new X50. I have set the provider mode on this to Teams and updated to software version: 3.1.1-216122. After connecting my teams account, I do see that my TV looks good. It shows the meetings I've booked in the room, etc. but I cannot get either my Trio 8800 paired  or TC8 to work correctly with Teams with the X50.

 

I've configured device mode: generic and device type: device on the Trio but I haven't found a way to use the Trio to control meetings i.e. start meetings, create ad-hoc meetings, etc. When I try to tap on the 'Start Mirroring' button after pairing the Trio with X50, it says 'daisy chain connection failed'. I'm not sure if that is related to the issue or not. The Trio is on software version 5.9.3.8724.

 

For the TC8, it's running software version 3.0.1. When I pair it, it doesn't seem to resemble the purple Teams theme that the screen has. Not sure what can be done but from looking on YouTube, I saw a TC8 that's display looks like it is running a Teams theme on it: https://www.youtube.com/watch?v=GH4Ie1oFgu4

 

 I'm looking at the viability of the X50 for a large amount of rooms. Ideally, it would pair perfectly with the Trio 8800 but if it has to be the TC8, so be it.

 

Also, quick question: is there any way to get the X50 to support hybrid line registration with one line being Teams and one line being SIP?

 

I'm not quite sure what I'm doing wrong here but any help or guidance would be appreciated here.

 

Thanks so much

Message 1 of 4
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: Initial X50 Teams Setup

Hello @cmoney ,

 

Welcome back to the Poly Community.

 

The Trio, when paired with a Studio X running 3.1.1, will just be like the TC8. This enables accounts that already had a Trio being able to re-use it with the Studio X or G7500 not needing to purchase a TC8.

 

It will be nothing else and no other functionality is given.

 

The TC8 in order to pair to a Studio X needs to be on the same software. If the unit does not automatically update please work with our support team.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 3 of 4
3 REPLIES 3
Highlighted
Occasional Advisor

Re: Initial X50 Teams Setup

Update: I think there may have been a firmware update bug on the Trio 8800 as when I rebooted it, it started working with the X50. Still curious about the hybrid line registration in this setup. I'm not able to configure lines on my Trio 8800 as it's not in it's normal state in this setup. Is there any way to have a SIP line as well as Teams functionality on the X50?

Thanks.

Message 2 of 4
Highlighted
Polycom Employee & Community Manager

Re: Initial X50 Teams Setup

Hello @cmoney ,

 

Welcome back to the Poly Community.

 

The Trio, when paired with a Studio X running 3.1.1, will just be like the TC8. This enables accounts that already had a Trio being able to re-use it with the Studio X or G7500 not needing to purchase a TC8.

 

It will be nothing else and no other functionality is given.

 

The TC8 in order to pair to a Studio X needs to be on the same software. If the unit does not automatically update please work with our support team.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 3 of 4
Occasional Advisor

Re: Initial X50 Teams Setup

Thanks. Definitely helpful info.

 

 

Message 4 of 4