Plantronics + Polycom. Now together as Poly Logo

People+Content IP and Kaspersky Endpoint Security 10

Frequent Visitor

People+Content IP and Kaspersky Endpoint Security 10

Hi,

 

I updated my Kaspersky Endpoint Security Antivirus from version 8 to version 10 SP1

 

Since then, People + Content IP won't connect

 

I tried many things to tweak Kaspersky V10 policy (it works with v8 policy) but no luck.

 

I know, Polycom software is not the problem but if anyone had the same problem ?

 

Regards

 

Denis

Message 1 of 6
5 REPLIES 5
Polycom Employee & Moderator

Re: People+Content IP and Kaspersky Endpoint Security 10

PPCIP (People+Content IP) uses port 5001 make sure that is open in your security settings.  Guessing that will be it.

Message 2 of 6
Frequent Visitor

Re: People+Content IP and Kaspersky Endpoint Security 10

Actually I'm not using the network version (which by the way is working fine but is a bit slower)

 

I try to connect to the polycom device through the usb cable.

The software is located on the usb space in the Polycom touchpad

So the network in not the problem.

 

Message 3 of 6
Polycom Employee & Moderator

Re: People+Content IP and Kaspersky Endpoint Security 10

Not sure how your security would work with this but the port between the PTC and the codec is still using 5001 for the PPCIP applicaiton that is being used through the Polycom Touch Control that you connected to via USB.  Since it is an application that is using the USB to run on I am wondering if the settings do not allow applications across the USB.

Message 4 of 6
Frequent Visitor

Re: People+Content IP and Kaspersky Endpoint Security 10

Hello,

 

I'm still working on a resolution.

 

May I paste here the ppcip.log file. You should be able to explain what's happening ?

 

Log opened Tue Aug 04 16:48:57 2015
2015-08-04 14:48:57.664 PPCIP version 1.3.0.494
2015-08-04 14:48:57.664 CPPCIPApp::LoadResources: Loading PPCIPFRA.dll
2015-08-04 14:48:57.826 CContentSourceImpl::SetNotificationSink: enter
2015-08-04 14:48:57.828 CCtlBarView::OnBtnClickedConnect: enter
2015-08-04 14:48:57.829 CContentSourceImpl::Connect: enter [pszAddress: (null)] [m_bConnected: 0]
2015-08-04 14:48:57.830 IPIPCInit: processor 0 srvAddr (null) [IPCCBs - ctrl: 0x55e4e0 data: 0x55e3e0]
2015-08-04 14:48:57.832 IPIPC: Creating 'ipc0' device (IPIPC ctrl connection)
2015-08-04 14:48:57.833 IPIPCDevInit: ipc0: proc0 addr: (null)
2015-08-04 14:48:57.834 OSWIN: started thread [task name:  iic] [taskID: 1] [WIN32 thread id: 1788(0x6fc)] [WIN32 parent id: 340(0x154)]
2015-08-04 14:48:57.835 IPIPC: Creating 'ipd0' device (IPIPC data connection)
2015-08-04 14:48:57.836 IPIPCDevInit: ipd0: proc0 addr: (null)
2015-08-04 14:48:57.838 OSWIN: started thread [task name:  iid] [taskID: 2] [WIN32 thread id: 2512(0x9d0)] [WIN32 parent id: 352(0x160)]
2015-08-04 14:48:57.839 IPIPCInit: task IDs [ctrl: 1] [data: 2]
2015-08-04 14:48:57.840 USBIPCInit: [pDriveName: E:\data0] opening file...
2015-08-04 14:48:57.843 USBIPCInit: exit [gbHost: 1]
2015-08-04 14:48:57.845 OSWIN: started thread [task name: vcla] [taskID: 3] [WIN32 thread id: 4108(0x100c)] [WIN32 parent id: 372(0x174)]
2015-08-04 14:48:57.845 CContentSourceImpl::ConnectTask: enter
2015-08-04 14:48:57.846 ShowSettingsCtrls: [vis: 0] [bShow: 0]
2015-08-04 14:48:57.847 CContentSourceImpl::OpenDevice: enter
2015-08-04 14:48:57.848 CCtlBarView::OnBtnClickedConnect: exit
2015-08-04 14:48:57.849 IPIPCOpen: ipc0
2015-08-04 14:48:57.852 IPIPC: ConnectToServer: calling connect()...
2015-08-04 14:48:57.854 ConnectToUSBServer [USB state: 0]
2015-08-04 14:48:57.863 ConnectToUSBServer: state now CONNECTING, waiting up to 2 secs for USBIPC set state -> CONNECTED...
2015-08-04 14:48:59.364 ConnectToUSBServer: TIMEOUT waiting for usbipc -> CONNECTED [USB state: 1]
2015-08-04 14:48:59.365 IPIPC: ConnectToServer: ERROR, unable to connect [errVal: -1] [GetLastError: 0]
2015-08-04 14:48:59.368 CContentSourceImpl::ConnectionNotfCB: enter [nConStat: 1]
2015-08-04 14:48:59.370 CContentSourceImpl::Disconnect: enter
2015-08-04 14:48:59.371 CContentSourceImpl::Disconnect: WARN: [m_bConnected == false]
2015-08-04 14:48:59.373 IPIPCClose: enter [dev name: ipc0]
2015-08-04 14:48:59.434 IPIPCTask: ctrl task Setting state to closed
2015-08-04 14:48:59.444 IPIPCClose: ipc0 closed
2015-08-04 14:48:59.446 CContentSourceImpl::ConnectTask(): OpenDevice failed [0x80000004]
2015-08-04 14:48:59.448 CContentSourceImpl::SendNotification: enter [hr: 0x80000004]
2015-08-04 14:48:59.450 CContentSourceImpl::Disconnect: enter
2015-08-04 14:48:59.452 CContentSourceImpl::Disconnect: WARN: [m_bConnected == false]
2015-08-04 14:48:59.450 CCtlBarView::ConnectResultSink enter [hr: 0x80000004]
2015-08-04 14:48:59.456 SystemExit: ERROR, system not initialized
2015-08-04 14:48:59.459 ShowSettingsCtrls: [vis: 0] [bShow: 0]
2015-08-04 14:48:59.461 IPIPC: closed data socket to server
2015-08-04 14:48:59.463 CRemoteCommand::Notify: 2015-08-04 14:48:59.464 IPIPC: closed ctrl socket to server
2015-08-04 14:48:59.466 Connect FAILED 1

2015-08-04 14:48:59.467 IPIPCDevExit: ipd0
2015-08-04 14:48:59.470 IPIPCClose: enter [dev name: ipd0]
2015-08-04 14:48:59.471 IPIPCClose: ipd0 closed
2015-08-04 14:48:59.474 IPIPC: IPIPCTask: ipd0 task exit
2015-08-04 14:48:59.574 IPIPCDevExit: ipc0
2015-08-04 14:48:59.575 IPIPCClose: enter [dev name: ipc0]
2015-08-04 14:48:59.577 IPIPCClose: ipc0 closed
2015-08-04 14:48:59.579 IPIPC: IPIPCTask: ipc0 task exit
2015-08-04 14:48:59.679 CContentSourceImpl::ConnectTask: exit [hr: 0x80000004]
2015-08-04 14:49:02.529 CZoomWnd::~CZoomWnd(): called
2015-08-04 14:49:02.532 ERROR, system not initialized
2015-08-04 14:49:02.534 CContentSourceImpl::~CContentSourceImpl: exit
Log closed Tue Aug 04 16:49:02 2015

Message 5 of 6
Frequent Visitor

Re: People+Content IP and Kaspersky Endpoint Security 10

Actually, KASPERSKY found out that the encryption plugin was the problem.

 

Without this plugin installed, Polycom software is working properly.

 

They are working on a patch or a workaround.

 

Thank you for your time.

 

best regards

Message 6 of 6