Plantronics + Polycom. Now together as Poly Logo

Poly Studio X50 automatically starts presenting on PC wake

SOLVED
kilowattson
Occasional Advisor

Poly Studio X50 automatically starts presenting on PC wake

Hey folks. 

So, in addition to our Studio X50, we have a small form factor HP PC with Windows 10 in our conference room. 


It has 2 video outs (1 HDMI and 1 DP)
HDMI goes to Poly Studio X50 "HDMI IN" 
DP goes to TV via DP->HDMI cable 

This is so that you can use the computer with the TV separate from the Poly if you're just doing something solely internally in the conference room. 

However, we have noticed that if you wake up the PC - the Poly Studio X50 automatically enters Presentation mode and starts screen sharing. This happens regardless of the input you have the TV on. Wake the computer up and Poly starts presenting.

This is evident by the presentation light on the Poly, the TC8 indicates it's in Presi mode and then of course just switching inputs over to the Poly shows the screen shared. 

Any idea what's causing this?

Message 1 of 9
1 ACCEPTED SOLUTION

Accepted Solutions
kilowattson
Occasional Advisor

Re: Poly Studio X50 automatically starts presenting on PC wake

I'm actually pretty sure I figured out the problem. 

Apparently for HDMI in connections, in the Zoom Room settings, you have to turn *off* automatic sharing and make it manual. 

Interesting that it's a default option. 

View solution in original post

Message 4 of 9
8 REPLIES 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly Studio X50 automatically starts presenting on PC wake

Hello @kilowattson ,

 

Welcome to the Poly Community.

Consumer Electronics Control under Audio/Video > Monitors?


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 9
kilowattson
Occasional Advisor

Re: Poly Studio X50 automatically starts presenting on PC wake

Sorry for the late reply! But unfortunately that didn't fix it. 

CEC on both the TV *and* the Poly is disabled and it still does it. On wake or on meeting start... bam... automatic screen sharing.

Message 3 of 9
kilowattson
Occasional Advisor

Re: Poly Studio X50 automatically starts presenting on PC wake

I'm actually pretty sure I figured out the problem. 

Apparently for HDMI in connections, in the Zoom Room settings, you have to turn *off* automatic sharing and make it manual. 

Interesting that it's a default option. 

View solution in original post

Message 4 of 9
kilowattson
Occasional Advisor

Re: Poly Studio X50 automatically starts presenting on PC wake

I can confirm the above setting was the issue. 

I guess it assumes people won't leave anything plugged into the HDMI so, by default, it's set to auto start sharing if it detects an HDMI signal. 

Well we have a computer permanently plugged in for sharing purposes so it was always triggering that feature. I went into the ZOOM ROOM edit settings and turned on the "HDMI sharing always manual" feature. 

Message 5 of 9
sonicMike
Visitor

Re: Poly Studio X50 automatically starts presenting on PC wake

Hi Anyone who will reply!!

 

We have the same problem, but we do NOT use Zoom Rooms at the moment, it's just an X50 in Poly mode, but it will ALWAYS auto present becuase we have a Barco clickshare plugged into the HDMI content port and it will auto present, but I don't want it to.

 

Does anyone know where the setting is to stop this auto-presentation when you're not using Zoom Rooms??

Message 6 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly Studio X50 automatically starts presenting on PC wake

Hello @sonicMike ,

 

Welcome to the Poly Community.


I have seen internal communication around this and at present, it is working as designed aka you cannot control the auto-share.

 

The latest 3.3.2 software added an API for the control so maybe this could work for you. If not please work with Poly reseller to work on feature requests based on the importance for your organisation.

 

When doing so please mention SEFR-375

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 7 of 9
sonicMike
Visitor

Re: Poly Studio X50 automatically starts presenting on PC wake

Thanks for the speedy reply Steffen,

 

I have to say this is a little disappointing that there is an API to control the auto-share, but on the web interface of the base device, there isn't such an option

 

We have multiple rooms with HDMI auto-switchers and HDMI Devices like Barco Clickshare that are 'always on' and for simplicity they are always connected to the StudioX50, but we are finding that sometimes in the middle of a meeting, the content will just start automatically presenting until someone click 'stop presenting' and then it will stay off for the duration of that meeting, but after the meeting it will come on again.

 

I'll see if we can get our Poly Reseller to raise a feature reqeust.

 

Regards,

Mike

 

Message 8 of 9
zachmiller
Occasional Visitor

Re: Poly Studio X50 automatically starts presenting on PC wake

I have found a solution for Zoom Rooms & Poly Studio X50/X30 starting a presentation on PC Wake / Restart.

 

  1. On your Zoom Admin Dashboard, go to Admin >> Zoom Rooms.
  2. Click into the Zoom Room that is having issues.
  3. Click Edit
  4. Go to the Meeting Tab
  5. Find the Setting "Start HDMI content share manually on controller"
  6. Turn on
  7. Restart your Poly X50 so it syncs with the new Zoom Rooms settings that have been applied.
  8. Once Poly X50 is back online, restart your PC / device that is sending HDMI content to the Poly X50.  Ensure that auto-share doesn't begin.

This worked in our environment.  Hope this helps!

 

-Zach

 

Message 9 of 9