Plantronics + Polycom. Now together as Poly Logo

Poly TC8 and Teams

SOLVED
Will Sherlock
Occasional Contributor

Poly TC8 and Teams

Hi,

 

I have an X50 and a TC8 which I wish to run in Teams mode. The X50 works fine once logged in. However the TC8 wont sign into Teams. I have tried registering on the device itself and also using the MS authentication broker. It goes through the process and then fails and loops back to the logon screen displaying the code to use at microsoft.com/devicelogin. I have reset both devices with no joy. I have both devices connected to the same network with unrestricted Internet access.

 

Any help would be appreciated.

Message 1 of 8
1 ACCEPTED SOLUTION

Accepted Solutions
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly TC8 and Teams

Hello @LT  , @Will Sherlock  and @npde ,

 

first of all, I can only ask you to use Poly Studio X software 3.5.0 as this includes Microsoft Teams APK 20h2 1449 1.0.96.2021051904 for MTRoA and then upgrade via the TAC if offered.

 

In addition, if using Intunes:

 

  1. Add the device serial numbers as corporate identifiers
    i. Endpoint Manager > Devices > Enroll Devices > Corporate device identifiers

  2. This allows the X 50 or X 30 to enroll, however, the TC8s may not be able to sign.

    It has been found that Intune is reporting the incorrect serial number for the TC8 so it is failing to be recognized as a corporate device.
    If this is the case for your organization please work with Poly support and quote EN-208386

  3. To work around this allow personal enrolment.
    Create an exception group for personal enrolment for certain accounts

  4. Endpoint Manager > Devices > Enroll Devices > Enrollment Restrictions > Create Restriction
    Add each of the rooms accounts to the above exception group


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 7 of 8
7 REPLIES 7
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly TC8 and Teams

Hello @Will Sherlock ,

 

Welcome back to the Poly Community. 


A very good starting point would be to share the currently used exact software version.


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 8
Will Sherlock
Occasional Contributor

Re: Poly TC8 and Teams

The current firmware version is 3.3.2-286154. The Teams version is 1449/1.0.96.2021032002

Message 3 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly TC8 and Teams

Hello @Will Sherlock ,

 

I would suggest upgrading to the latest 3.5.0 as this contains a fix from our Partner Microsoft preventing a no Video issue with their latest APK version. If this still fails I would suggest working with them to troubleshoot this issue as they most likely should be able to help you with this. Alternatively give our support team a call but if the issue is Microsoft-related I am unsure how much they can troubleshoot this.


Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 8
npde
Occasional Visitor

Re: Poly TC8 and Teams

I just received a brand new Poly X50 and TC8 and do have the very same problem. Firmware is up to date 3.5.0

 

Did you find a solution for this problem?

 

Thanks

Norbert

Message 5 of 8
LT
Occasional Visitor

Re: Poly TC8 and Teams

Same here, the problem was Microsoft licence 

Room license don't work with broker auth, changed to E1 or E3 is ok 

 

 

Message 6 of 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly TC8 and Teams

Hello @LT  , @Will Sherlock  and @npde ,

 

first of all, I can only ask you to use Poly Studio X software 3.5.0 as this includes Microsoft Teams APK 20h2 1449 1.0.96.2021051904 for MTRoA and then upgrade via the TAC if offered.

 

In addition, if using Intunes:

 

  1. Add the device serial numbers as corporate identifiers
    i. Endpoint Manager > Devices > Enroll Devices > Corporate device identifiers

  2. This allows the X 50 or X 30 to enroll, however, the TC8s may not be able to sign.

    It has been found that Intune is reporting the incorrect serial number for the TC8 so it is failing to be recognized as a corporate device.
    If this is the case for your organization please work with Poly support and quote EN-208386

  3. To work around this allow personal enrolment.
    Create an exception group for personal enrolment for certain accounts

  4. Endpoint Manager > Devices > Enroll Devices > Enrollment Restrictions > Create Restriction
    Add each of the rooms accounts to the above exception group


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 7 of 8
Will Sherlock
Occasional Contributor

Re: Poly TC8 and Teams

Hi,

 

Upgrading helped but I was till having intermittent issues with connectivity between the X50 and TC8. Adding the serial number helped alleviate this. Not sure why it would work sometimes but not others when the serial number wasn't specified as a corporate device.

 

Thank You for your support an solution.

 

Kind Regards

 

Will

Message 8 of 8