Plantronics + Polycom. Now together as Poly Logo

Polycom Trio8800 and setup for Teams AudioVideo calls

Highlighted
Occasional Contributor

Polycom Trio8800 and setup for Teams AudioVideo calls

Hi there,

 

We have started setting up Teams for use on Polycom Trio8800 and RealPresence Group devices.

 

The Office365 Tenant is setup with the correct info and registered enterprise apps, and this has been tested with the RealPresence Group device successfully for Teams A/V calls in an Exchange Online Calendar.

 

The Trio8800 we are testing has been factory reset with skype login information added, and setup as per Jeff Schertzs blog with an unregistered 2nd SIP line.

 

The SIP line is present in the web interface of the Trio8800 , I can have Teams meetings with audio only.

 

Two lines of config that appear to import successfully, but cannot be seen on the exported config are the ones below:

 

exchange.meeting.realConnectProcessing.outboundRegistration="2"
reg.2.keepalive.sessionTimers="1"

 

Config exported from Trio8800 VC

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<PHONE_CONFIG>
<!-- Note: The following parameters have been excluded from the export:
btoe.PairingCode=""
tcpIpApp.ice.password=""
tcpIpApp.ice.username=""
-->
<ALL
btoe.pairingMode="Manual"
call.teluri.showPrompt="0"
device.prov.serverName.set="1"
device.prov.ztpEnabled="0"
device.prov.ztpEnabled.set="1"
device.set="1"
dialplan.digitmap.lineSwitching.enable="1"
exchange.meeting.realConnectProcessing.teams.enabled="1"
exchange.server.url="https://outlook.office365.com/EWS/Exchange.asmx"
feature.EWSAutodiscover.enabled="0"
httpd.cfg.enabled="1"
httpd.enabled="1"
lcl.ml.lang="English_United_Kingdom"
log.level.change.afe="5"
log.level.change.auth="2"
log.level.change.curl="3"
log.level.change.nisvc="2"
log.level.change.proxy="2"
log.level.change.sip="0"
log.level.change.tls="0"
log.level.change.wad="2"
log.render.file.size="10240"
log.render.level="0"
lync.qos.dscpVoice="40"
powerSaving.idleTimeout.offHours="5"
powerSaving.idleTimeout.officeHours="15"
reg.limit="2"
system.name="VCName"
tcpIpApp.ice.turn.server="mediaedge1E.online.lync.com"
tcpIpApp.ice.turn.udpPort="3478"
tcpIpApp.port.rtp.lync.audioPortRangeEnd="50019"
tcpIpApp.port.rtp.lync.audioPortRangeStart="50000"
tcpIpApp.port.rtp.lync.contentPortRangeEnd="50059"
tcpIpApp.port.rtp.lync.contentPortRangeStart="50040"
tcpIpApp.port.rtp.lync.videoPortRangeEnd="50039"
tcpIpApp.port.rtp.lync.videoPortRangeStart="50020"
tcpIpApp.sntp.address="45.34.5.45"
tcpIpApp.sntp.olsonTimezoneID="Europe/London"
call.autoOffHook.2.contact="673879732@t.plcm.vc"
call.autoOffHook.2.enabled="1"
dialplan.2.applyToDirectoryDial="1"
dialplan.2.digitmap="^.+@t\.plcm\.vc$"
dialplan.2.digitmap.mode="regex"
dialplan.2.digitmap.timeOut="4"
dialplan.1.lyncDigitmap.timeOut="5"
mr.pair.uid.1="64167f2e3cb2"
msg.mwi.1.callBack="sip:VCName@companydomain.co.uk;opaque=app:voicemail"
msg.mwi.1.callBackMode="contact"
reg.1.address="VCName@companydomain.co.uk"
reg.2.address="VCNameTrio"
reg.1.auth.loginCredentialType="usernameAndPassword"
reg.1.ice.turn.callAdmissionControl.enabled="1"
reg.2.label="Teams Meeting"
reg.1.srtp.offer="1"
reg.2.srtp.offer="1"
reg.2.server.1.address="t.plcm.vc"
reg.2.server.1.register="0"
reg.2.server.1.transport="TCPpreferred"
/>
</PHONE_CONFIG>

 

Trio8800 Details

Phone Information
Phone Model Trio 8800
Part Number 3111-65290-001 Rev:A
MAC Address 64:16:7F:38:EB:05
Wi-Fi MAC Address 64:16:7F:38:EB:06
Bluetooth MAC Address 64:16:7F:38:EB:07
IP Mode IPv4
   
UC Software Version 5.9.4.7038
Updater Signature Release
Camera Name EagleEyeIVUSB
Camera Version 1.1.1-432
System Name VCName

 

Any pointers very welcome. I could try Factory reset again and go through the process.

Message 1 of 6
5 REPLIES 5
Highlighted
Occasional Advisor

Re: Polycom Trio8800 and setup for Teams AudioVideo calls

Hello,

The Trio 8800 cannot be used natively for Teams meetings

To join Teams meeting with Trio 8800, you need to subscribe to a CVI provider (like Polycom Realconnect cloud, Pexip teams gateway or Bluejans teams gateway)

 

Here the second line "VCName@companydomain.co.uk" is an example and you need to put your CVI provider information instead (if you have subscribed to it of course)

Message 2 of 6
Highlighted
Occasional Contributor

Re: Polycom Trio8800 and setup for Teams AudioVideo calls

Thank you for your quick response As it stands, we can make Teams audio calls, the idea was to setup a second SIP line on the Trio to do Teams video calls using Polycom RealConnect CVI The essential lines that the device is not porting are the ones below in order for this to work, particularly the first line.

exchange.meeting.realConnectProcessing.outboundRegistration="2" reg.2.keepalive.sessionTimers="1" 

Scratching my head as to what to do next. Or how I can check logs to see if it will give clues as to why it will not set these parameters, or if they are typed incorrectly.

Message 3 of 6
Highlighted
Frequent Advisor

Re: Polycom Trio8800 and setup for Teams AudioVideo calls

Hi @Polyphasic 

 

You can try referring to this article by Jeff Schertz.

http://blog.schertz.name/2019/08/poly-trio-with-microsoft-teams/ 

 

Search for part named "Hybrid mode" and just below there is some configuration for second line just like in your case.

 

I've also attached a template file exported from PDMS service, so you have a config ready to be modified.

Highlighted
Visitor

Re: Polycom Trio8800 and setup for Teams AudioVideo calls

Hi Polyphasic

 

we've the same situation and can't get video services running, while Audio works. Did you find a solution. As far as I've seen the responses are only leading to your initial configuration help from Jeff Schertzs blog - without any real solution.

Our settings are the same you described in your Mail.

 

 

Message 5 of 6
Highlighted
Polycom Employee & Community Manager

Re: Polycom Trio8800 and setup for Teams AudioVideo calls

Hello @aflexio_it ,

 

Welcome to the Poly Community.

The quickest way, if no other volunteer has any other ideas or configuration examples, would be to contact your Poly reseller.


In order to raise a support ticket, you need to work with your Poly reseller as they may need to do this for you.

End Customers are usually unable to open a ticket directly with Poly support. Available End User Poly services offerings are detailed here

If this is some sort of an Internet discounter providing your MAC address or your Poly devices serial will enable us to look up who would be able to support you. This may not be who you purchased the Poly device from.

If the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6