Plantronics + Polycom. Now together as Poly Logo

Studio X50 Keypad input issues

David@MeetingSpace
Occasional Contributor

Studio X50 Keypad input issues

There is a further issue when making a call with the keypad on a paired Trio C60

- when I select ‘call’, then ‘keypad' on the Trio C60, the only number that can be selected is ‘1’

- after selecting 1, all other keys will enter a letter (if I select any other key before 1 it shows as a letter not number)

- numbers are only available when multiple selections of the key is made

- keys are also very unresponsive, delete the most

Work around I’ve found

- to get to a numeric keypad, select ‘call’, select ’end’ or top left ‘back’ to display the onscreen keypad (the default is a box to enter a number only)

- select ‘keypad’ on Trio to show the touchscreen keypad, operates correctly (or navigate the onscreen keypad using arrows to enter numbers)

 

I would have expected, as a default, an onscreen window with keypad below (as per Group series)

 

If I select ‘recent calls’ or ‘contacts’ as the default screen, navigating to ‘keypad’ requires the same work around

Message 1 of 3
2 REPLIES 2
SteffenBaierUK
Polycom Employee & Community Manager

Re: Studio X50 Keypad input issues

Hello David@MeetingSpace ,

 

Welcome back to the Poly Community.


As we are unaware what software version is being used for either the Studio X50 or the connected Trio C60 please go ahead and open a support ticket with your Poly reseller.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 3
David@MeetingSpace
Occasional Contributor

Re: Studio X50 Keypad input issues

For info. the Studio X50 is on 3.2.3-280012, the C60 is on 7.0.0.4225

 

In addition, I experienced the same issue when using a Trio 8800, software 7.0.0.4229 and a Bluetooth remote FW: 97.

 

NB: before updating devices the issue was present, I had hoped the update would provide a fix, unfortunately not.

 

I have spoken to our UK support partner who has opened a ticket, just wondered whether there were any other users experiencing the same so that we may understand whether there is a fix.

 

Regards

 

David

Message 3 of 3