Plantronics + Polycom. Now together as Poly Logo

Studio X50 receiving video poor quality

Highlighted
Occasional Contributor

Studio X50 receiving video poor quality

Hi

 

We have problems with the video quality in Teams on the receiving video. The video we see from other participants is very poor and when they share content we can't hardly see it because it's very blurry. We have a 400Mbit/75Mbit dedicated just for this. When we join with a laptop there is no problems with the quality. We have connected a Philips 55" monitor.

 

Can anyone help?

Message 1 of 6
5 REPLIES 5
Highlighted
Polycom Employee & Community Manager

Re: Studio X50 receiving video poor quality

Hello @netit-cal  ,

 

Welcome to the Poly Community.

 

A good starting point to share with all of us would be the currently used software. In addition, the resolution is determined by the Teams Application running on the Studio X. Its an Android Software and the resolution can be low compared to a PC.

 

I suggest you work with our partner Microsoft on raising a ticket on this if you are already running the latest 3.2. software we recently released.

 

If this fails please open a ticket with our team directly.

 

Best regards

 

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 6
Highlighted
Occasional Contributor

Re: Studio X50 receiving video poor quality

Hi

 

We are using 3.2.

 

I'll open a ticket.

 

Regards

Casper

Message 3 of 6
Highlighted
Occasional Advisor

Re: Studio X50 receiving video poor quality

X50 with teams natif send 720p....1080p soon (december)

 

Its not an Android problem...just a restraint by Microsoft on its application

Message 4 of 6
Highlighted
Occasional Contributor

Re: Studio X50 receiving video poor quality

Hi

 

Ok, but when we only looks at our own camrea feed from the X50 before anyone joins the meeting (with fullscreen), then the quality is much better (not the best, there is room for improvement). But everything from other participants is really bad.

Message 5 of 6
Highlighted
Polycom Employee & Community Manager

Re: Studio X50 receiving video poor quality

Hello @netit-cal ,

 

Welcome back to the Poly Community.


This completely depends on the other participants and what Video they are sending / what the formally known AVMCU sends.

 

A video may look fine on a laptop screen but once you connect the Studio X running the Teams APK to a large screen the video from the other side can look bad if they only send a small video resolution.

 

Again I can only ask you to work directly with Microsoft as they have access to logs and statistics within the Microsoft TAC and can comment on the video rate and quality.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. My official "day" Job is 3rd Level support at Poly but I am unable to provide official support via the community.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 6