Plantronics + Polycom. Now together as Poly Logo

Unable to join Teams meetings on Studio X50

Simon
Occasional Advisor

Unable to join Teams meetings on Studio X50

Hi,

 

We have a Studio X50 and when it is setup from scratch everything works fine however there are times and the unit tends to stick like this that the unit will not join Teams calls as shown in the image I have uploaded.

 

Has anyone seen any messages like this please?

 

Regards

 

Simon

5 REPLIES 5
mshu
Respected Contributor

Re: Unable to join Teams meetings on Studio X50

Hi @Simon,

 

a bit more info would be appreciated. Which software version is installed? As we can see, you use Poly Mode, right? With RealConnect for joining Teams? Give us more info about your enviroment, else it is a look into a glas ball.

Message 2 of 6
Simon
Occasional Advisor

Re: Unable to join Teams meetings on Studio X50

Hi mshu,

 

Apologies for being a bit vague as I the  unit is in a different office. 

 

I was at this unit a couple of weeks ago and the Poly firmware was 3.3.2-286154. I see there is a further update of 3.4.0 but it does say not to use this firmware if in Teams mode which this X50 is in. 

 

What further info would you like please?

 

Regards

 

Simon

Message 3 of 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to join Teams meetings on Studio X50

Hello @Simon  ,

 

Welcome back to the Poly Community.


As already noted by @mshu  the unit, based on the attached screenshot, is not in Microsoft Teams mode. 

 

I would suggest you get this into our support organization as we may need a network trace and look at the logs.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------
The title Polycom Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 6
mshu
Respected Contributor

Re: Unable to join Teams meetings on Studio X50

Hi @ Simon,

 

as Steffen said, you are not in Teams mode, so you won´t be able to access any Teams meeting. If you run Poly mode (H.323/SIP) you will need a interop service like Poly RealConnect for example to bring in your device into the Teams world, because Microsoft Teams does not support H.323/SIP.

If you only use Teams for conferencing, switch the mode to Teams and you are intergrated to Teams directly. Ask you admins for support or for further info. 

 

Message 5 of 6
Simon
Occasional Advisor

Re: Unable to join Teams meetings on Studio X50

Hi Steffen,

 

I must apologise as I didn't notice it was in Poly mode and not in Teams mode. I wish people would stop playing around with settings. 

 

Thanks for pointing this out to me. I do feel quite embarrassed. It is a Monday

 

Cheers

 

Simon

 

 

Message 6 of 6