Plantronics + Polycom. Now together as Poly Logo

VSX 5000 some commands didn't work

SOLVED
Visitor

VSX 5000 some commands didn't work

Hello.


We have VSX 5000 and would like to control it by telnet. Polycom systems have rich command set, good. But some needed commands didn't work or I found them experimentally. I use the Integrator’s Reference Manual for the VSX Series v. 8.7.

 

1. "preset ..." command does not work at all, it call inner "PresetChangeNotify" with wrong params. I found preset functionality with "camera near preset <presetNum> set/go <any words there>", but IR control use other preset preferences/commands.
"camera near gotoPreset" from "shellHelp" doesn't work, too.


2. "camera <near|far> move <continuous|discrete>" command doesn't work, no such command.


3. "camera near <getposition|setposition “x” “y” “z”>" command doesn't work, no such command. But I found other command, "camera near moveto 1 pan tilt zoom", thanks to full debug mode by default (-_-').

4. "button <valid_button> [<valid_button> …]" doesn't work, it use only first parameter. Besides, I can't use preset by consistently calling "button preset" and "button 1".


5. Some commands with not full parameters set throw system reboot :)


6. And so on… I had to spend a significant amount of time searching for these pitfalls.

 

Trying different commands, I have learned to call all needed command but not preset, I can't save and clear preset and can go to preset only by using "camera near moveto".


I updated software by different versions, but it doesn't give effect. I use the last 9.0.6.2 version, 9.0.6 was initially.

 

There is some solution to use preset by telnet?

 

Thanks,

Sergey.

 

 



P.S. In all HDX 6000/7000 that we had, we never had such problems.

Message 1 of 6
1 ACCEPTED SOLUTION

Accepted Solutions
Frequent Advisor

Re: VSX 5000 some commands didn't work

Ok I have been beating this up for about an hour now, I have ERFL'd my system and loaded 9.0.6.2-103.

Using Putty > Telnet > Port 24 I am able to get these commands to work. I do see you are probably using port

23 as there is quite a bit of data in the Telnet trace you provided. I would try to use Port 24 and see if you get

different results. I have added two traces for you, one using 23 and the other 24 for reference.

View solution in original post

5 REPLIES 5
Frequent Advisor

Re: VSX 5000 some commands didn't work

Please see the attached screen shot of the VSX 8.7 IRM. The API for the presets do not specify having to use the word "Camera" in the command. For example if I want to use telnet for the camera to go to a set preset I would use:

preset near go 1

 

If I want to set a particular preset I would use:

 

preset near set 1

Visitor

Re: VSX 5000 some commands didn't work

Yes, I tried to use "preset near set 1", "preset near go 42" and even "preset far go 999", but as I wrote It doesn't work at all. System return something like "PresetChangeNotify error: wrong command parameters" (I could write an exact reply when I come to work).

I have never worked with Polycom systems before but my collegue has successfully worked with the HDX systems. And he also couldn't use commands from the manual to set preset or go to preset.

 

During research of the system, I found a way to bypass that strange behavior by useing system commands "config" or "sconfig". I get current position by command

->camera near position 1

If system return "100 100 7000" and I wish to set preset #8, I write preset param to system's flash memory by writing

-> config voicepresetpalmarley8 0 "100 100 7000 1"

But preset apply to system only after reboot... (Who is pal Marley and why voice preset? I don't know, but it works)

 

Maybe we have the system with test/developer configuration?

 

I may attach telnet log if my explanation is not enough.

 

 

P.S. Sorry for my poor english.

Message 3 of 6
Visitor

Re: VSX 5000 some commands didn't work

Model:               VSX 5000
Serial Number:       8210320B794DB7
Software Version:    Release 9.0.6.2-103 - 04Sep2011 21:27
Build Information:   ecommander on engint00.austin.polycom.com
FPGA Revision:       1.0.2b4
Main Processor:      BSP15   v0.0 ~ Core/Mem Clks 405/135  [3:4 0:3]

...

->preset near go 1
-><0> 06:29:27.584 D SYS  TERM      Audio: PresetChangeNotify incorrectly used!
->
->preset near set 1
->Audio: PresetChangeNotify incorrectly used!
->
->camera near move discrete
->
->camera near getposition
->CamMan[0]: ERROR unknown command
<0> 06:30:48.654 D (NOCAT)        (0)near (1)getposition
<0> 06:30:48.655 D (NOCAT)        
->
->button up left
->button down up telnet
<0> 06:31:33.743 D (NOCAT)        camera near position 1
-> Last Inquired PTZ position: Pan[115], Tilt[7], Zoom[4789] for pPositionRequestedCamera[1] = 12748a4 ...
<0> 06:32:04.164 D (NOCAT)        115 7 4789
->
->camera near setposition 50 60 7080
-><0> 12:38:11.416 D (NOCAT)        CamMan[0]: ERROR unknown command
<0> 12:38:11.416 D (NOCAT)        (0)near (1)setposition (2)50 (3)60 (4)7080 
<0> 12:38:11.417 D (NOCAT)        
->
->camera near moveto 1 60 70 8090
-><0> 12:36:46.300 D (NOCAT)         Entering CameraNearMovetoPTZPositionCmd() ...
<0> 12:36:46.301 D (NOCAT)         argc[6]  ...
<0> 12:36:46.301 D (NOCAT)         argv[0] = near ...
<0> 12:36:46.301 D (NOCAT)         argv[1] = moveto ...
<0> 12:36:46.301 D (NOCAT)         argv[2] = 1 ...
<0> 12:36:46.301 D (NOCAT)         argv[3] = 60 ...
<0> 12:36:46.301 D (NOCAT)         argv[4] = 70 ...
<0> 12:36:46.301 D (NOCAT)         argv[5] = 8090 ...
<0> 12:36:46.301 D (NOCAT)        CamMan[0]: CamManGetExactSelectedCamera: returning near camera
<0> 12:36:46.301 D (NOCAT)        NearCamera[1]: camera[12748a4] moves to PTZ position: Pan[60]--Tilt[70]--Zoom[8090]...
<0> 12:36:46.301 D (NOCAT)         Move pNearCamera[1] = 12748a4 to new PTZ position: Pan[60], Tilt[70], Zoom[8090] ...
<0> 12:36:46.302 D (NOCAT)        ### nearCameraIndex[1] -- newPanPos[60] newTiltPos[70] newZoomPos[8090] ...
<0> 12:36:46.302 D (NOCAT)        Entering CamManCameraNearPresetLogic() 
<0> 12:36:46.303 D (NOCAT)        zoomPresetPercent [70] 
<0> 12:36:46.303 D (NOCAT)        Current Camera Position -- CurrentPanPos[0] CurrentTiltPos[0] CurrentZoomPos[0] 
<0> 12:36:46.303 D (NOCAT)        For Marley executing the kCameraPresetBehaviourDefault behaviour .
<0> 12:36:46.303 D (NOCAT)        Leaving CamManCameraNearPresetLogic() 
<0> 12:36:46.303 D (NOCAT)        OrionCamera[0]: set focus to auto focus
<0> 12:36:46.303 D (NOCAT)        NearCamera[1]: zoom to position 0x1f9a
<0> 12:36:46.303 D (NOCAT)        #### OrionCameraZoomIn() ACTUALY DO IT ....
<0> 12:36:46.303 D (NOCAT)        @@@@@ AFTER ZOOM IN @@@@@: controlMsg[8] -- do_zoom[1] -- curZoomPos [8154] ...
<0> 12:36:46.304 D (NOCAT)        NearCamera[1]: zoom to 809.0 degrees field of view
<0> 12:36:46.304 D (NOCAT)        NearCamera[1]: camera pans to position 4.166667 degrees, tilt to position 4.861111 degrees
<0> 12:36:46.304 D (NOCAT)        $$$$$$$$$$$$$$ configuredPanSpeed[20] -- configuredTiltSpeed[16] ...
<0> 12:36:46.304 D (NOCAT)         Done with executed goto zoom ....
<0> 12:36:48.395 D (NOCAT)        NearCamera[1]: pan to position 6.0 degrees and tilt to position 7.0 degrees 
->
->camera near setposition 50 60 7080
-><0> 12:38:11.416 D (NOCAT)        CamMan[0]: ERROR unknown command
<0> 12:38:11.416 D (NOCAT)        (0)near (1)setposition (2)50 (3)60 (4)7080 
<0> 12:38:11.417 D (NOCAT)        
->
->camera near preset 1 goooooo!!!  I can write anything after "go" :)
->CamMan[0]: CamManGetExactSelectedCamera: returning near camera
<0> 12:49:21.746 D (NOCAT)        NearCamera[1]: camera moves to preset 1
<0> 12:49:21.746 D (NOCAT)        NearCamera[1]: zoom to position 0x1b58
<0> 12:49:21.747 D (NOCAT)        #### OrionCameraZoomOut() ACTUALY DO IT ....
<0> 12:49:21.747 D (NOCAT)        @@@@@ AFTER ZOOM OUT @@@@@: do_zoom[1] -- curZoomPos [6936] ...
<0> 12:49:21.747 D (NOCAT)        NearCamera[1]: zoom to 700.0 degrees field of view
<0> 12:49:21.747 D (NOCAT)        ### SENDING the pan-tilt position part of the goto preset command ...
<0> 12:49:21.747 D (NOCAT)        NearCamera[1]: camera pans to position 7.013889 degrees, tilt to position 7.083333 degrees
<0> 12:49:21.747 D (NOCAT)        $$$$$$$$$$$$$$ configuredPanSpeed[20] -- configuredTiltSpeed[16] ...
<0> 12:49:21.747 D (NOCAT)         Done with executed goto zoom ....
<0> 12:49:22.482 D (NOCAT)        #### OrionCameraTiltDown() ACTUALY DO IT ....
<0> 12:49:22.482 D (NOCAT)        NearCamera[1]: pan to position 10.1 degrees and tilt to position 10.2 degrees
<0> 12:49:22.482 D (NOCAT)        NearCamera[1]: move to preset 1
->
->camera near preset 1 set "20 150 6000 1"
-><0> 12:53:45.706 D (NOCAT)        CamMan[0]: CamManGetExactSelectedCamera: returning near camera
<0> 12:53:45.706 D (NOCAT)        NearCamera[1]: store camera preset 1
<0> 12:53:45.706 D SYS  NOTF      config voicepreset 1 "115 7 4789 1" rw
<0> 12:53:45.706 D (NOCAT)        NearCamera[1]: store preset
<0> 12:53:45.707 D (NOCAT)        

As you can see, "preset" and "camera near move discrete" commands don't work.

 

"camera near getposition" command doesn't work, "camera near position 1" works, but it returns PTZ do not match with the VSX 8.7 IRM (-880 <= pan <= 880, -300 <= tilt <= 300, 0 <= zoom <= 1023). Real PTZ scope: minimum zoom is 4789, locked tilt is 7, 7 <= pan <= 208; maximum zoom is 8181, 7 <= tilt <= 374, 7 <= pan <= 921. Pan and tilt scopes change linearly with zoom.

 

"camera near setposition" command doesn't work, too, but "camera near moveto 1 60 70 8090" works.

 

"camera near presetgo" command works, "camera near presetset" works incorrect. These commands exist but it's some other presets (IR control uses others) and there are only 31.

 

Message 4 of 6
Frequent Advisor

Re: VSX 5000 some commands didn't work

Ok I have been beating this up for about an hour now, I have ERFL'd my system and loaded 9.0.6.2-103.

Using Putty > Telnet > Port 24 I am able to get these commands to work. I do see you are probably using port

23 as there is quite a bit of data in the Telnet trace you provided. I would try to use Port 24 and see if you get

different results. I have added two traces for you, one using 23 and the other 24 for reference.

View solution in original post

Visitor

Re: VSX 5000 some commands didn't work

I'm sorry that didn't reply for a long time, was in urgent business trip.
It's really, using port 24 is helpful. All necessary commands work. Pity only that the real borders of PTZ position have to find out experimentally.
That's really strange, why port 23 works and why it works differently on VSX and HDX? This introduces a strong delusion.

 

Thank you very much for help, the problem appears solved.

Message 6 of 6