Plantronics + Polycom. Now together as Poly Logo

Workflow Server - Registrations from Group 500s fail every 4-6 hours

SOLVED
Highlighted
Regular Advisor

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

Its ok. I finally got an answer. Memory Leak. I was advised to do the following

 

The most important and relevant thing is that this WFS is configured on pass-through authentication mode. There is a memory leak bug in WFS for pass-through mode, and that is not fixed yet. See details in EN-154169.

Both items can cause Node.JS memory utilization to build up and eventually service can either restart or simply hang, requiring a manual restart.

The only option (workaround) at the moment is to ask the customer to enable delegated mode following the official documentation available here https://support.polycom.com/content/dam/polycom-support/products/uc-infrastructure-support/polycom-w...

  • create an Exchange enabled service account (pages 20-21);
  • grant this service account with Reviewer Rights permission to all 35 room mailboxes (pages 19-20);
  • configure WFS credentials accordingly (pages 28-29).

View solution in original post

Message 21 of 26
Highlighted
Regular Advisor

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

Wow, thank you.

 

Tier4 on my end couldn't come up with anything and kept pointing fingers at my config.

 

I assumed this would end up as a memory leak/throttling and require a SVC account with impersonation enabled.  Seems like the workaround is similar.

 

Really appreciate your follow-up information on this issue.  Good luck

Message 22 of 26
Highlighted
Polycom Employee & Community Manager

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

Hi @Sean.Stanley66 

 

I had provided the Siebel Ticket with information to this post and made the product manager aware so I am surprised that you have not had the correct feedback.

 

Best Regards

 

Steffen Baier

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 23 of 26
Highlighted
Regular Advisor

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

Hi Steffen,

 

Thanks for that.  Not receiving correct responses at all from support.

I had to escalate to my account manager.

Still not getting the correct support but I'm working through it.

 

I do feel that Polycom doesn't want our money and that's ok.

 

Thanks to this forum I get the help I need.

 

Sean

Message 24 of 26
Highlighted
Regular Advisor

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

You're welcome, best of luck!

Message 25 of 26
Highlighted
Regular Advisor

Re: Workflow Server - Registrations from Group 500s fail every 4-6 hours

Sean - just FYI, I have setup the credentials part of WFS with a service acct, had the service acct granted reviewer rights on the mailboxes and WFS has been up, peppy and pretty darn sweet for several days *GASP*

 

Additionally, the actual config screens and steps found in the document I posted a link to in the solution..is a tad different than the real deal so feel free to reply here if you get stuck

Message 26 of 26