Plantronics + Polycom. Now together as Poly Logo

Behavior for Polycom Phone

SOLVED
Highlighted
Occasional Visitor

Behavior for Polycom Phone

Hey,

 

We are using Polycom VVX400 with 5.4.3 firmware (S/N = 0004F2DD8084)

 

Current our setup is that, the Polycom phone will contantly register to 2 different SIP server (Failover Server). The phone will constantly sent REGISTER message to Server A and Server B.

 

If Server A is the Active Primary, and Server B is backup. Server B will reject the REGISTER message with 503 Service Unavailable. 

 

With this way, the phone will always know which server is the active primary server to sent the INVITE message to for call.

 

However, when we try to put the phone into DND status, the phone will sent the SUBSCRIBE message to the SIP server.

 

What happen here is that, when server A is still the active primary, the phone will be able to sent SUBSCRIBE message and getting response fine.

 

In the case of failover event and Server B took over, the phone is still sending the SUBSCRIBE message to server A (and get the response of 403 forbideen) eventhough Server A response to the phone's earlier REGISTER message with 503 message.

 

May I know, what response need to be receive by the Polycom phone for it to stop sending the SUBSCRIBE message to server A and sent the SUBSCRIBE message to the other server?

 

Regards,

kam

Message 1 of 5
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Polycom Employee & Community Manager

Re: Behavior for Polycom Phone

Hello Kam,

welcome to the Polycom Community.

First you are not using a currently supported software version like UC Software 5.6.0 or 5.5.2

 

Secondly we do not have any configuration so we are not able to confirm that you are using the correct template for your yet unknown SIP provider.

 

Checking your details and the MAC of the phone gives me the impression you are working for one of our service provider partners so I simply suggest you escalate this into Polycom support so we can work with you on this to verify we are not violating any RFC's.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 5
4 REPLIES 4
Highlighted
Polycom Employee & Community Manager

Re: Behavior for Polycom Phone

Hello Kam,

welcome to the Polycom Community.

First you are not using a currently supported software version like UC Software 5.6.0 or 5.5.2

 

Secondly we do not have any configuration so we are not able to confirm that you are using the correct template for your yet unknown SIP provider.

 

Checking your details and the MAC of the phone gives me the impression you are working for one of our service provider partners so I simply suggest you escalate this into Polycom support so we can work with you on this to verify we are not violating any RFC's.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

View solution in original post

Message 2 of 5
Highlighted
Occasional Visitor

Re: Behavior for Polycom Phone

Hey Steffen,

 

Thank you very much for your feedback.

 

 

I had proceed to raise a service request within the Polycom portal.

 

Thanks,

Kam

Message 3 of 5
Highlighted
Occasional Advisor

Re: Behavior for Polycom Phone

Was there an actual solution/outcome to this issue?

 

It seems the Polycom phones only send the SIP SUBSCRIBE message to the first sucessfully registered server (e.g. Server A) - regardless if that registration then changes (e.g. to Server B).

 

Is there a configuration setting to change the SUBCRIBE behaviour so it goes to all registered servers?

Message 4 of 5
Highlighted
Occasional Advisor

Re: Behavior for Polycom Phone

After some research, it appears to be "working as designed". According to the UC 5.7.0 Admin Guide (page 501-502):

 

Phone Operation for Registration
After the phone has booted up, it registers to all configured servers.
Server 1 is the primary server and supports greater SIP functionality than other servers.
For example, 
SUBSCRIBE/NOTIFY services used for features such as shared lines, presence, and BLF is established only with Server 1.

 

Therefore in example originally provided, by design, the SUBSCRIBE will never try/contact Server 2 (or Server B as referenced).

 

The Polycom guide suggests 'Recommended Practices for Fallback Deployments' is to "Educate users as to the features that are not available when in fallback operating mode."

Message 5 of 5