Plantronics + Polycom. Now together as Poly Logo

C100S and Windows 7

jpatterson
Occasional Visitor

Re: C100S and Windows 7

We have the same problem. We couldn't get it to work with the Win 7 installer. Just for kicks, we tried the WinXP driver. The installer for WinXP doesn't even check to see if it is the correct OS version. It fires through the installation on Windows 7 without even complaining! We can't get this software to work on any of our Windows 7 computers. The diagnostics complains that the C100S is not found. It will, however, let you toggle the LED after you dismiss the warning. It doesn't do the same for the microphone, unfortunately. Windows complains that there is an error in the INF file and doesn't load the driver. If anyone has found a solution to this, please let us know!

Message 11 of 12
jpatterson
Occasional Visitor

Re: C100S and Windows 7

Update:

 

Following the suggestion of a previous user and with a hint from a Polycom Employee here, I uninstalled and completely removed all traces of the program and drivers from the hard drive, startup and registry and did a windows driver cleanup and disabled the remaining Polycom mystery device that was listed in device manager. After all of that, the speaker and microphone work with Skype. The call and Skype buttons do not, but I can live with that. Better than having a $120 paperweight. We'll see if the noise cancellation is functioning or if that was a "feature" of the non-functioning driver that died with WinXP. Moral of the story, don't install the any Polycom software. 4 hours wasted. Last Polycom product for us.

Message 12 of 12