Plantronics + Polycom. Now together as Poly Logo

CAN´T UPGRADE POLYCOM 331

Occasional Advisor

CAN´T UPGRADE POLYCOM 331

Hello everyone

I´ll try to go to the point since my english is not very good

 

I´ve try to upgrade the phone via internet and local without any luck

First via internet with this server information <removed by a moderator>, after 100 trys the phone did not open web UI so I format the phone and now just say "Error , aplication is not present polycom"

so I have try to do it with FTP and TFTP and did not work either

I have downloaded from http://downloads.polycom.com/voice/voip/sip_sw_releases_matrix.html the release that I had on other phones (4.0.1.1) (Combined and Split) and downloaded the last release (4.0.14 1580) (Combined and Split)

 

I have try each one alone and together and nothing....

The app Im using for TFTP and FTP is MobaXterm

any Ideas?

Message 1 of 13
12 REPLIES 12
Polycom Employee & Community Manager

Re: CAN´T UPGRADE POLYCOM 331

Hello @Rommelotero ,

 

Welcome to the Poly Community.

Both the communities Must Read First and the FAQ reference the basic minimum information a new or follow up post should contain.

This ensures the questions having to be asked are limited and any new or follow up post contains the right amount of details to ensure any voluntary participant within the community does not spend additional time chasing basic information.

As a reminder the basic information asked for:

 

  • Provide the exact Software Version of your Phone
  • Provide the Phone Model
  • Provide the Call Platform (aka openSIP,Teams, Skype for Business Online, Skype for Business on Premise, Lync)
  • Provide details if UC / SIP or ObiEdition
  • Additional Poly Infrastructure (RPRM,PDMS or BToE)
  • If applicable provide a backup of the phone in question

UC Software 4.0.0 or later via the Web Interface Utilities > Phone Backup & Restore > Phone Backup > Phone Backup. Please rename into .TXT or Zip the file to attach.
Since UC Software 5.9.0 simply provide this via the Web Interface Diagnostics > Download Support Information Package

  • If possible provide a Log and either attach them or use the Code Tag.Consult the Troubleshooting Section found within the FAQ if applicable
  • If possible provide the MAC Address or Serial of the device
  • Provide details for example if the issue is a day 1 issue or only happened after an upgrade or any other relevant details
  • For questions around Support please check here

 

 

Whilst providing some of these details may not directly impact any possible answer the community can provide, it does enable Poly to have an overview of the current software used. In addition, providing all details at the same time allow us to check logs or look up potential support partners if an issue needs to come into support. It also enables us to verify the entitlement for using features.

 

You have neither provided us with Logs or details on what software you are currently running on the phone that fails.


Please ensure you always check the FAQ's and/or utilize the community search before posting any new topics or follow up posts.

 

Oct 7, 2011 Question: How can I setup my Phone / Provisioning / Download / Upgrade / Update / Downgrade Software?
Resolution: Please check => here <=

 

The above explains in detail how to upgrade a Phone especially from older 3.3.x software and has examples using Filezilla as a server.

 

I have removed the server address you provided as this is for Poly Support customers only and cannot handle any extra traffic.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 2 of 13
Occasional Advisor

Re: CAN´T UPGRADE POLYCOM 331

Hello Steffen that for the replay

 

I didn´t read de FAQ sorry for that however I did read that post that u mencioned and did not work either

 

I install filezila test it agaist my PC with telnet and was fine, when I try to connect the phone nothing not even logs on server that someone is trying

 

in the past I upgrade this phone from internet just with the address that u erase from my original post but now does not work either

 

I need some good advise please, just tell me exacly what to do. Right now phone reboots and does not start up so I can give u the sofware. again I explain that I format the hole phone, model is SoundPoint Polycom 330 and MAC 0004F22552F0

Message 3 of 13
Polycom Employee & Community Manager

Re: CAN´T UPGRADE POLYCOM 331

Hello @Rommelotero ,

 

you still have not provided us with the currently used software version. If the phone does not show any activity on your locally installed FTP then most likely a local firewall is the issue.

 

The same may be applicable if the external, not meant for the public, IP address no longer works.

 

I can see that 0004F22552F0 was sold via SCANSOURCE INC back in 03/09/2009 so it must have worked at some point.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 4 of 13
Occasional Advisor

Re: CAN´T UPGRADE POLYCOM 331

I was working but I took like 5 minutes to boot everytime, that change on the phones that I upgrade few years back so I decided to do the upgrade process


The phone was working on Elastix 2.5, now we are upgrading to Issabell and so far no problem with the rest ofphone, (good for me I just started to upgrade just 1 phone xD)


All the phones work fine, some with software 3.2 and others with 4.0.1.1


I manage to figure out FTP server problem but still is not doing the upgrade

 

Here log from filezile server:

000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> Connected on port 21, sending welcome message...
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> 220-FileZilla Server 0.9.60 beta
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> 220-written by Tim Kosse (tim.kosse@filezilla-project.org)
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> 220 Please visit https://filezilla-project.org/
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> USER test
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> 331 Password required for test
(000033)8/22/2019 13:03:49 PM - (not logged in) (172.20.5.10)> PASS
(000033)8/22/2019 13:03:49 PM - test (172.20.5.10)> 230 Logged on
(000033)8/22/2019 13:03:49 PM - test (172.20.5.10)> PWD
(000033)8/22/2019 13:03:49 PM - test (172.20.5.10)> 257 "/" is current directory.
(000033)8/22/2019 13:03:49 PM - test (172.20.5.10)> PASV
(000033)8/22/2019 13:03:49 PM - test (172.20.5.10)> 227 Entering Passive Mode (172,20,4,139,247,195)
(000033)8/22/2019 13:04:06 PM - test (172.20.5.10)> CWD /
(000033)8/22/2019 13:04:06 PM - test (172.20.5.10)> 250 CWD successful. "/" is current directory.
(000033)8/22/2019 13:04:06 PM - test (172.20.5.10)> PASV
(000033)8/22/2019 13:04:06 PM - test (172.20.5.10)> 227 Entering Passive Mode (172,20,4,139,232,108)
(000033)8/22/2019 13:04:42 PM - test (172.20.5.10)> CWD /
(000033)8/22/2019 13:04:42 PM - test (172.20.5.10)> 250 CWD successful. "/" is current directory.
(000033)8/22/2019 13:04:42 PM - test (172.20.5.10)> PASV
(000033)8/22/2019 13:04:42 PM - test (172.20.5.10)> 227 Entering Passive Mode (172,20,4,139,192,101)
(000033)8/22/2019 13:06:30 PM - test (172.20.5.10)> disconnected.
-----------------------------------------------------------------------------------------------

From another server I try FTP and TFTP, the last one generaste a boot log (attached) but basically if I understod well it says the file is missing

 

so I have downloaded 4.0.1.4 and 4.0.1.1 Both split and combined and tested the server each one and together and nothing

 

I notice that the 000000.cof file is missing the values of sip 330

 

<APPLICATION_SPIP320 APP_FILE_PATH_SPIP320="sip_335.ld" CONFIG_FILES_SPIP320=""/>
<APPLICATION_SPIP330 APP_FILE_PATH_SPIP330="sip_335.ld" CONFIG_FILES_SPIP330=""/>

 

could that be the problem? how can I solved it?

Polycom Employee & Community Manager

Re: CAN´T UPGRADE POLYCOM 331

Hello @Rommelotero ,

 

From the FAQ:

 

Updating to UCS 4.x.x:

 

If the phone is running an older Version of Software you will need to download the compatible UCS Version and in addition the BootROM 4.4.0 B Upgrader.

 

As an example download software version UCS 4.0.3 Rev F (or later) and BootROM 4.4.0 B Upgrader and unzip the content of both of the downloads into one directory.

 

You will then have to point the relevant Server (HTTP(s), FTP(s) or TFTP to the directory where the Software has been unzipped.

 

Before you can successfully install UC Software 4.x.x onto phones running Polycom® UCS released prior to version 4.0.0, you must perform a required upgrade procedure using the Polycom® Upgrader 4.0.0 Utility. 

Before you download and install Polycom® UC Software version 4.0.x or higher, Polycom strongly recommends that you review the changes to the upgrade procedures detailed in the Polycom® UC Software 4.0.0 Administrators’ Guide or newer and Engineering Advisory 64731 Polycom® UC Software 4.0.0: Upgrade and Downgrade Methods.

 

 

  • Do not make any changes to the downloaded 000000000000.cfg !

 

The phone will automatically download the right files.

 

I can see it is getting the files it needs:

 

0822164454|copy |3|00|'ftp://test:****@172.20.2.65/2345-12200-001.bootrom.ld' from '172.20.2.65'
0822164454|copy |4|00|Download of '2345-12200-001.bootrom.ld' FAILED on attempt 1 (addr 1 of 1)
0822164454|copy |4|00|Server '172.20.2.65' said '2345-12200-001.bootrom.ld' is not present
0822164454|cfg  |4|00|Could not get all 512 bytes of the header
0822164454|copy |3|00|'ftp://test:****@172.20.2.65/bootrom.ld' from '172.20.2.65'
0822164454|copy |4|00|Download of 'bootrom.ld' FAILED on attempt 1 (addr 1 of 1)
0822164454|copy |4|00|Server '172.20.2.65' said 'bootrom.ld' is not present
0822164454|cfg  |4|00|Could not get all 512 bytes of the header
0822164454|cfg  |3|00|bootROM file not present on boot server
0822164454|copy |3|00|'ftp://test:****@172.20.2.65/0004f22552f0.cfg' from '172.20.2.65'
0822164454|copy |4|00|Download of '0004f22552f0.cfg' FAILED on attempt 1 (addr 1 of 1)
0822164454|copy |4|00|Server '172.20.2.65' said '0004f22552f0.cfg' is not present
0822164454|copy |3|00|Update of '/ffs0/init.mac' failed, leaving local copy intact
0822164454|copy |3|00|'ftp://test:****@172.20.2.65/000000000000.cfg' from '172.20.2.65'
0822164454|copy |3|00|Download of '000000000000.cfg' succeeded on attempt 1 (addr 1 of 1)

But again you have not told us what software version is on the phone you are having issues with.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 6 of 13
Occasional Advisor

Re: CAN´T UPGRADE POLYCOM 331

how can i get the software version is the phone does not start up?

 

It was running this 3.2.1.0054.before I try to upgrade it

 

On the log u can see it says

 

0822164454|cfg  |3|00|bootROM file not present on boot server

 

means that is not present the file right? I download the following:

 

This is the version I have working on some of the phones where I did sometime ago and upgrade

  • Polycom_UC_Software_4_0_11_rts15_release_sig_combined.rar
  • Polycom_UC_Software_4_0_11_rts15_release_sig_split.rar

and this that are the last upgrade software available

  • Polycom-UC-Software-4.0.14-rts26-G-release-sig-combined.rar
  • Polycom-UC-Software-4.0.14-rts26-G-release-sig-split.rar

In none of those I see this file that is missing

 

I have not made changes on the 00000000.cfg file I just view it and notice that that is missing the info I mencioned

Message 7 of 13
Polycom Employee & Community Manager

Re: CAN´T UPGRADE POLYCOM 331

Hi @Rommelotero ,

 

you need:

 

Best Regards

 

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 8 of 13
Occasional Advisor

Re: CAN´T UPGRADE POLYCOM 331

Steffen thank you for your pacience

 

Still not working, phone says "Error application not present"

Message 9 of 13
Highlighted
Polycom Employee & Community Manager

Re: CAN´T UPGRADE POLYCOM 331

Hello @Rommelotero ,

 

you are not sharing any logs so we cannot help you.


As the unit is no longer within the warranty please be prepared to Pay Per Incident / PPI. This is all outlined in detail here

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier




<======== Signature / Disclaimer ========>
Please be aware:For questions about the type of support to expect please check here

Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Please remember, if you see a post that helped you , and it answers your question, please mark it as an "Accept as Solution".

The title Polycom Employee & Community Manager is an automatic setting within the community and any forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer.
Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and maybe answered on weekends, bank holidays or personal holidays.
Message 10 of 13