Plantronics + Polycom. Now together as Poly Logo

CX100 echo problems

SOLVED
Occasional Visitor

CX100 echo problems

I am running a CX100 with Microsoft Lync 2010 on a 64-bit Windows 7 platform.  The receivers on my calls (other CX-100s) all hear their echo when talking to me.  I don't have any problems on the sender end, and no other users seem to have this problem with their devices when talking to anyone except me.  I have tried turning off all other input/output devices, and turning the volume down to minimum levels, but to no avail.  Any suggestions on what to do?

Thanks, John.

Message 1 of 4
3 REPLIES 3
Occasional Visitor

Re: CX100 echo problems

Same problem - hope you get an answer soon!

Message 2 of 4
Occasional Visitor

Re: CX100 echo problems

SOLVED!  For some reason TTY mode was turned on.  I turned it off, restarted, and the echo went away!  The sound quality also improved!

 

Below is the Lync 2010 description of what can happen with TTY turned on:

 

"Text telephone (TTY) mode is used for text communication over a telephone line. A TTY device must be connected to the computer to interpret the modified audio; otherwise you might experience poor audio quality during the call. Using TTY mode in a conference call might also cause audio quality issues.

By default, TTY mode is turned off. You can turn on TTY mode by clicking Phones in the Lync - Options dialog box. You will then need to sign out of Lync 2010 and sign back in to use the feature."

Message 3 of 4
Occasional Visitor

Re: CX100 echo problems

I thought that this would solve the problems I have where other folks report terrible echo when I am using my Polycom speaker / microphone - unless it is muted or with headphones...

 

BUT the option is already turned off in my LYNC set-up, and they still report the terrible echo. :-(

 

Message 4 of 4